summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-13 19:47:57 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-13 19:47:57 +0000
commit7d87a60e2c13297e6afda15187c75da25e11cb12 (patch)
tree13d86946a2a9ccfcfb739dbaaf50c58242027894 /www-plugins
parentAdded the new armv4t-nanjit patch to stable xulrunner as well. (diff)
downloadhistorical-7d87a60e2c13297e6afda15187c75da25e11cb12.tar.gz
historical-7d87a60e2c13297e6afda15187c75da25e11cb12.tar.bz2
historical-7d87a60e2c13297e6afda15187c75da25e11cb12.zip
Add patch to respect LDFLAGS. Bug #332115. Thanks to Diego E. 'Flameeyes' Pettenò <flameeyes@gentoo.org> for reporting
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/lightspark/ChangeLog7
-rw-r--r--www-plugins/lightspark/Manifest5
-rw-r--r--www-plugins/lightspark/files/lightspark-0.4.3-cmakelists.patch44
-rw-r--r--www-plugins/lightspark/lightspark-0.4.3.ebuild6
4 files changed, 58 insertions, 4 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 4a3cf0cbd64b..16627bce9160 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.13 2010/08/12 10:03:42 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.14 2010/08/13 19:47:56 hwoarang Exp $
+
+ 13 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ lightspark-0.4.3.ebuild, +files/lightspark-0.4.3-cmakelists.patch:
+ Add patch to respect LDFLAGS. Bug #332115. Thanks to Diego E. 'Flameeyes'
+ Pettenò <flameeyes@gentoo.org> for reporting
*lightspark-0.4.3 (12 Aug 2010)
diff --git a/www-plugins/lightspark/Manifest b/www-plugins/lightspark/Manifest
index ac427ad35af8..e7f01b96bfa6 100644
--- a/www-plugins/lightspark/Manifest
+++ b/www-plugins/lightspark/Manifest
@@ -1,4 +1,5 @@
+AUX lightspark-0.4.3-cmakelists.patch 2352 RMD160 e247b7023effb5f8199b52f495ac3499490b2466 SHA1 6011a237fe1f601f988f9d8f97a7abe03d866a72 SHA256 00e9f0174f75be78781d9b502718d6f6e5654ce233a8c1c37835580c2698e5c0
DIST lightspark-0.4.3.tar.gz 253971 RMD160 36e1626a4223459a844a864cfb9fbefd910a9376 SHA1 f0e2f09dea7f66cbdeb4368156750fd81a71500a SHA256 ae443bc90c68cde5ca034f8f3bc29be1a5a35fd742dad674b56f4b3c9fb125ce
-EBUILD lightspark-0.4.3.ebuild 1893 RMD160 7b63205fe0d6ed765f6a741552730af3a2b92a25 SHA1 ddcb698e77ea1c10fa0aa2fc958417c88f48d136 SHA256 3d835796c834b59afd82725ec02837c371b4546a74819df78c9c1c909609c3b0
-MISC ChangeLog 2947 RMD160 20f623c98225dc2ee20b057aead85c0b0d0c61a6 SHA1 959754c7819999deac896e9d74afb971dcc36e5c SHA256 031c7548805b8069a95a032c300f635d949a1e5f9df15ac24705e98a11710985
+EBUILD lightspark-0.4.3.ebuild 1943 RMD160 c50f0780e316d1e043ef21859129ab75c375f3b5 SHA1 f2f421cf534de81ba53b41c4977dd4cbe2805dcd SHA256 8087863b65f72e9a58c2014f9c868a7f4a57b3012a777c2601ca4842693a8680
+MISC ChangeLog 3194 RMD160 c1681b2aaa47fdb075ae34c25c88febb9c1047db SHA1 2905643ed14e5416c4a11e991c48eeae7ba20dd6 SHA256 f967e48531811885ab8bb71ffd7e64b0d8b043f04e3dfd526117ee5e1dcd938e
MISC metadata.xml 275 RMD160 1b1d48ace7eb30ee16b7cd1c33dd9fa695817f08 SHA1 8e66ce36ba12401c927e1b7394b652962a979a52 SHA256 9fcd14bdea1cdbac9fa4d44a3c9728877d7b87266c3553f6519a7aaec9795009
diff --git a/www-plugins/lightspark/files/lightspark-0.4.3-cmakelists.patch b/www-plugins/lightspark/files/lightspark-0.4.3-cmakelists.patch
new file mode 100644
index 000000000000..f0f585dd580b
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.4.3-cmakelists.patch
@@ -0,0 +1,44 @@
+Index: lightspark-0.4.3/CMakeLists.txt
+===================================================================
+--- lightspark-0.4.3.orig/CMakeLists.txt
++++ lightspark-0.4.3/CMakeLists.txt
+@@ -199,7 +199,7 @@ ENDIF(${i386})
+ # liblightspark.so target
+ ADD_LIBRARY(spark SHARED ${LIBSPARK_SOURCES})
+ SET_TARGET_PROPERTIES(spark PROPERTIES OUTPUT_NAME lightspark)
+-TARGET_LINK_LIBRARIES(spark ${SOUND_LIBS_LIBRARIES} ${EXTRA_LIBS_LIBRARIES} ${ZLIB_LIBRARIES} ${LLVM_LIBS_CORE} ${LLVM_LIBS_JIT} ${SDL_LIBRARY} ${OPTIONAL_LIBRARIES} ${GTK_LIBRARIES} ${lib_glew})
++TARGET_LINK_LIBRARIES(spark ${CMAKE_MODULE_LINKER_FLAGS} ${SOUND_LIBS_LIBRARIES} ${EXTRA_LIBS_LIBRARIES} ${ZLIB_LIBRARIES} ${LLVM_LIBS_CORE} ${LLVM_LIBS_JIT} ${SDL_LIBRARY} ${OPTIONAL_LIBRARIES} ${GTK_LIBRARIES} ${lib_glew})
+ SET_TARGET_PROPERTIES(spark PROPERTIES LINK_FLAGS "${LLVM_LDFLAGS} -Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/lightspark.expmap")
+ SET_TARGET_PROPERTIES(spark PROPERTIES LINK_INTERFACE_LIBRARIES "")
+
+@@ -214,7 +214,7 @@ ENDIF(UNIX)
+ IF(COMPILE_LIGHTSPARK)
+ ADD_EXECUTABLE(lightspark main.cpp)
+ TARGET_LINK_LIBRARIES(lightspark spark)
+- TARGET_LINK_LIBRARIES(lightspark ${SDL_LIBRARY})
++ TARGET_LINK_LIBRARIES(lightspark ${SDL_LIBRARY} ${CMAKE_MODULE_LINKER_FLAGS})
+
+ IF(UNIX)
+ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lightspark.frag DESTINATION ${DATADIR}/lightspark)
+@@ -227,7 +227,7 @@ ENDIF(COMPILE_LIGHTSPARK)
+ # tightspark executable target
+ IF(COMPILE_TIGHTSPARK)
+ ADD_EXECUTABLE(tightspark tightspark.cpp)
+- TARGET_LINK_LIBRARIES(tightspark spark)
++ TARGET_LINK_LIBRARIES(tightspark spark ${CMAKE_MODULE_LINKER_FLAGS})
+
+ IF(UNIX)
+ INSTALL(TARGETS tightspark RUNTIME DESTINATION ${BINDIR})
+Index: lightspark-0.4.3/plugin-dir/CMakeLists.txt
+===================================================================
+--- lightspark-0.4.3.orig/plugin-dir/CMakeLists.txt
++++ lightspark-0.4.3/plugin-dir/CMakeLists.txt
+@@ -31,7 +31,7 @@ ENDIF(UNIX)
+
+ # Firefox plugin target
+ ADD_LIBRARY(lightsparkplugin SHARED np_entry.cpp npn_gate.cpp npp_gate.cpp plugin.cpp)
+-TARGET_LINK_LIBRARIES(lightsparkplugin spark ${MOZ_PLUGIN_LIBRARIES} ${GTK_LIBRARIES})
++TARGET_LINK_LIBRARIES(lightsparkplugin spark ${CMAKE_MODULE_LINKER_FLAGS} ${MOZ_PLUGIN_LIBRARIES} ${GTK_LIBRARIES})
+
+ IF(UNIX)
+ INSTALL(TARGETS lightsparkplugin LIBRARY DESTINATION ${PLUGIN_DIRECTORY})
diff --git a/www-plugins/lightspark/lightspark-0.4.3.ebuild b/www-plugins/lightspark/lightspark-0.4.3.ebuild
index b62634fd317e..695161c4f4a0 100644
--- a/www-plugins/lightspark/lightspark-0.4.3.ebuild
+++ b/www-plugins/lightspark/lightspark-0.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.3.ebuild,v 1.1 2010/08/12 10:03:42 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.3.ebuild,v 1.2 2010/08/13 19:47:56 hwoarang Exp $
EAPI=3
inherit cmake-utils nsplugins multilib
@@ -41,6 +41,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P/_rc*/}
+PATCHES=(
+ "${FILESDIR}"/${P}-cmakelists.patch
+)
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use nsplugin COMPILE_PLUGIN)