summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-30 10:16:37 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-30 10:16:37 +0000
commit690b865bcb72eb843e4a46291d463bd941e55059 (patch)
tree82d877878cadfe7b4e4bb5b743496e7df938f288 /www-client
parentHOMEPAGE and SRC_URI have been changed. (diff)
downloadhistorical-690b865bcb72eb843e4a46291d463bd941e55059.tar.gz
historical-690b865bcb72eb843e4a46291d463bd941e55059.tar.bz2
historical-690b865bcb72eb843e4a46291d463bd941e55059.zip
Version bumped.
Diffstat (limited to 'www-client')
-rw-r--r--www-client/dillo/ChangeLog7
-rw-r--r--www-client/dillo/Manifest10
-rw-r--r--www-client/dillo/dillo-0.8.3.ebuild126
-rw-r--r--www-client/dillo/files/digest-dillo-0.8.33
4 files changed, 141 insertions, 5 deletions
diff --git a/www-client/dillo/ChangeLog b/www-client/dillo/ChangeLog
index 83d704735f64..b1ffeffa24fe 100644
--- a/www-client/dillo/ChangeLog
+++ b/www-client/dillo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/dillo
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.2 2004/09/14 19:11:26 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.3 2004/10/30 10:16:37 usata Exp $
+
+*dillo-0.8.3 (30 Oct 2004)
+
+ 30 Oct 2004; Mamoru KOMACHI <usata@gentoo.org> +dillo-0.8.3.ebuild:
+ Version bumped.
14 Sep 2004; Stephen P. Becker <geoman@gentoo.org> dillo-0.8.2.ebuild:
Added ~mips keyword.
diff --git a/www-client/dillo/Manifest b/www-client/dillo/Manifest
index 64036b077e00..78ff3f391f66 100644
--- a/www-client/dillo/Manifest
+++ b/www-client/dillo/Manifest
@@ -1,8 +1,10 @@
-MD5 4f795eb065d1f730c3b2a59557a2688c dillo-0.8.2.ebuild 3504
MD5 32ce4bdd116a1cbc557cd41eebde0c77 dillo-0.8.0-r5.ebuild 3402
-MD5 1d6c625a8cdf0571597433b0b3501fb3 ChangeLog 8185
-MD5 3ff31b5479b2a0244f5711fff3155aed metadata.xml 221
+MD5 c1d993851d4217eb41556689c253556e dillo-0.8.3.ebuild 3469
MD5 7f2bb92ac717537bf6e4bf64e0d14243 dillo-0.7.3-r7.ebuild 3071
+MD5 b5911331d95e3e362cfc65010a500549 ChangeLog 8301
+MD5 3ff31b5479b2a0244f5711fff3155aed metadata.xml 221
+MD5 4f795eb065d1f730c3b2a59557a2688c dillo-0.8.2.ebuild 3504
MD5 999857d7ee9a88dd460d44fa95e5b9d5 files/digest-dillo-0.8.2 220
-MD5 95d879f408936b0b61006a6a55a3f68d files/digest-dillo-0.8.0-r5 226
+MD5 ba28c8a3ac90eda9150e386ab318bbcd files/digest-dillo-0.8.3 220
MD5 e257387d2c71e79a44b93b59e5240db3 files/digest-dillo-0.7.3-r7 226
+MD5 95d879f408936b0b61006a6a55a3f68d files/digest-dillo-0.8.0-r5 226
diff --git a/www-client/dillo/dillo-0.8.3.ebuild b/www-client/dillo/dillo-0.8.3.ebuild
new file mode 100644
index 000000000000..fcc0101c2f54
--- /dev/null
+++ b/www-client/dillo/dillo-0.8.3.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/dillo-0.8.3.ebuild,v 1.1 2004/10/30 10:16:37 usata Exp $
+
+inherit flag-o-matic eutils
+
+S2=${WORKDIR}/dillo-gentoo-extras-patch4
+DILLO_I18N_P="${P}-i18n-20041026"
+
+DESCRIPTION="Lean GTK+-based web browser"
+HOMEPAGE="http://www.dillo.org/"
+SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
+ mirror://gentoo/dillo-gentoo-extras-patch4.tar.bz2
+ http://teki.jpn.ph/pc/software/${DILLO_I18N_P}.diff.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~mips"
+#MISC_IUSE="nls truetype"
+IUSE="${MISC_IUSE} ipv6 ssl"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.3
+ >=media-libs/libpng-1.2.1
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ../${DILLO_I18N_P}.diff
+
+ if [ "${DILLO_ICONSET}" = "kde" ]
+ then
+ einfo "Using Konqueror style icon set"
+ cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "gnome" ]
+ then
+ einfo "Using Ximian style icon set"
+ cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "mozilla" ]
+ then
+ einfo "Using Netscape style icon set"
+ cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "cobalt" ]
+ then
+ einfo "Using Cobalt style icon set"
+ cp ${S2}/pixmaps.cobalt.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "bold" ]
+ then
+ einfo "Using bold style icon set"
+ cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "trans" ]
+ then
+ einfo "Using transparent style icon set"
+ cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "trad" ]
+ then
+ einfo "Using the traditional icon set"
+ cp ${S2}/pixmaps.trad.h ${S}/src/pixmaps.h
+ else
+ einfo "Using default Dillo icon set"
+ fi
+}
+
+src_compile() {
+ replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
+
+ local myconf
+
+ #myconf="$(use_enable nls)
+ # $(use_enable truetype anti-alias)
+ # --enable-tabs
+ # --enable-meta-refresh
+ # --enable-user-agent"
+
+ myconf="$(use_enable ipv6)
+ $(use_enable ssl)"
+
+ econf ${myconf} || die
+ emake || make || die
+}
+
+src_install() {
+ dodir /etc /usr/share/icons/${PN}
+ einstall || die
+
+ dosed /etc/dpidrc
+
+ dodoc AUTHORS COPYING ChangeLog* INSTALL README NEWS
+ docinto doc
+ dodoc doc/*.txt doc/README
+
+ cp ${S2}/icons/*.png ${D}/usr/share/icons/${PN}
+}
+
+pkg_postinst() {
+ einfo "This ebuild for dillo comes with different toolbar icons"
+ einfo "If you want mozilla style icons then try"
+ einfo " DILLO_ICONSET=\"mozilla\" emerge dillo"
+ einfo
+ einfo "If you prefer konqueror style icons then try"
+ einfo " DILLO_ICONSET=\"kde\" emerge dillo"
+ einfo
+ einfo "If you prefer ximian gnome style icons then try"
+ einfo " DILLO_ICONSET=\"gnome\" emerge dillo"
+ einfo
+ einfo "If you prefer cobalt style icons then try"
+ einfo " DILLO_ICONSET=\"cobalt\" emerge dillo"
+ einfo
+ einfo "If you prefer bold style icons then try"
+ einfo " DILLO_ICONSET=\"bold\" emerge dillo"
+ einfo
+ einfo "If you prefer transparent style icons then try"
+ einfo " DILLO_ICONSET=\"trans\" emerge dillo"
+ einfo
+ einfo "If you prefer the traditional icons then try"
+ einfo " DILLO_ICONSET=\"trad\" emerge dillo"
+ einfo
+ einfo "If the DILLO_ICONSET variable is not set, you will get the"
+ einfo "default iconset"
+ einfo
+ einfo "To see what the icons look like, please point your browser to:"
+ einfo "http://dillo.auriga.wearlab.de/Icons/"
+ einfo
+}
diff --git a/www-client/dillo/files/digest-dillo-0.8.3 b/www-client/dillo/files/digest-dillo-0.8.3
new file mode 100644
index 000000000000..264195b24182
--- /dev/null
+++ b/www-client/dillo/files/digest-dillo-0.8.3
@@ -0,0 +1,3 @@
+MD5 be772ec9361bcc01515ae0da61de9bda dillo-0.8.3.tar.bz2 418714
+MD5 0d0bc7cdd39dc66b80280f73d74bfeaf dillo-gentoo-extras-patch4.tar.bz2 98800
+MD5 f7eeb66e82940694b77bab0ab5497bad dillo-0.8.3-i18n-20041026.diff.bz2 21539