summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-10-28 15:12:07 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-10-28 15:12:07 +0000
commitf923cd094ad1c036f7051ab14fd6ca495a277eca (patch)
treef4c10f76b50fbbeae90d4fdd19a4ef3ac58f3528 /www-client/firefox/files
parentStable on amd64 wrt bug #342897 (diff)
downloadhistorical-f923cd094ad1c036f7051ab14fd6ca495a277eca.tar.gz
historical-f923cd094ad1c036f7051ab14fd6ca495a277eca.tar.bz2
historical-f923cd094ad1c036f7051ab14fd6ca495a277eca.zip
Readded latest stable sparc version which I foolishly removed from the tree.
Package-Manager: portage-2.2.0_alpha2/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'www-client/firefox/files')
-rw-r--r--www-client/firefox/files/137-bz460917_reload_new_plugins-gentoo-update-3.6.4.patch60
-rw-r--r--www-client/firefox/files/801-enable-x86_64-tracemonkey.patch25
-rw-r--r--www-client/firefox/files/firefox-3.0-solaris64.patch14
-rw-r--r--www-client/firefox/files/xulrunner-1.9.2-arm-fixes.patch35
4 files changed, 134 insertions, 0 deletions
diff --git a/www-client/firefox/files/137-bz460917_reload_new_plugins-gentoo-update-3.6.4.patch b/www-client/firefox/files/137-bz460917_reload_new_plugins-gentoo-update-3.6.4.patch
new file mode 100644
index 000000000000..5d0c93c3dea0
--- /dev/null
+++ b/www-client/firefox/files/137-bz460917_reload_new_plugins-gentoo-update-3.6.4.patch
@@ -0,0 +1,60 @@
+This patch has been ported to 3.6.4, may not be entirely correct.
+
+Original patch was from bmo 460917, att 350845
+
+---
+--- browser/base/content/browser.js
++++ browser/base/content/browser.js
+@@ -6009,9 +6009,18 @@
+ var pluginInfo = getPluginInfo(aEvent.target);
+ missingPluginsArray[pluginInfo.mimetype] = pluginInfo;
+
++
++ gBrowser.selectedBrowser.addEventListener("NewPluginInstalled",
++ gMissingPluginInstaller.refreshBrowser,
++ false);
++
+ openDialog("chrome://mozapps/content/plugins/pluginInstallerWizard.xul",
+ "PFSWindow", "chrome,centerscreen,resizable=yes",
+ {plugins: missingPluginsArray, browser: gBrowser.selectedBrowser});
++
++ gBrowser.selectedBrowser.removeEventListener("NewPluginInstalled",
++ gMissingPluginInstaller.refreshBrowser,
++ false);
+ },
+
+ // Callback for user clicking on a disabled plugin
+@@ -6107,11 +6116,19 @@
+ function showPluginsMissing() {
+ // get the urls of missing plugins
+ var missingPluginsArray = gBrowser.selectedBrowser.missingPlugins;
++
++ gBrowser.selectedBrowser.addEventListener("NewPluginInstalled",
++ gMissingPluginInstaller.refreshBrowser,
++ false);
++
+ if (missingPluginsArray) {
+ window.openDialog("chrome://mozapps/content/plugins/pluginInstallerWizard.xul",
+ "PFSWindow", "chrome,centerscreen,resizable=yes",
+ {plugins: missingPluginsArray, browser: gBrowser.selectedBrowser});
+ }
++ gBrowser.selectedBrowser.removeEventListener("NewPluginInstalled",
++ gMissingPluginInstaller.refreshBrowser,
++ false);
+ }
+
+ if (aEvent.type == "PluginBlocklisted") {
+@@ -6442,6 +6459,13 @@
+ notificationBox.removeNotification(notification);
+ }
+ // reload the browser to make the new plugin show.
++
++ // reload plugins
++ var pm = Components.classes["@mozilla.org/plugin/manager;1"]
++ .getService(Components.interfaces.nsIPluginManager);
++ pm.reloadPlugins(false);
++
++ // ... and reload the browser to activate new plugins available
+ browser.reload();
+ }
+ };
diff --git a/www-client/firefox/files/801-enable-x86_64-tracemonkey.patch b/www-client/firefox/files/801-enable-x86_64-tracemonkey.patch
new file mode 100644
index 000000000000..b72ad76b450e
--- /dev/null
+++ b/www-client/firefox/files/801-enable-x86_64-tracemonkey.patch
@@ -0,0 +1,25 @@
+--- js/src/configure.in.old 2009-11-08 19:50:54.299642792 -0500
++++ js/src/configure.in 2009-11-08 19:57:49.235621814 -0500
+@@ -2465,6 +2465,10 @@
+ ENABLE_JIT=1
+ NANOJIT_ARCH=i386
+ ;;
++x86_64*-*)
++ ENABLE_JIT=1
++ NANOJIT_ARCH=X64
++ ;;
+ arm*-*)
+ ENABLE_JIT=1
+ NANOJIT_ARCH=ARM
+@@ -2488,7 +2492,10 @@
+ i?86-*)
+ AC_DEFINE(AVMPLUS_IA32)
+ ;;
+-
++x86_64*-*)
++ AC_DEFINE(AVMPLUS_AMD64)
++ AC_DEFINE(AVMPLUS_64BIT)
++ ;;
+ arm*-*)
+ AC_DEFINE(AVMPLUS_ARM)
+ ;;
diff --git a/www-client/firefox/files/firefox-3.0-solaris64.patch b/www-client/firefox/files/firefox-3.0-solaris64.patch
new file mode 100644
index 000000000000..988b280f67ca
--- /dev/null
+++ b/www-client/firefox/files/firefox-3.0-solaris64.patch
@@ -0,0 +1,14 @@
+Don't use -G, it results in a relocation error against _DYNAMIC on
+amd64, use -shared instead per the manpage, and as it works as well.
+
+--- configure.in
++++ configure.in
+@@ -2481,7 +2481,7 @@
+ AC_LANG_RESTORE
+ else
+ ASFLAGS="$ASFLAGS -fPIC"
+- DSO_LDOPTS='-G'
++ DSO_LDOPTS='-shared'
+ _WARNINGS_CFLAGS=''
+ _WARNINGS_CXXFLAGS=''
+ if test "$OS_RELEASE" = "5.3"; then
diff --git a/www-client/firefox/files/xulrunner-1.9.2-arm-fixes.patch b/www-client/firefox/files/xulrunner-1.9.2-arm-fixes.patch
new file mode 100644
index 000000000000..a726209e6373
--- /dev/null
+++ b/www-client/firefox/files/xulrunner-1.9.2-arm-fixes.patch
@@ -0,0 +1,35 @@
+Fix arm OS detection
+
+https://bugs.gentoo.org/327783
+https://bugzilla.mozilla.org/show_bug.cgi?id=577319
+---
+--- configure.in
++++ configure.in
+@@ -1424,9 +1424,11 @@
+ CPU_ARCH="$OS_TEST"
+ ;;
+
+-arm)
++arm*)
+ if test "$OS_TARGET" = "WINCE"; then
+ CPU_ARCH="$OS_TEST"
++ else
++ CPU_ARCH="arm"
+ fi
+ ;;
+ esac
+--- js/src/configure.in
++++ js/src/configure.in
+@@ -1162,9 +1162,11 @@
+ CPU_ARCH="$OS_TEST"
+ ;;
+
+-arm)
++arm*)
+ if test "$OS_TARGET" = "WINCE"; then
+ CPU_ARCH="$OS_TEST"
++ else
++ CPU_ARCH="arm"
+ fi
+ ;;
+ esac