summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-06-18 00:36:20 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-06-18 00:36:20 +0000
commitc03fe174c4ec6992204ed3370ae66a42969774c7 (patch)
treec9d508d1bfb7d4844380ae1bbda11393527d640f /www-apps/mambo
parentBug 137118 - PDEPENDing the deps we dropped since they do add post installed ... (diff)
downloadhistorical-c03fe174c4ec6992204ed3370ae66a42969774c7.tar.gz
historical-c03fe174c4ec6992204ed3370ae66a42969774c7.tar.bz2
historical-c03fe174c4ec6992204ed3370ae66a42969774c7.zip
Version bump, security bug #130584.
Package-Manager: portage-2.1
Diffstat (limited to 'www-apps/mambo')
-rw-r--r--www-apps/mambo/ChangeLog8
-rw-r--r--www-apps/mambo/files/digest-mambo-4.5.43
-rw-r--r--www-apps/mambo/mambo-4.5.4.ebuild45
3 files changed, 55 insertions, 1 deletions
diff --git a/www-apps/mambo/ChangeLog b/www-apps/mambo/ChangeLog
index 9a85186f693d..75c9c8632344 100644
--- a/www-apps/mambo/ChangeLog
+++ b/www-apps/mambo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mambo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.22 2006/04/29 22:19:32 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.23 2006/06/18 00:36:20 rl03 Exp $
+
+*mambo-4.5.4 (18 Jun 2006)
+
+ 18 Jun 2006; Renat Lumpau <rl03@gentoo.org> -mambo-4.5.3h_p1.ebuild,
+ +mambo-4.5.4.ebuild:
+ Version bump, security bug #130584.
*mambo-4.5.3h_p1 (29 Apr 2006)
diff --git a/www-apps/mambo/files/digest-mambo-4.5.4 b/www-apps/mambo/files/digest-mambo-4.5.4
new file mode 100644
index 000000000000..ad7e87ea748d
--- /dev/null
+++ b/www-apps/mambo/files/digest-mambo-4.5.4
@@ -0,0 +1,3 @@
+MD5 5e475aa284c05bcae4b3966ca47f9d35 mambov4.5.4.tar.gz 1911335
+RMD160 c25d39ba00d78078dd28eb824e6808d8e76995f0 mambov4.5.4.tar.gz 1911335
+SHA256 4845095dce71fc82e5df7c8ba9743e494aefab40672c8507978b6d4b76f9bd9b mambov4.5.4.tar.gz 1911335
diff --git a/www-apps/mambo/mambo-4.5.4.ebuild b/www-apps/mambo/mambo-4.5.4.ebuild
new file mode 100644
index 000000000000..82613aa3c002
--- /dev/null
+++ b/www-apps/mambo/mambo-4.5.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/mambo-4.5.4.ebuild,v 1.1 2006/06/18 00:36:20 rl03 Exp $
+
+inherit webapp depend.php
+
+MY_PN="${PN/m/M}"
+DESCRIPTION="Mambo is yet another CMS"
+HOMEPAGE="http://www.mamboserver.com/"
+SRC_URI="http://mamboxchange.com/frs/download.php/7877/${PN}v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+S=${WORKDIR}
+
+IUSE="mysql"
+
+RDEPEND="mysql? ( dev-db/mysql )
+ virtual/httpd-php
+ net-www/apache"
+
+pkg_setup () {
+ webapp_pkg_setup
+ require_php_with_use mysql zlib
+}
+
+src_install () {
+ webapp_src_preinst
+ local files="administrator/backups administrator/components components
+ images images/banners images/stories mambots mambots/content mambots/search
+ media language administrator/modules administrator/templates cache modules
+ templates"
+
+ dodoc CHANGELOG.php INSTALL.php README
+
+ cp -R [^d]* ${D}/${MY_HTDOCSDIR}
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}