summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2005-02-17 00:16:25 +0000
committerLim Swee Tat <st_lim@gentoo.org>2005-02-17 00:16:25 +0000
commit2cb16ecd6ef57473b09bb5adc42a0ab8682dbc6a (patch)
treed063e0d6ef3745659b41949fdafdadf9a765542a /www-apps/dspam-web
parentVersion bumped (diff)
downloadhistorical-2cb16ecd6ef57473b09bb5adc42a0ab8682dbc6a.tar.gz
historical-2cb16ecd6ef57473b09bb5adc42a0ab8682dbc6a.tar.bz2
historical-2cb16ecd6ef57473b09bb5adc42a0ab8682dbc6a.zip
Version bumped.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'www-apps/dspam-web')
-rw-r--r--www-apps/dspam-web/ChangeLog5
-rw-r--r--www-apps/dspam-web/Manifest4
-rw-r--r--www-apps/dspam-web/dspam-web-3.4_beta3.ebuild165
-rw-r--r--www-apps/dspam-web/files/digest-dspam-web-3.4_beta31
4 files changed, 173 insertions, 2 deletions
diff --git a/www-apps/dspam-web/ChangeLog b/www-apps/dspam-web/ChangeLog
index a90977550bec..9313faf8d7c0 100644
--- a/www-apps/dspam-web/ChangeLog
+++ b/www-apps/dspam-web/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-apps/dspam-web
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/ChangeLog,v 1.13 2005/02/14 04:49:38 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/ChangeLog,v 1.14 2005/02/17 00:16:25 st_lim Exp $
+
+ 17 Feb 2005; Lim Swee Tat <st_lim@gentoo.org> :
+ Version bump
*dspam-web-3.4_beta2 (14 Feb 2005)
diff --git a/www-apps/dspam-web/Manifest b/www-apps/dspam-web/Manifest
index 4ecb43d2e4f4..366fead37fc1 100644
--- a/www-apps/dspam-web/Manifest
+++ b/www-apps/dspam-web/Manifest
@@ -1,14 +1,16 @@
-MD5 2710dd9c1bbdcd38f498fd66aeb61d04 ChangeLog 2372
+MD5 ee2bcd460d849b9822eb7a72f4eed2c3 ChangeLog 2438
MD5 200f508058004a98dd2c61761111d363 dspam-web-3.2.4.ebuild 5213
MD5 fa757721b552f847cd14d1a15885e622 dspam-web-3.3.11.ebuild 4963
MD5 02b8d404199d28d7c1c185280ced86a8 dspam-web-3.3.8.ebuild 5213
MD5 f1ea445d6b4ddf81c55a4e886bc04218 metadata.xml 341
MD5 015276e9399597459156c822f5c004f2 dspam-web-3.4_beta1.ebuild 4977
MD5 a1613f88505ca2763a8f14b330104afb dspam-web-3.4_beta2.ebuild 4977
+MD5 69f06996690d3ccb8322ad45bcc76b00 dspam-web-3.4_beta3.ebuild 4977
MD5 b59703cc943f7df3ca77763cc47c59f9 files/digest-dspam-web-3.3.11 64
MD5 ffdfc8d816078f4c58b75b9bed07503f files/htaccess 135
MD5 b4099a94a52af9abd4ade48d82914c3c files/htpasswd 19
MD5 4dea50acb83ec9cac74817c0ef84a07c files/digest-dspam-web-3.4_beta1 68
MD5 d2381c80ba8701cbb0711cdaab5d388d files/digest-dspam-web-3.4_beta2 68
+MD5 6f429af99757058b5a6a1019e10e0cfe files/digest-dspam-web-3.4_beta3 68
MD5 ea56d34fd80be48f9b308655b5620c2f files/digest-dspam-web-3.2.4 63
MD5 ad704c9a2372dd9ab4d112a8c687873e files/digest-dspam-web-3.3.8 63
diff --git a/www-apps/dspam-web/dspam-web-3.4_beta3.ebuild b/www-apps/dspam-web/dspam-web-3.4_beta3.ebuild
new file mode 100644
index 000000000000..3b7fb7d043a1
--- /dev/null
+++ b/www-apps/dspam-web/dspam-web-3.4_beta3.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/dspam-web-3.4_beta3.ebuild,v 1.1 2005/02/17 00:16:25 st_lim Exp $
+
+inherit webapp eutils
+
+MY_PN=${PN/-web/}
+MY_PV=${PV/_beta/.beta.}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="Web based administration and user controls for dspam"
+SRC_URI="http://dspam.nuclearelephant.com/sources/${MY_P}.tar.gz"
+
+HOMEPAGE="http://dspam.nuclearelephant.com/"
+LICENSE="GPL-2"
+DEPEND=">=mail-filter/dspam-3.2_rc3
+ >=net-www/apache-1.3
+ >=dev-lang/perl-5.8.2
+ >=dev-perl/GD-2.0
+ dev-perl/GD-Graph3d
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil"
+KEYWORDS="~x86 ~ppc"
+S=${WORKDIR}/${MY_P}
+HOMEDIR=/etc/mail/dspam
+
+src_compile() {
+ local myconf
+
+ # these are the default settings
+ #myconf="${myconf} --enable-daemon"
+ #myconf="${myconf} --enable-nodalcore"
+ myconf="${myconf} --enable-homedir"
+ myconf="${myconf} --enable-long-username"
+ myconf="${myconf} --enable-robinson"
+ #myconf="${myconf} --enable-chi-square"
+ #myconf="${myconf} --enable-robinson-pvalues"
+ use large-domain && myconf="${myconf} --enable-large-scale" ||\
+ myconf="${myconf} --enable-domain-scale"
+
+ myconf="${myconf} --with-dspam-mode=4755"
+ myconf="${myconf} --with-dspam-owner=dspam"
+ myconf="${myconf} --with-dspam-group=dspam"
+ myconf="${myconf} --with-dspam-home=${HOMEDIR} --sysconfdir=${HOMEDIR}"
+ myconf="${myconf} --with-logdir=${LOGDIR}"
+
+ use debug && myconf="${myconf} --enable-debug --enable-verbose-debug"
+
+ # select storage driver
+ if use mysql || use mysql41; then
+ myconf="${myconf} --with-storage-driver=mysql_drv"
+ myconf="${myconf} --with-mysql-includes=/usr/include/mysql"
+ myconf="${myconf} --with-mysql-libraries=/usr/lib/mysql"
+ myconf="${myconf} --with-client-compression"
+ myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
+
+ # an experimental feature available with MySQL and PgSQL backend
+ if use neural ; then
+ myconf="${myconf} --enable-neural-networking"
+ fi
+ elif use postgres ; then
+ myconf="${myconf} --with-storage-driver=pgsql_drv"
+ myconf="${myconf} --with-pgsql-includes=/usr/include/postgresql"
+ myconf="${myconf} --with-pgsql-libraries=/usr/lib/postgresql"
+ myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
+
+ # an experimental feature available with MySQL and PgSQL backend
+ if use neural ; then
+ myconf="${myconf} --enable-neural-networking"
+ fi
+ elif use oci8 ; then
+ myconf="${myconf} --with-storage-driver=ora_drv"
+ myconf="${myconf} --with-oracle-home=${ORACLE_HOME}"
+ myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
+
+ # I am in no way a Oracle specialist. If someone knows
+ # how to query the version of Oracle, then let me know.
+ if (expr ${ORACLE_HOME/*\/} : 10 1>/dev/null 2>&1)
+ then
+ --with-oracle-version=MAJOR
+ myconf="${myconf} --with-oracle-version=10"
+ fi
+ elif use sqlite ; then
+ myconf="${myconf} --with-storage-driver=sqlite_drv"
+ myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
+
+ else
+ myconf="${myconf} --with-storage-driver=libdb4_drv"
+ fi
+
+ econf ${myconf} || die
+ cd ${S}/cgi
+ make
+}
+
+src_install () {
+ cd ${S}/cgi
+ webapp_src_preinst
+
+ sed -e 's,/var/dspam,/etc/mail/dspam,' \
+ -e 's,/usr/local,/usr,' \
+ -i admin.cgi
+ sed -e 's,/var/dspam,/etc/mail/dspam,' \
+ -e 's,/usr/local,/usr,' \
+ -i dspam.cgi
+
+ insinto ${MY_HTDOCSDIR}
+ insopts -m644 -o apache -g apache
+ doins *.css
+ doins *.gif
+ doins rgb.txt
+ doins default.prefs
+ doins admins
+ doins configure.pl
+
+ newins ${FILESDIR}/htaccess .htaccess
+ newins ${FILESDIR}/htpasswd .htpasswd
+
+ insopts -m755 -o apache -g apache
+ doins *.cgi
+
+ for CGI_SCRIPT in admin.cgi admingraph.cgi dspam.cgi graph.cgi; do
+ webapp_runbycgibin perl ${MY_HTDOCSDIR}/${CGI_SCRIPT}
+ done
+
+ dodir ${MY_HTDOCSDIR}/templates
+
+ insinto ${MY_HTDOCSDIR}/templates
+ doins templates/*.html
+
+ #All files must be owned by server
+ cd ${D}${MY_HTDOCSDIR}
+ for x in `find . -type f -print` ; do
+ webapp_serverowned ${MY_HTDOCSDIR}/$x
+ done
+
+ webapp_src_install
+}
+
+pkg_config () {
+ # add apache to the dspam group so the CGIs can access the data
+
+ local groups
+ groups=`groups apache`
+ groups=`echo ${groups} | sed -e 's/ /,/g'`
+ usermod -G "${groups},dspam" apache
+}
+
+pkg_postinst () {
+ einfo "The CGIs need to be executed as group dspam in order to write"
+ einfo "to the dspam data directory. You will need to configure apache"
+ einfo "manually to do this. Another option is to add the user apache"
+ einfo "to the dspam group. You can do this automatically by running:"
+ echo
+ einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ echo
+ einfo "This app requires basic auth in order to operate properly."
+ einfo "You will need to add dspam users to the .htpasswd file or"
+ einfo "configure a different authentication mechanism for the user"
+ einfo "accounts."
+}
diff --git a/www-apps/dspam-web/files/digest-dspam-web-3.4_beta3 b/www-apps/dspam-web/files/digest-dspam-web-3.4_beta3
new file mode 100644
index 000000000000..54357c255bd8
--- /dev/null
+++ b/www-apps/dspam-web/files/digest-dspam-web-3.4_beta3
@@ -0,0 +1 @@
+MD5 ab4850dd7474fdf4dbc4878784eccf30 dspam-3.4.beta.3.tar.gz 676547