summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-24 05:43:53 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-24 05:43:53 +0000
commit2222eaea28f62d41c0580df129942c6c528a72b2 (patch)
tree9dc9d272b9f89e0b4070424e4e63743775dc73e7 /sys-process/lsof/lsof-4.84-r1.ebuild
parentInherit eutils for epatch, and user for enewuser/etc... (diff)
downloadhistorical-2222eaea28f62d41c0580df129942c6c528a72b2.tar.gz
historical-2222eaea28f62d41c0580df129942c6c528a72b2.tar.bz2
historical-2222eaea28f62d41c0580df129942c6c528a72b2.zip
Move to usex() from eutils.eclass.
Package-Manager: portage-2.2.0_alpha107_p3/cvs/Linux x86_64
Diffstat (limited to 'sys-process/lsof/lsof-4.84-r1.ebuild')
-rw-r--r--sys-process/lsof/lsof-4.84-r1.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/sys-process/lsof/lsof-4.84-r1.ebuild b/sys-process/lsof/lsof-4.84-r1.ebuild
index 33d05a802b7a..bb2abc241deb 100644
--- a/sys-process/lsof/lsof-4.84-r1.ebuild
+++ b/sys-process/lsof/lsof-4.84-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.84-r1.ebuild,v 1.2 2012/04/23 16:06:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.84-r1.ebuild,v 1.3 2012/05/24 05:43:53 vapier Exp $
EAPI="2"
-inherit flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs eutils
MY_P=${P/-/_}
DESCRIPTION="Lists open files for running Unix processes"
@@ -39,7 +39,6 @@ src_prepare() {
Configure || die
}
-usex() { use $1 && echo ${2:-yes} || echo ${3:-no} ; }
target() { usex kernel_FreeBSD freebsd linux ; }
src_configure() {
use static && append-ldflags -static