summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-04 07:51:09 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-04 07:51:09 +0000
commit7f9f3a1f771cbaca46a4543691e6814888080db5 (patch)
treebb1c241db7c2a70f4a79d7d8fd801bfbd81ecdea /sys-process/iotop/iotop-0.5.ebuild
parentFix html generation for USE=doc (bug 448426) (diff)
downloadhistorical-7f9f3a1f771cbaca46a4543691e6814888080db5.tar.gz
historical-7f9f3a1f771cbaca46a4543691e6814888080db5.tar.bz2
historical-7f9f3a1f771cbaca46a4543691e6814888080db5.zip
sys-process/iotop: Version Bump, #455392; use new python eclasses; allow installation for py3
Package-Manager: portage-2.2.0_alpha161/cvs/Linux x86_64 Manifest-Sign-Key: 0x70EB7916
Diffstat (limited to 'sys-process/iotop/iotop-0.5.ebuild')
-rw-r--r--sys-process/iotop/iotop-0.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-process/iotop/iotop-0.5.ebuild b/sys-process/iotop/iotop-0.5.ebuild
new file mode 100644
index 000000000000..d051c492b003
--- /dev/null
+++ b/sys-process/iotop/iotop-0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.5.ebuild,v 1.1 2013/02/04 07:51:08 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1 linux-info
+
+DESCRIPTION="Top-like UI used to show which process is using the I/O"
+HOMEPAGE="http://guichaz.free.fr/iotop/"
+SRC_URI="http://guichaz.free.fr/iotop//files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+DOCS=( NEWS README THANKS ChangeLog )
+
+pkg_setup() {
+ linux-info_pkg_setup
+}