summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-07-27 08:35:35 +0000
committerPacho Ramos <pacho@gentoo.org>2013-07-27 08:35:35 +0000
commit37f8f0d9cc7be76156a6b3b62dc0c28aee8b0a02 (patch)
tree63b1d37d0f0959c9d118db4e479996e1693325a1 /sys-process/dcron/dcron-4.5-r1.ebuild
parentInstall unit file #470746 (diff)
downloadhistorical-37f8f0d9cc7be76156a6b3b62dc0c28aee8b0a02.tar.gz
historical-37f8f0d9cc7be76156a6b3b62dc0c28aee8b0a02.tar.bz2
historical-37f8f0d9cc7be76156a6b3b62dc0c28aee8b0a02.zip
Install unit file #470754
Package-Manager: portage-2.1.13.1/cvs/Linux x86_64 Manifest-Sign-Key: 0xA188FBD4
Diffstat (limited to 'sys-process/dcron/dcron-4.5-r1.ebuild')
-rw-r--r--sys-process/dcron/dcron-4.5-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-process/dcron/dcron-4.5-r1.ebuild b/sys-process/dcron/dcron-4.5-r1.ebuild
new file mode 100644
index 000000000000..aeb4116fcd94
--- /dev/null
+++ b/sys-process/dcron/dcron-4.5-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/dcron/dcron-4.5-r1.ebuild,v 1.1 2013/07/27 08:35:31 pacho Exp $
+
+EAPI=4
+
+inherit cron toolchain-funcs eutils systemd
+
+DESCRIPTION="A cute little cron from Matt Dillon"
+HOMEPAGE="http://www.jimpryor.net/linux/dcron.html http://apollo.backplane.com/FreeSrc/"
+SRC_URI="http://www.jimpryor.net/linux/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.5-pidfile.patch
+ epatch "${FILESDIR}"/${PN}-4.5-ldflags.patch
+ tc-export CC
+ cat <<-EOF > config
+ PREFIX = /usr
+ CRONTAB_GROUP = cron
+ EOF
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc CHANGELOG README "${FILESDIR}"/crontab
+
+ docrondir
+ docron crond -m0700 -o root -g wheel
+ docrontab
+
+ insinto /etc
+ doins "${FILESDIR}"/crontab
+ insinto /etc/cron.d
+ doins extra/prune-cronstamps
+ dodoc extra/run-cron extra/root.crontab
+
+ newinitd "${FILESDIR}"/dcron.init-4.5 dcron
+ newconfd "${FILESDIR}"/dcron.confd-4.4 dcron
+ systemd_dounit "${FILESDIR}"/dcron.service
+
+ insinto /etc/logrotate.d
+ newins extra/crond.logrotate dcron
+}
+
+pkg_postinst() {
+ # upstream renamed their pid file
+ local src="${ROOT}/var/run/cron.pid" dst="${ROOT}/var/run/crond.pid"
+ if [ -e "${src}" -a ! -e "${dst}" ] ; then
+ cp "${src}" "${dst}"
+ fi
+}