summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-03-01 22:24:47 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-03-01 22:24:47 +0000
commitf60376bb6aef1e89a08b82f1bfdb2aab54431bc2 (patch)
tree73612063c3118533c50dfc9bf32886b32e929065 /sys-libs
parentfilter a broken flag (diff)
downloadhistorical-f60376bb6aef1e89a08b82f1bfdb2aab54431bc2.tar.gz
historical-f60376bb6aef1e89a08b82f1bfdb2aab54431bc2.tar.bz2
historical-f60376bb6aef1e89a08b82f1bfdb2aab54431bc2.zip
emake
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog6
-rw-r--r--sys-libs/db/db-3.2.9-r1.ebuild12
-rw-r--r--sys-libs/db/db-3.2.9-r2.ebuild11
-rw-r--r--sys-libs/db/db-4.1.24.ebuild4
4 files changed, 21 insertions, 12 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 14e8fa19b6d7..66bf6a03edaf 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for sys-libs/db
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.22 2003/02/25 01:53:42 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.23 2003/03/01 22:24:47 lostlogic Exp $
*db-3.2.9-r2 (23 Feb 2003)
+ 01 Mar 2003; Brandon Low <lostlogic@gentoo.org> db-3.2.9-r1.ebuild,
+ db-3.2.9-r2.ebuild, db-4.1.24.ebuild:
+ Fix for userpriv and make -> emake changes
+
24 Feb 2003; Brandon Low <lostlogic@gentoo.org> db-3.2.9-r2.ebuild :
Fix for userpriv mode
diff --git a/sys-libs/db/db-3.2.9-r1.ebuild b/sys-libs/db/db-3.2.9-r1.ebuild
index 79df9cf80c6d..e16cb27b3cb4 100644
--- a/sys-libs/db/db-3.2.9-r1.ebuild
+++ b/sys-libs/db/db-3.2.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r1.ebuild,v 1.11 2003/02/20 22:00:24 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r1.ebuild,v 1.12 2003/03/01 22:24:47 lostlogic Exp $
S=${WORKDIR}/${P}/build_unix
DESCRIPTION="Berkeley DB for transaction support in MySQL"
@@ -23,6 +23,7 @@ export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
src_unpack() {
unpack ${A}
+ chmod -R ug+w *
cd ${WORKDIR}/${P}
patch -p0 < ${FILESDIR}/patch.3.2.9.1 || die
@@ -51,17 +52,18 @@ src_compile() {
echo
# Parallel make does not work
einfo "Building static libs..."
- make libdb=libdb-3.2.a libdb-3.2.a || die
- make libcxx=libdb_cxx-3.2.a libdb_cxx-3.2.a || die
+ emake libdb=libdb-3.2.a libdb-3.2.a || die
+ emake libcxx=libdb_cxx-3.2.a libdb_cxx-3.2.a || die
echo
einfo "Building db_dump185..."
- /bin/sh ./libtool --mode=compile cc -c ${CFLAGS} -D_GNU_SOURCE \
+ /bin/sh ./libtool --mode=compile ${CC} -c ${CFLAGS} -D_GNU_SOURCE \
-I/usr/include/db1 -I../dist/../include -D_REENTRANT \
../dist/../db_dump185/db_dump185.c || die
gcc -s -static -o db_dump185 db_dump185.lo -L/usr/lib -ldb1 || die
echo
einfo "Building everything else..."
- make libdb=libdb-3.2.a libcxx=libdb_cxx-3.2.a || die
+ MAKEOPTS="${MAKEOPTS} -j1"
+ emake libdb=libdb-3.2.a libcxx=libdb_cxx-3.2.a || die
}
src_install () {
diff --git a/sys-libs/db/db-3.2.9-r2.ebuild b/sys-libs/db/db-3.2.9-r2.ebuild
index a7a47e3b75ff..70029b11ea9d 100644
--- a/sys-libs/db/db-3.2.9-r2.ebuild
+++ b/sys-libs/db/db-3.2.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r2.ebuild,v 1.2 2003/02/25 01:53:42 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r2.ebuild,v 1.3 2003/03/01 22:24:47 lostlogic Exp $
IUSE=""
@@ -21,7 +21,7 @@ DEPEND="${RDEPEND}
=sys-libs/db-1.85-r1
sys-devel/libtool
sys-devel/m4"
-# We need m4 to else build fails without config.guess
+# We need m4 too else build fails without config.guess
# This doesn't build without exceptions
export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
@@ -29,6 +29,8 @@ export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
src_unpack() {
unpack ${A}
+ chmod -R ug+w *
+
cd ${WORKDIR}/${P}
epatch ${FILESDIR}/patch.3.2.9.1
epatch ${FILESDIR}/patch.3.2.9.2
@@ -81,12 +83,13 @@ src_compile() {
--enable-shared || die
# Parallel make does not work
+ MAKEOPTS="${MAKEOPTS} -j1"
einfo "Building ${P} (static)..."
cd ${S}/build-static
- make || die
+ emake || die "Static build failed"
einfo "Building ${P} (shared)..."
cd ${S}/build-shared
- make || die
+ emake || die "Shared build failed"
}
src_install () {
diff --git a/sys-libs/db/db-4.1.24.ebuild b/sys-libs/db/db-4.1.24.ebuild
index fc551d1de6c7..66300f0bc4f7 100644
--- a/sys-libs/db/db-4.1.24.ebuild
+++ b/sys-libs/db/db-4.1.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.7 2003/02/13 16:48:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.8 2003/03/01 22:24:47 lostlogic Exp $
IUSE="tcltk java"
@@ -10,7 +10,7 @@ SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
HOMEPAGE="http://www.sleepycat.com"
SLOT="4"
LICENSE="DB"
-KEYWORDS="-x86 -ppc -sparc "
+KEYWORDS="~x86 -ppc -sparc "
DEPEND="tcltk? ( dev-lang/tcl )
java? ( virtual/jdk )"