summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-22 05:28:34 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-22 05:28:34 +0000
commitdf3295966e6e6ef432855b094f8a2a3a6e8fe872 (patch)
treed0cc3b16182ce03dc5eb449c8a28bc593447ac81 /sys-libs
parentVersion bump. Marked as unstable. Please comment on bug #9303. (diff)
downloadhistorical-df3295966e6e6ef432855b094f8a2a3a6e8fe872.tar.gz
historical-df3295966e6e6ef432855b094f8a2a3a6e8fe872.tar.bz2
historical-df3295966e6e6ef432855b094f8a2a3a6e8fe872.zip
configure enhancements
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog7
-rw-r--r--sys-libs/db/db-4.1.24.ebuild38
2 files changed, 33 insertions, 12 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index a71eccddb919..82cdb70b2a6c 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for sys-libs/db
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.9 2002/10/08 23:43:38 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.10 2002/10/22 05:28:34 seemant Exp $
db-4.1.24 (08 Oct 2002)
+ 21 Oct 2002; Seemant Kulleen <seemant@gentoo.org> db-4.1.24.ebuild :
+
+ changed configure statement to add a few features (like db-1.8.5
+ compatibility).
+
08 Oct 2002; Ryan Phillips <rphillips@gentoo.org> :
version bump.. has new crypto support
diff --git a/sys-libs/db/db-4.1.24.ebuild b/sys-libs/db/db-4.1.24.ebuild
index 1e8fc0642482..07273a8e59b0 100644
--- a/sys-libs/db/db-4.1.24.ebuild
+++ b/sys-libs/db/db-4.1.24.ebuild
@@ -1,34 +1,50 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.1 2002/10/08 23:43:38 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.2 2002/10/22 05:28:34 seemant Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="Berkeley DB"
+IUSE="tcltk java"
+S=${WORKDIR}/${P}/build_unix
+DESCRIPTION="Berkeley DB"
SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
HOMEPAGE="http://www.sleepycat.com"
SLOT="4"
LICENSE="DB"
KEYWORDS="x86 ppc sparc sparc64"
-DEPEND="virtual/glibc"
+DEPEND="tcltk? ( dev-lang/tcl )
+ java? ( virtual/jdk )"
src_compile() {
- cd dist
+ local myconf
+
+ use java \
+ && myconf="${myconf} --enable-java" \
+ || myconf="${myconf} --disable-java"
+
+ use tcltk \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/lib" \
+ || myconf="${myconf} --disable-tcl"
- ./configure \
- --host=${CHOST} \
+ ../dist/configure \
--prefix=/usr \
+ --mandir=/usr/share/man \
--infodir=/usr/share/info \
- --mandir=/usr/share/man || die
- emake || die
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --enable-compat185 \
+ --enable-cxx \
+ --enable-posixmutexes \
+ ${myconf} || die
+
+ emake || make || die
}
src_install () {
- cd dist
- make prefix=${D}/usr install || die
+ einstall || die
dodir /usr/share/doc/${PF}/html
mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html/