summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-06-11 00:47:48 +0000
committerTravis Tilley <lv@gentoo.org>2004-06-11 00:47:48 +0000
commitd458dd7da36c3c3c4aa240c9a92f645228379726 (patch)
treec8fe81520428f801f683cb7f927cba84aed9e914 /sys-libs
parentAdded libtermcap-compat as a DEPEND. Closes bug #53573 by Martin Hajduch <ma... (diff)
downloadhistorical-d458dd7da36c3c3c4aa240c9a92f645228379726.tar.gz
historical-d458dd7da36c3c3c4aa240c9a92f645228379726.tar.bz2
historical-d458dd7da36c3c3c4aa240c9a92f645228379726.zip
fixed the bug where some apps would fail to link if libstdc++-v3 is installed. stable on amd64
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libstdc++-v3/ChangeLog9
-rw-r--r--sys-libs/libstdc++-v3/Manifest6
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild7
3 files changed, 16 insertions, 6 deletions
diff --git a/sys-libs/libstdc++-v3/ChangeLog b/sys-libs/libstdc++-v3/ChangeLog
index 1516c44b8b7b..f09ddbf36eb7 100644
--- a/sys-libs/libstdc++-v3/ChangeLog
+++ b/sys-libs/libstdc++-v3/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/libstdc++-v3
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.5 2004/06/01 00:11:51 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.6 2004/06/11 00:47:48 lv Exp $
+
+ 10 Jun 2004; Travis Tilley <lv@gentoo.org> libstdc++-v3-3.3.3-r1.ebuild:
+ stable on amd64
+
+ 10 Jun 2004; Travis Tilley <lv@gentoo.org> libstdc++-v3-3.3.3-r1.ebuild:
+ fixed the bug where some apps would fail to link if libstdc++-v3 is installed.
+ I didnt have previous ebuilds remove the .so symlink... this one does.
31 May 2004; Joshua Kinard <kumba@gentoo.org> libstdc++-v3-3.3.3-r1.ebuild:
Added ~mips to KEYWORDS.
diff --git a/sys-libs/libstdc++-v3/Manifest b/sys-libs/libstdc++-v3/Manifest
index 3b24e75bc4f0..c49a73dd6896 100644
--- a/sys-libs/libstdc++-v3/Manifest
+++ b/sys-libs/libstdc++-v3/Manifest
@@ -1,5 +1,5 @@
-MD5 4a02ccb85faf6b777c0ec99bc1d2940d ChangeLog 1172
-MD5 cf547e5b3ccf5194ca2f9c9f506a894e libstdc++-v3-3.3.3-r1.ebuild 6079
+MD5 68567a086a8214b3d4dae3f90703e868 libstdc++-v3-3.3.3-r1.ebuild 6259
+MD5 f8aa5bcd9cc9bea199ac0d4d55f0e91f ChangeLog 1492
MD5 b6c1db1060c4e856b248a22adec1ff53 metadata.xml 220
-MD5 14f4d6619c938dbb907e2420c0eeefd9 files/digest-libstdc++-v3-3.3.3-r1 64
MD5 b2a96584f4cee72362695ba44c911c40 files/libstdc++_amd64_multilib_hack.patch 350
+MD5 14f4d6619c938dbb907e2420c0eeefd9 files/digest-libstdc++-v3-3.3.3-r1 64
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
index 40cae5128659..bb65de4f7fc1 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.4 2004/06/01 00:11:51 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.5 2004/06/11 00:47:48 lv Exp $
IUSE="nls"
@@ -66,7 +66,7 @@ HOMEPAGE="http://gcc.gnu.org/libstdc++/"
LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="-* ~amd64 ~mips"
+KEYWORDS="-* amd64 ~mips"
if [ "${CHOST}" == "${CCHOST}" ]
then
@@ -212,6 +212,9 @@ src_install() {
rm -rf ${D}/${LOC}/share
# or anything other than the .so files, really.
find ${D} | grep -e c++.la$ -e c++.a$ | xargs rm -f
+ # we dont even want the un-versioned .so symlink, as it confuses some
+ # apps and also causes others to link against the old libstdc++...
+ rm ${D}/${LOC}/lib/libstdc++-v3/libstdc++.so
mkdir -p ${D}/etc/env.d/
echo "LDPATH=\"${LOC}/lib/libstdc++-v3/\"" >> ${D}/etc/env.d/99libstdc++