summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-09-20 22:58:44 +0000
committerAchim Gottinger <achim@gentoo.org>2000-09-20 22:58:44 +0000
commitb79c11999df2e3b93b87a7456d2045001aec665c (patch)
tree433b42161eafe20ed976f3000ce77b25cb1ad2c5 /sys-libs
parent*** empty log message *** (diff)
downloadhistorical-b79c11999df2e3b93b87a7456d2045001aec665c.tar.gz
historical-b79c11999df2e3b93b87a7456d2045001aec665c.tar.bz2
historical-b79c11999df2e3b93b87a7456d2045001aec665c.zip
*** empty log message ***
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/files/digest-glibc-2.1.3-r25
-rw-r--r--sys-libs/glibc/glibc-2.1.3-r2.ebuild93
2 files changed, 98 insertions, 0 deletions
diff --git a/sys-libs/glibc/files/digest-glibc-2.1.3-r2 b/sys-libs/glibc/files/digest-glibc-2.1.3-r2
new file mode 100644
index 000000000000..c6a825e29b9a
--- /dev/null
+++ b/sys-libs/glibc/files/digest-glibc-2.1.3-r2
@@ -0,0 +1,5 @@
+MD5 886afcbcfb2883c09c3cbfe0b2cb1f22 glibc-2.1.3.tar.gz
+MD5 5d28eb5376031c4cf7ba6057322852fd glibc-crypt-2.1.tar.gz
+MD5 14352cd699b5c751004438d644a6059c glibc-linuxthreads-2.1.3.tar.gz
+MD5 699e73877b1211af64d488ddb76598b2 glibc-compat-2.1.2.tar.gz
+MD5 70fcaf79c3c1e84c6bb18c579784b062 glibc_2.1.3-13.diff.gz
diff --git a/sys-libs/glibc/glibc-2.1.3-r2.ebuild b/sys-libs/glibc/glibc-2.1.3-r2.ebuild
new file mode 100644
index 000000000000..171b5a21ece7
--- /dev/null
+++ b/sys-libs/glibc/glibc-2.1.3-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.1.3-r2.ebuild,v 1.1 2000/09/20 22:58:44 achim Exp $
+
+P=glibc-2.1.3
+A="glibc-2.1.3.tar.gz glibc-crypt-2.1.tar.gz
+ glibc-linuxthreads-2.1.3.tar.gz glibc-compat-2.1.2.tar.gz
+ glibc_2.1.3-13.diff.gz"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU libc6 (also called glibc2) C library"
+SRC_URI="ftp://prep.ai.mit.edu/gnu/glibc/glibc-2.1.3.tar.gz
+ ftp://prep.ai.mit.edu/gnu/glibc/glibc-crypt-2.1.tar.gz
+ ftp://prep.ai.mit.edu/gnu/glibc/glibc-linuxthreads-2.1.3.tar.gz
+ ftp://jurix.jura.uni-sb.de/pub/linux/source/libc/glibc/glibc-compat-2.1.2.tar.gz
+ http://security.debian.org/dists/potato/updates/main/source/glibc_2.1.3-13.diff.gz"
+
+HOMEPAGE="http://www.gnu.org/software/libc/libc.html"
+
+src_compile() {
+ if [ "$CHOST" = "i686-pc-linux-gnu" ]
+ then
+ CHOST=i586-pc-linux-gnu #this is so there's no PII specific stuff
+ fi
+ rm -rf buildhere
+ mkdir buildhere
+ cd buildhere
+ try ../configure --host=${CHOST} --without-cvs \
+ --enable-add-ons=linuxthreads,glibc-compat,crypt \
+ --disable-profile --prefix=/usr
+ try make
+ try make check
+}
+
+src_unpack() {
+ unpack glibc-2.1.3.tar.gz
+ cd ${S}
+ gzip -dc ${DISTDIR}/glibc_2.1.3-13.diff.gz | patch -p1
+ unpack glibc-crypt-2.1.tar.gz
+ unpack glibc-linuxthreads-2.1.3.tar.gz
+ unpack glibc-compat-2.1.2.tar.gz
+
+ # This patch is required to compile with binutils higher than
+ # 2.9.5.0.42
+ cp ${O}/files/setjmp.S ${S}/sysdeps/i386/elf/setjmp.S
+}
+
+src_install() {
+ cd ${S}
+ rm -rf ${D}
+ mkdir ${D}
+ dodir /etc/rc.d/init.d
+ try make install_root=${D} install -C buildhere
+ try make -C linuxthreads/man
+ mkdir -p ${D}/usr/man/man3
+ install -m 0644 linuxthreads/man/*.3thr ${D}/usr/man/man3
+ chmod 755 ${D}/usr/libexec/pt_chown
+ install -m 644 nscd/nscd.conf ${D}/etc
+ install -m 755 ${O}/files/nscd ${D}/etc/rc.d/init.d/nscd
+ dodir /var/db
+ install -m 644 nss/db-Makefile ${D}/var/db/Makefile
+ strip ${D}/sbin/*
+ strip ${D}/usr/bin/*
+ strip ${D}/usr/sbin/*
+ prepinfo
+ prepman
+ rm -rf documentation
+ mkdir documentation
+ mkdir documentation/html
+ cp linuxthreads/ChangeLog documentation/ChangeLog.threads
+ cp linuxthreads/Changes documentation/Changes.threads
+ cp linuxthreads/README documentation/README.threads
+ cp linuxthreads/FAQ.html documentation/html/FAQ-threads.html
+ cp crypt/README documentation/README.crypt
+ cp db2/README documentation/README.db2
+ cp db2/mutex/README documentation/README.db2.mutex
+ cp timezone/README documentation/README.timezone
+ cp ChangeLog* documentation
+ dodoc documentation/*
+ docinto html
+ dodoc documentation/html/*.html
+ dodir /usr/doc/${PF}/examples.threads
+ install -m0644 linuxthreads/Examples/*.c ${D}/usr/doc/${PF}/examples.threads
+ install -m0644 linuxthreads/Examples/Makefile ${D}/usr/doc/${PF}/examples.threads
+ # Patch ucontext.h (needed for lynx, xfree)
+ cd ${D}/usr/include/sys
+ cp ucontext.h ucontext.h.orig
+ sed -e "s/ERR/GLIBCBUG/g" ucontext.h.orig > ucontext.h
+}
+
+
+