summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-06-08 04:59:56 +0000
committerMike Frysinger <vapier@gentoo.org>2010-06-08 04:59:56 +0000
commit263d57bc4c4b93a39fbdc2b35e914f86fc504228 (patch)
treeeefe079026e790778a5b85c4c221de7572963111 /sys-libs
parentold (diff)
downloadhistorical-263d57bc4c4b93a39fbdc2b35e914f86fc504228.tar.gz
historical-263d57bc4c4b93a39fbdc2b35e914f86fc504228.tar.bz2
historical-263d57bc4c4b93a39fbdc2b35e914f86fc504228.zip
Tweak src_unpack a bit more to handle snaps again #323009 by Maksim Melnikau.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/files/eblits/src_unpack.eblit12
2 files changed, 13 insertions, 6 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index a8700ad9272e..882034c6d93b 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.684 2010/05/20 18:17:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.685 2010/06/08 04:59:56 vapier Exp $
+
+ 08 Jun 2010; Mike Frysinger <vapier@gentoo.org>
+ files/eblits/src_unpack.eblit:
+ Tweak src_unpack a bit more to handle snaps again #323009 by Maksim
+ Melnikau.
20 May 2010; Samuli Suominen <ssuominen@gentoo.org> glibc-2.5-r4.ebuild,
glibc-2.5.1.ebuild, glibc-2.6.1.ebuild, glibc-2.7-r2.ebuild,
diff --git a/sys-libs/glibc/files/eblits/src_unpack.eblit b/sys-libs/glibc/files/eblits/src_unpack.eblit
index 5de2a7f08fb9..d99dc563b39e 100644
--- a/sys-libs/glibc/files/eblits/src_unpack.eblit
+++ b/sys-libs/glibc/files/eblits/src_unpack.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_unpack.eblit,v 1.10 2010/04/25 17:17:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_unpack.eblit,v 1.11 2010/06/08 04:59:56 vapier Exp $
int_to_KV() {
local version=$1 major minor micro
@@ -60,12 +60,14 @@ unpack_pkg() {
local a=${PN}
[[ -n ${SNAP_VER} ]] && a="${a}-${RELEASE_VER}"
[[ -n $1 ]] && a="${a}-$1"
- if [[ -n $2 ]] ; then
- a="${a}-$2"
- elif [[ -n ${SNAP_VER} ]] ; then
+ if [[ -n ${SNAP_VER} ]] ; then
a="${a}-${SNAP_VER}"
else
- a="${a}-${RELEASE_VER}"
+ if [[ -n $2 ]] ; then
+ a="${a}-$2"
+ else
+ a="${a}-${RELEASE_VER}"
+ fi
fi
unpack ${a}.tar.bz2
[[ -n $1 ]] && mv ${a} $1