summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-12 04:26:57 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-12 04:26:57 +0000
commit33da67a6b8967d738a62414b119b05a6c13e70fd (patch)
tree46372e328301fe21dacab847af98069bdf002389 /sys-libs/uclibc++/uclibc++-0.1.8.ebuild
parentBumping to fix multilib issues after discussion with caleb. (diff)
downloadhistorical-33da67a6b8967d738a62414b119b05a6c13e70fd.tar.gz
historical-33da67a6b8967d738a62414b119b05a6c13e70fd.tar.bz2
historical-33da67a6b8967d738a62414b119b05a6c13e70fd.zip
merge a bunch of fixes from psm
Diffstat (limited to 'sys-libs/uclibc++/uclibc++-0.1.8.ebuild')
-rw-r--r--sys-libs/uclibc++/uclibc++-0.1.8.ebuild48
1 files changed, 32 insertions, 16 deletions
diff --git a/sys-libs/uclibc++/uclibc++-0.1.8.ebuild b/sys-libs/uclibc++/uclibc++-0.1.8.ebuild
index 2ef39ca88a56..d4a3c3bb1a4c 100644
--- a/sys-libs/uclibc++/uclibc++-0.1.8.ebuild
+++ b/sys-libs/uclibc++/uclibc++-0.1.8.ebuild
@@ -1,17 +1,26 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc++/uclibc++-0.1.8.ebuild,v 1.2 2005/01/10 13:55:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc++/uclibc++-0.1.8.ebuild,v 1.3 2005/01/12 04:26:57 vapier Exp $
-inherit eutils
+inherit eutils toolchain-funcs
+
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
DESCRIPTION="embedded C++ library"
HOMEPAGE="http://cxx.uclibc.org/"
SRC_URI="http://cxx.uclibc.org/src/uClibc++-${PV}.tbz2"
LICENSE="GPL-2"
-SLOT="0"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
KEYWORDS="~arm ~ppc ~x86"
-IUSE=""
+IUSE="debug static"
DEPEND=""
@@ -22,14 +31,13 @@ src_unpack() {
cd ${S}
make defconfig || die "defconfig failed"
- export CTARGET="${CTARGET:-${CHOST}}"
local target
- case ${CTARGET} in
- arm*) target="arm";;
- mips*) target="mips";;
- powerpc*) target="powerpc";;
- i?86*) target="i386";;
- *) die "${CTARGET} lists no defaults :/";;
+ case $(tc-arch ${CTARGET}) in
+ arm) target="arm";;
+ mips) target="mips";;
+ ppc) target="powerpc";;
+ x86) target="i386";;
+ *) die "$(tc-arch ${CTARGET}) lists no defaults :/";;
esac
sed -i \
@@ -37,20 +45,28 @@ src_unpack() {
-e '/^TARGET_'${target}'/d' \
.config
- cat << EOF >> .config
-TARGET_${target}=y
-UCLIBCXX_RUNTIME_PREFIX="/usr/${CTARGET}"
-EOF
+ echo "UCLIBCXX_RUNTIME_PREFIX=\"/usr/${CTARGET}\"" >> .config
echo "TARGET_${target}=y" >> .config
+ use debug && echo "CONFIG_DODEBUG=y" >> .config
yes "" | make oldconfig || die "oldconfig failed"
+ # has to come after make oldconfig, else it will be disabled
+ echo "BUILD_STATIC_LIB=y" >> .config
+ if use static ; then
+ echo "BUILD_ONLY_STATIC_LIB=y" >> .config
+ fi
+
# Patches!
epatch "${FILESDIR}"/${PV}-pop_back.patch
}
src_compile() {
- emake -j1 CROSS=${CTARGET}- || die "make failed"
+ emake -j1 ARCH_CFLAGS="${CFLAGS}" CROSS=${CTARGET}- || die "make failed"
+}
+
+src_test() {
+ make test || die "test failed"
}
src_install() {