summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Houser <chouser@gentoo.org>2001-09-09 21:17:20 +0000
committerChris Houser <chouser@gentoo.org>2001-09-09 21:17:20 +0000
commit03d6905ade83ffd56e355ea02b184d2419f2a69c (patch)
tree3204eb09c6a7d37ef3ff7a4e0e4ee18a37cd9bfd /sys-libs/readline
parentcolons added back (diff)
downloadhistorical-03d6905ade83ffd56e355ea02b184d2419f2a69c.tar.gz
historical-03d6905ade83ffd56e355ea02b184d2419f2a69c.tar.bz2
historical-03d6905ade83ffd56e355ea02b184d2419f2a69c.zip
removed redundant rlusernam.info from install
this should fix the readline info error during emerge also replaced 'try' with 'die' and 'assert'
Diffstat (limited to 'sys-libs/readline')
-rw-r--r--sys-libs/readline/readline-4.1-r3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-libs/readline/readline-4.1-r3.ebuild b/sys-libs/readline/readline-4.1-r3.ebuild
new file mode 100644
index 000000000000..b8f24a133f41
--- /dev/null
+++ b/sys-libs/readline/readline-4.1-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.1-r3.ebuild,v 1.1 2001/09/09 21:17:20 chouser Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Another cute console display library"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/readline/${A}
+ ftp://ftp.gnu.org/gnu/readline/${A}"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ # Don't install redunant rluserman.info
+ sed -e 's|${INSTALL_DATA.*rluserman\.info.*|: &|' doc/Makefile.in \
+ > doc/Makefile.in.new
+ mv doc/Makefile.in.new doc/Makefile.in
+
+ ./configure --host=${CHOST} --with-curses \
+ --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info
+ assert "configure failed"
+ make ${MAKEOPTS} || die "make failed"
+ cd shlib
+ make ${MAKEOPTS} || die "make in shlib failed"
+
+}
+
+
+src_install() {
+
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ assert "make install failed"
+ cd shlib
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ assert "make install in shlib failed"
+
+ cd ..
+
+ dodir /lib
+ mv ${D}/usr/lib/*.so* ${D}/lib
+ dosym libhistory.so.${PV} /lib/libhistory.so
+ dosym libreadline.so.${PV} /lib/libreadline.so
+ # Needed because make install uses ${D} for the link
+ dosym libhistory.so.${PV} /lib/libhistory.so.4
+ dosym libreadline.so.${PV} /lib/libreadline.so.4
+ chmod 755 ${D}/lib/*.${PV}
+
+ dodoc CHANGELOG CHANGES COPYING MANIFEST README USAGE
+ docinto ps
+ dodoc doc/*.ps
+ docinto html
+ dodoc doc/*.html
+
+}