summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-09-05 06:39:01 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-09-05 06:39:01 +0000
commit66d368f0cc28edae60a44b86971ef8b8d6905c68 (patch)
tree421e2d66fca6aa1d1aafd9f702e47e50a8715784 /sys-libs/libtermcap-compat
parentremove /etc/termcap (diff)
downloadhistorical-66d368f0cc28edae60a44b86971ef8b8d6905c68.tar.gz
historical-66d368f0cc28edae60a44b86971ef8b8d6905c68.tar.bz2
historical-66d368f0cc28edae60a44b86971ef8b8d6905c68.zip
new package
Diffstat (limited to 'sys-libs/libtermcap-compat')
-rw-r--r--sys-libs/libtermcap-compat/ChangeLog10
-rw-r--r--sys-libs/libtermcap-compat/files/digest-libtermcap-compat-1.2.31
-rw-r--r--sys-libs/libtermcap-compat/files/libtermcap-compat_bcopy_fix.patch14
-rw-r--r--sys-libs/libtermcap-compat/libtermcap-compat-1.2.3.ebuild39
4 files changed, 64 insertions, 0 deletions
diff --git a/sys-libs/libtermcap-compat/ChangeLog b/sys-libs/libtermcap-compat/ChangeLog
new file mode 100644
index 000000000000..538d212de899
--- /dev/null
+++ b/sys-libs/libtermcap-compat/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-libs/libtermcap-compat
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtermcap-compat/ChangeLog,v 1.1 2002/09/05 06:39:01 azarah Exp $
+
+*libtermcap-compat-1.2.3 (5 Sep 2002)
+
+ 5 Sep 2002; Martin Schlemmer <azarah@gentoo.org> libtermcap-compat-1.2.3.ebuild :
+
+ Initial version. This is based on Debian's termcap-compat package.
+
diff --git a/sys-libs/libtermcap-compat/files/digest-libtermcap-compat-1.2.3 b/sys-libs/libtermcap-compat/files/digest-libtermcap-compat-1.2.3
new file mode 100644
index 000000000000..7f86750b9f0e
--- /dev/null
+++ b/sys-libs/libtermcap-compat/files/digest-libtermcap-compat-1.2.3
@@ -0,0 +1 @@
+MD5 698f1e510845b8c0f15ea8c3010c35ed termcap-compat_1.2.3.tar.gz 552156
diff --git a/sys-libs/libtermcap-compat/files/libtermcap-compat_bcopy_fix.patch b/sys-libs/libtermcap-compat/files/libtermcap-compat_bcopy_fix.patch
new file mode 100644
index 000000000000..350659745d07
--- /dev/null
+++ b/sys-libs/libtermcap-compat/files/libtermcap-compat_bcopy_fix.patch
@@ -0,0 +1,14 @@
+--- tparam.c.orig Sun Feb 15 22:40:15 1998
++++ tparam.c Thu Sep 5 08:16:58 2002
+@@ -24,9 +24,11 @@
+ #undef STDC_HEADERS
+ #define STDC_HEADERS
+ #define HAVE_UNISTD_H
++/*
+ #if defined(HAVE_STRING_H) || defined(STDC_HEADERS)
+ #define bcopy(s, d, n) memcpy ((d), (s), (n))
+ #endif
++ */
+ #endif
+
+ #ifdef STDC_HEADERS
diff --git a/sys-libs/libtermcap-compat/libtermcap-compat-1.2.3.ebuild b/sys-libs/libtermcap-compat/libtermcap-compat-1.2.3.ebuild
new file mode 100644
index 000000000000..b8f27661f0ca
--- /dev/null
+++ b/sys-libs/libtermcap-compat/libtermcap-compat-1.2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtermcap-compat/libtermcap-compat-1.2.3.ebuild,v 1.1 2002/09/05 06:39:01 azarah Exp $
+
+MY_PN="termcap-compat"
+S="${WORKDIR}/${MY_PN}-${PV}"
+DESCRIPTION="This is a sample skeleton ebuild file"
+SRC_URI="http://ftp.debian.org/debian/dists/potato/main/source/oldlibs/${MY_PN}_${PV}.tar.gz"
+HOMEPAGE="http://packages.debian.org/stable/oldlibs/termcap-compat.html"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}; patch -p0 < ${FILESDIR}/${PN}_bcopy_fix.patch || die
+}
+
+src_compile() {
+ emake prefix="/usr" \
+ CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ dodir /usr/{include,lib}
+ make prefix="${D}/usr" install || die
+
+ dosym libtermcap.so.2.0.8 /usr/lib/libtermcap.so
+
+ insinto /etc
+ newins ${S}/termtypes.tc termcap
+
+ dodoc ChangeLog README
+}
+