summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-04-03 04:54:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-04-03 04:54:16 +0000
commitb6da810d80a801ec6bd5da8642eb9dc91336e0c5 (patch)
treedecbf41e304cd4a3b745ee4858f8ab1f442d5a69 /sys-libs/gdbm
parentupdated metadata.xml. torbenh is retired. (diff)
downloadhistorical-b6da810d80a801ec6bd5da8642eb9dc91336e0c5.tar.gz
historical-b6da810d80a801ec6bd5da8642eb9dc91336e0c5.tar.bz2
historical-b6da810d80a801ec6bd5da8642eb9dc91336e0c5.zip
resurrect version needed by ppc-macos
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-libs/gdbm')
-rw-r--r--sys-libs/gdbm/ChangeLog10
-rw-r--r--sys-libs/gdbm/Manifest4
-rw-r--r--sys-libs/gdbm/files/digest-gdbm-1.8.0-r51
-rw-r--r--sys-libs/gdbm/gdbm-1.8.0-r5.ebuild54
4 files changed, 66 insertions, 3 deletions
diff --git a/sys-libs/gdbm/ChangeLog b/sys-libs/gdbm/ChangeLog
index 96d36c6d8bb3..3b4240bf7911 100644
--- a/sys-libs/gdbm/ChangeLog
+++ b/sys-libs/gdbm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/gdbm
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/ChangeLog,v 1.31 2004/12/07 20:21:00 hardave Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/ChangeLog,v 1.32 2005/04/03 04:54:16 mr_bones_ Exp $
+
+*gdbm-1.8.0-r5 (03 Apr 2005)
+
+ 03 Apr 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +gdbm-1.8.0-r5.ebuild:
+ resurrect version needed by ppc-macos
07 Dec 2004; Hardave Riar <hardave@gentoo.org> gdbm-1.8.3-r1.ebuild:
Stable on mips, dep for bug #66360
diff --git a/sys-libs/gdbm/Manifest b/sys-libs/gdbm/Manifest
index 1dad340ecee0..f538b5a0d364 100644
--- a/sys-libs/gdbm/Manifest
+++ b/sys-libs/gdbm/Manifest
@@ -1,4 +1,6 @@
-MD5 e117546136cff8ffcffe35c6f879b80a ChangeLog 3918
+MD5 0b61d80b1d834d8c8f9564160b9126b3 ChangeLog 4071
+MD5 22314eff7a4f923601e6dba3863baf3d gdbm-1.8.0-r5.ebuild 1232
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 d316ae3f7b5f49d523ed8f783272e816 gdbm-1.8.3-r1.ebuild 1430
+MD5 017b1a2d0ae227d89ee16480e3129a3b files/digest-gdbm-1.8.0-r5 62
MD5 c7bef9bbd37f161be399c58c61edef94 files/digest-gdbm-1.8.3-r1 62
diff --git a/sys-libs/gdbm/files/digest-gdbm-1.8.0-r5 b/sys-libs/gdbm/files/digest-gdbm-1.8.0-r5
new file mode 100644
index 000000000000..487a5b061df3
--- /dev/null
+++ b/sys-libs/gdbm/files/digest-gdbm-1.8.0-r5
@@ -0,0 +1 @@
+MD5 cd543862287f55ad66e62cc9d82cc906 gdbm-1.8.0.tar.gz 134080
diff --git a/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild b/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild
new file mode 100644
index 000000000000..a7fb23753a11
--- /dev/null
+++ b/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild,v 1.44 2005/04/03 04:54:16 mr_bones_ Exp $
+
+inherit gnuconfig eutils flag-o-matic libtool
+
+DESCRIPTION="Standard GNU database libraries included for compatibility with Perl"
+HOMEPAGE="http://www.gnu.org/software/gdbm/gdbm.html"
+SRC_URI="mirror://gnu/gdbm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390 ppc-macos"
+IUSE="berkdb static"
+
+DEPEND="virtual/libc
+ berkdb? ( ~sys-libs/db-1.85 )"
+
+RDEPEND="virtual/libc"
+
+pkg_setup() {
+ enewuser bin
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ epatch ${FILESDIR}/${PF}-gentoo.diff
+ gnuconfig_update
+ append-flags -fomit-frame-pointer
+ uclibctoolize
+ use ppc-macos && darwintoolize
+}
+
+src_compile() {
+ local myconf
+
+ use static && myconf="${myconf} --enable-static"
+
+ econf ${myconf} || die
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ einstall \
+ man3dir=${D}/usr/share/man/man3 || die
+
+ make includedir=${D}/usr/include/gdbm \
+ install-compat || die
+
+ dosed "s:/usr/local/lib':/usr/lib':g" /usr/lib/libgdbm.la
+
+ dodoc ChangeLog NEWS README
+}