summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-04-06 20:23:30 +0000
committerDonny Davies <woodchip@gentoo.org>2002-04-06 20:23:30 +0000
commitaf1a8d8460f377218c1c10aa6b3b9778e5be4bc9 (patch)
tree4f040820df8cbb501bfdac653407d3c81f4768c8 /sys-libs/gdbm/gdbm-1.8.0-r5.ebuild
parentcleaned up the ebuild a little bit, added SLOT (diff)
downloadhistorical-af1a8d8460f377218c1c10aa6b3b9778e5be4bc9.tar.gz
historical-af1a8d8460f377218c1c10aa6b3b9778e5be4bc9.tar.bz2
historical-af1a8d8460f377218c1c10aa6b3b9778e5be4bc9.zip
fix libgdbm.la with the proper libdir
Diffstat (limited to 'sys-libs/gdbm/gdbm-1.8.0-r5.ebuild')
-rw-r--r--sys-libs/gdbm/gdbm-1.8.0-r5.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild b/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild
new file mode 100644
index 000000000000..862999fe53a2
--- /dev/null
+++ b/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# Chad Huneycutt <chad.huneycutt@acm.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild,v 1.1 2002/04/06 20:23:30 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU database libraries included for compatibility with Perl"
+SRC_URI="ftp://prep.ai.mit.edu/gnu/gdbm/${P}.tar.gz"
+
+HOMEPAGE="http://www.gnu.org/software/gdbm/gdbm.html"
+
+DEPEND="virtual/glibc
+ berkdb? ( =sys-libs/db-1.85-r1 )"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff || die
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die
+
+ emake CFLAGS="${CFLAGS} -fomit-frame-pointer" || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ man3dir=${D}/usr/share/man/man3 \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ make includedir=${D}/usr/include/gdbm \
+ install-compat || die
+
+ dosed "s:/usr/local/lib':/usr/lib':g" /usr/lib/libgdbm.la
+
+ dodoc COPYING ChangeLog NEWS README
+}