summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Johnson <livewire@gentoo.org>2003-10-27 01:14:35 +0000
committerBob Johnson <livewire@gentoo.org>2003-10-27 01:14:35 +0000
commitfd8ddc066e8a168c0e81d9e0b83c4d1be8c44cd3 (patch)
tree7fbb785c3a0e26c0cff4c8764359911e48bc4599 /sys-kernel
parentcommiting 2.4.22 version (diff)
downloadhistorical-fd8ddc066e8a168c0e81d9e0b83c4d1be8c44cd3.tar.gz
historical-fd8ddc066e8a168c0e81d9e0b83c4d1be8c44cd3.tar.bz2
historical-fd8ddc066e8a168c0e81d9e0b83c4d1be8c44cd3.zip
commiting 2.4.22 version
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/xfs-sources/Manifest4
-rw-r--r--sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.222
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.22.ebuild67
3 files changed, 71 insertions, 2 deletions
diff --git a/sys-kernel/xfs-sources/Manifest b/sys-kernel/xfs-sources/Manifest
index c66e9353f9e4..706c3c5d7f5e 100644
--- a/sys-kernel/xfs-sources/Manifest
+++ b/sys-kernel/xfs-sources/Manifest
@@ -2,9 +2,9 @@ MD5 4daa3597c62a9676fad4a07e543be9c3 xfs-sources-2.4.20-r1.ebuild 2132
MD5 4fa4fca3767bc89c7c258ac3c382fc18 xfs-sources-2.4.19-r2.ebuild 1844
MD5 b2fb282b21e82e7cac47f99c48017e54 xfs-sources-2.4.20.ebuild 2142
MD5 7721ef109f2d111f961afe47a3baa0d9 xfs-sources-2.4.20-r3.ebuild 2185
-MD5 0f64323f9fbf3b5c3a17515fa5f18a12 xfs-sources-2.4.22.ebuild 2143
+MD5 8e0156afed80d85c166d9af22510592c xfs-sources-2.4.22.ebuild 2144
MD5 03830a0019c2793faccebaf4de544435 xfs-sources-2.4.20-r2.ebuild 2131
-MD5 b13ce9305197a9d518bb36ee44dbae79 ChangeLog 7779
+MD5 092b7d1cc0e327cfd548c6a2a6b58a07 ChangeLog 7778
MD5 a728d28dca69f5ae16aab56cd2fc6110 files/digest-xfs-sources-2.4.20 139
MD5 26b986cdd4c24df8ad3d0f0b21e802be files/digest-xfs-sources-2.4.22 139
MD5 ec7765fb708912e448a36dc6cf7cdce9 files/xfs-sources-2.4.20-gcc33.patch 11801
diff --git a/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.22 b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.22
new file mode 100644
index 000000000000..9394b057e9ea
--- /dev/null
+++ b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.22
@@ -0,0 +1,2 @@
+MD5 75dc85149b06ac9432106b8941eb9f7b linux-2.4.22.tar.bz2 29528612
+MD5 6940c38612564f9e03736fde8f79c4d3 patches-2.4.22-xfs.tar.bz2 1406293
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.22.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.22.ebuild
new file mode 100644
index 000000000000..8b20c1babe77
--- /dev/null
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.22.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.22.ebuild,v 1.1 2003/10/27 01:14:24 livewire Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel
+OKV=2.4.22
+EXTRAVERSION=-${P/-sources-2.4.22}
+KV=${OKV}${EXTRAVERSION}
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/xfs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the XFS Specialized Gentoo Linux kernel"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # If the compiler isn't gcc3 drop the gcc3 patches
+ if [[ "${COMPILER}" == "gcc3" ]];then
+ einfo "You are using gcc3, check out the special"
+ einfo "processor types just for you"
+ else
+ einfo "Your compiler is not gcc3, dropping patches..."
+ for file in *gcc3*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ kernel_src_unpack
+}