summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-04-29 17:36:05 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-04-29 17:36:05 +0000
commitc7b409b68a371ef786288f3cb9a85027c21617b1 (patch)
treef02be2a72f713a3047733693919931da70037caa /sys-kernel
parentcleaning (diff)
downloadhistorical-c7b409b68a371ef786288f3cb9a85027c21617b1.tar.gz
historical-c7b409b68a371ef786288f3cb9a85027c21617b1.tar.bz2
historical-c7b409b68a371ef786288f3cb9a85027c21617b1.zip
Fix #90455.
Package-Manager: portage-2.0.51.20-r5
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-headers/ChangeLog6
-rw-r--r--sys-kernel/linux-headers/Manifest4
-rw-r--r--sys-kernel/linux-headers/files/linux-headers-2.6.8.1-appCompat.patch4
3 files changed, 10 insertions, 4 deletions
diff --git a/sys-kernel/linux-headers/ChangeLog b/sys-kernel/linux-headers/ChangeLog
index 916e62518fc8..1fb23b5ff828 100644
--- a/sys-kernel/linux-headers/ChangeLog
+++ b/sys-kernel/linux-headers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/linux-headers
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.120 2005/04/24 19:26:23 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.121 2005/04/29 17:36:05 plasmaroo Exp $
+
+ 29 Apr 2005; <plasmaroo@gentoo.org>
+ files/linux-headers-2.6.8.1-appCompat.patch:
+ Fix #90455.
24 Apr 2005; <plasmaroo@gentoo.org>
files/linux-headers-2.6.11-appCompat.patch:
diff --git a/sys-kernel/linux-headers/Manifest b/sys-kernel/linux-headers/Manifest
index 0b3451768d7f..dd9e09b69d19 100644
--- a/sys-kernel/linux-headers/Manifest
+++ b/sys-kernel/linux-headers/Manifest
@@ -1,4 +1,4 @@
-MD5 ff4e2d9aa884d3201e6e6b9425fb8bd1 ChangeLog 25532
+MD5 dbcbb43e6adb420d96ce831ed934f0cc ChangeLog 25632
MD5 b3099588e509bea5bf8c12f2b3882f58 linux-headers-2.2.26.ebuild 2509
MD5 c2c4eec01b604c30d0826e73ac02cac4 linux-headers-2.4.23.ebuild 3482
MD5 e9a0370039c1d4fe1b0f7c0be1eef478 linux-headers-2.6.11.ebuild 1522
@@ -24,7 +24,7 @@ MD5 45ff5cde07cfe93ecbb514226def606f files/generate-asm-sparc 1661
MD5 556c7008fbfdf81750bbd4ab2beb111e files/digest-linux-headers-2.2.26 67
MD5 6ef3887ee4018c06c18e8726767189c7 files/digest-linux-headers-2.4.22 67
MD5 33d51532d0f696fefa15593b2cf2f6de files/digest-linux-headers-2.0.40 66
-MD5 34ffeae76f21b18c880ef86565f1d496 files/linux-headers-2.6.8.1-appCompat.patch 61598
+MD5 c68a4f50a666c677bea9cccaed04bf0f files/linux-headers-2.6.8.1-appCompat.patch 61683
MD5 2574d3f1b776f2df365737f456bfe435 files/digest-linux-headers-2.4.26 67
MD5 57e8b81485f8a1ba10d41dd7949d40a8 files/linux-headers-2.6.8.1-strict-ansi-fix.patch 4132
MD5 602f7309c0163c018627f06b5f1ace3a files/linux-headers-2.6.8.1-arm-float.patch 640
diff --git a/sys-kernel/linux-headers/files/linux-headers-2.6.8.1-appCompat.patch b/sys-kernel/linux-headers/files/linux-headers-2.6.8.1-appCompat.patch
index 6a623e1e1fee..0a8b99fe666b 100644
--- a/sys-kernel/linux-headers/files/linux-headers-2.6.8.1-appCompat.patch
+++ b/sys-kernel/linux-headers/files/linux-headers-2.6.8.1-appCompat.patch
@@ -1332,7 +1332,7 @@ diff -up linux-2.6.8.1/include/linux/list.h linux-2.6.8.1-gentoo/include/linux/l
#include <linux/stddef.h>
#include <linux/prefetch.h>
#include <asm/system.h>
-@@ -38,20 +36,31 @@ struct list_head {
+@@ -38,20 +36,33 @@ struct list_head {
(ptr)->next = (ptr); (ptr)->prev = (ptr); \
} while (0)
@@ -1340,10 +1340,12 @@ diff -up linux-2.6.8.1/include/linux/list.h linux-2.6.8.1-gentoo/include/linux/l
+ * list_empty - tests whether a list is empty
+ * @head: the list to test.
+ */
++#if (defined(_LINUX_WAIT_H) || defined (__KERNEL__)) && !defined(LIST_INIT)
+static inline int list_empty(const struct list_head *head)
+{
+ return head->next == head;
+}
++#endif
+
+#if defined(__KERNEL__) || defined(__LINUX_KEYBOARD_H)
+