summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-09-29 04:15:40 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-09-29 04:15:40 +0000
commitb6705e4669dd7db607028d3f31023147c94f1723 (patch)
tree261cbe547827c52e682d2ddf48c3781952311e54 /sys-kernel
parentRevision Bump; test6-mm1 (diff)
downloadhistorical-b6705e4669dd7db607028d3f31023147c94f1723.tar.gz
historical-b6705e4669dd7db607028d3f31023147c94f1723.tar.bz2
historical-b6705e4669dd7db607028d3f31023147c94f1723.zip
Revision Bump; test6-mm1
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/mm-sources/Manifest4
-rw-r--r--sys-kernel/mm-sources/mm-sources-2.6.0_beta6-r1.ebuild87
2 files changed, 89 insertions, 2 deletions
diff --git a/sys-kernel/mm-sources/Manifest b/sys-kernel/mm-sources/Manifest
index 87ae6bee33fd..5e6650e79dcf 100644
--- a/sys-kernel/mm-sources/Manifest
+++ b/sys-kernel/mm-sources/Manifest
@@ -1,5 +1,5 @@
-MD5 d9e17fdbb0a482058656bae240769eea ChangeLog 14674
-MD5 279a7e6f7e473ec98bbc997c181668ec mm-sources-2.6.0_beta6-r1.ebuild 2902
+MD5 d74d23093c51318da0e0c64f320d8b09 ChangeLog 14672
+MD5 68bb13303e83ca058ec8b08779bb370a mm-sources-2.6.0_beta6-r1.ebuild 2900
MD5 989752e6e5c4dac06c24117e0e857c0e mm-sources-2.6.0_beta4-r6.ebuild 2967
MD5 62587df4b49506468241ec3c9415b010 metadata.xml 435
MD5 6535d4722395ab12b5260836c2da7cba mm-sources-2.6.0_beta3-r3.ebuild 2164
diff --git a/sys-kernel/mm-sources/mm-sources-2.6.0_beta6-r1.ebuild b/sys-kernel/mm-sources/mm-sources-2.6.0_beta6-r1.ebuild
new file mode 100644
index 000000000000..d0bdc39b1c1a
--- /dev/null
+++ b/sys-kernel/mm-sources/mm-sources-2.6.0_beta6-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mm-sources/mm-sources-2.6.0_beta6-r1.ebuild,v 1.1 2003/09/29 04:15:37 kumba Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+
+OKV=${PV/_beta/-test}
+
+EXTRAVERSION="`echo ${OKV}-${PR/r/mm} | \
+ sed -e 's/[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\)/\1/'`"
+
+KV=${OKV}-${PR/r/mm}
+
+inherit kernel
+
+# What's in this kernel?
+
+# INCLUDED:
+# The development branch of the linux kernel with Andrew Morton's patch
+
+DESCRIPTION="Full sources for the development linux kernel with Andrew Morton's patchset"
+SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${PV/_beta/-test}.tar.bz2
+mirror://kernel/linux/kernel/people/akpm/patches/2.6/${PV/_beta/-test}/${KV}/${KV}.bz2"
+KEYWORDS="x86 ~ppc"
+RDEPEND="sys-apps/module-init-tools"
+SLOT=${KV}
+PROVIDE="virtual/linux-sources
+ virtual/alsa"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+
+ mv linux-${OKV} linux-${KV}
+ cd ${S}
+ find . -iname "*~" | xargs rm 2> /dev/null
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ # also fix the EXTRAVERSION
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+
+ cd ${S}/Documentation/DocBook
+ sed -e "s:db2:docbook2:g" Makefile > Makefile.new \
+ && mv Makefile.new Makefile
+ cd ${S}
+
+ #This is needed on > 2.5
+ MY_ARCH=${ARCH}
+ unset ARCH
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die "make mrproper died"
+ ARCH=${MY_ARCH}
+
+ # kernel_universal_unpack used to do this... changes in kconfig make
+ # this die now
+ #make include/linux/version.h || die "make include/linux/version.h failed"
+
+}
+pkg_postinst() {
+ if [ ! -e ${ROOT}usr/src/linux-beta ]
+ then
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
+ fi
+
+ ewarn "Please note that ptyfs support has been removed from devfs"
+ ewarn "in the later 2.5.x kernels, and you have to compile it in now,"
+ ewarn "or else you will get errors when trying to open a pty."
+ ewarn "The option is File systems->Pseudo filesystems->/dev/pts"
+ ewarn "filesystem."
+ echo
+ ewarn "Also, note that you must compile in support for"
+ ewarn "input devices (Input device support->Input devices),"
+ ewarn "the virtual terminal (Character Devices->Virtual terminal),"
+ ewarn "vga_console (Graphics Support->Console...->VGA text console)"
+ ewarn "and the vt_console (Character Devices->Support for console...)."
+ ewarn "Otherwise, you will get the dreaded \"Uncompressing the Kernel\"" ewarn "error."
+ echo
+ einfo "Consult http://www.codemonkey.org.uk/post-halloween-2.5.txt"
+ einfo "for more info about the development series."
+ echo
+}