summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-09-08 13:39:14 +0000
committerMichael Imhof <tantive@gentoo.org>2002-09-08 13:39:14 +0000
commit5add7ca581e2f1e362f7cb351321319fc6ee291b (patch)
treed7d802b024f8bc37eda620b426ef2dfb751a567a /sys-kernel
parentversion bumb of totem (diff)
downloadhistorical-5add7ca581e2f1e362f7cb351321319fc6ee291b.tar.gz
historical-5add7ca581e2f1e362f7cb351321319fc6ee291b.tar.bz2
historical-5add7ca581e2f1e362f7cb351321319fc6ee291b.zip
Added a patch to compile using gcc3.
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/openmosix-sources/ChangeLog7
-rw-r--r--sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.19-r43
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r4.ebuild111
3 files changed, 120 insertions, 1 deletions
diff --git a/sys-kernel/openmosix-sources/ChangeLog b/sys-kernel/openmosix-sources/ChangeLog
index 92e67ff7a78b..cd60a73d9170 100644
--- a/sys-kernel/openmosix-sources/ChangeLog
+++ b/sys-kernel/openmosix-sources/ChangeLog
@@ -1,8 +1,13 @@
# ChangeLog for sys-kernel/openmosix-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/ChangeLog,v 1.5 2002/09/03 16:29:58 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/ChangeLog,v 1.6 2002/09/08 13:39:14 tantive Exp $
+*openmosix-sources-2.4.19-r4 (08 Sep 2002)
+
+ 08 Sep 2002; Michael Imhof <tantive@gentoo.org>
+ Added a patch to compile using gcc3.
+
*openmosix-sources-2.4.19-r3 (02 Sep 2002)
02 Sep 2002; Michael Imhof <tantive@gentoo.org>
diff --git a/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.19-r4 b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.19-r4
new file mode 100644
index 000000000000..4fbbd2ffa457
--- /dev/null
+++ b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.19-r4
@@ -0,0 +1,3 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 333bd20d1c0424c703164e758225e244 linux-gentoo-2.4.19-openmosix-r4.patch.bz2 462412
+MD5 2d91247ccae3dffe0aefb053c5f60183 linux-gentoo-2.4.19-openmosix-r4-gcc3.patch.bz2 322
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r4.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r4.ebuild
new file mode 100644
index 000000000000..8f6fc470e6d7
--- /dev/null
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r4.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r4.ebuild,v 1.1 2002/09/08 13:39:14 tantive Exp $
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.19
+KV=2.4.19-openmosix-r4
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.19, plus:
+# 2.4.19 openmosix-2.4.19-3
+# 2.4.19 evms-1.1.0 (evms-linux-2.4.19-common-files, evms-1.1.0-linux-2.4.patch, linux-2.4.19.VFS-lock.patch)
+# for gcc3 there is a patch applied that let's you compile this kernel with gcc3.
+
+DESCRIPTION="Full sources for the Gentoo openMosix Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}-gcc3.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://www.openmosix.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+DEPEND="<sys-devel/gcc-3"
+
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ cat ${DISTDIR}/linux-gentoo-${KV}.patch.bz2 | bzip2 -d | patch -p1 || die
+
+ #if the used gcc is gcc3 there is a seperate patch applied.
+ if [ `gcc -dumpversion | cut -d. -f1` == 3 ]; then
+ cat ${DISTDIR}/linux-gentoo-${KV}-gcc3.patch.bzip2 | bzip2 -d | patch -p1 || die
+ fi
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}