summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Rickard <frogger@gentoo.org>2003-08-01 19:55:47 +0000
committerMatt Rickard <frogger@gentoo.org>2003-08-01 19:55:47 +0000
commit33127fb55c8d7071da674798d6b6f9268580ad2f (patch)
tree877c155889a5b16768c088bc4f198d53d815e6c9 /sys-kernel/vanilla-prepatch-sources
parentImport _pre10 (diff)
downloadhistorical-33127fb55c8d7071da674798d6b6f9268580ad2f.tar.gz
historical-33127fb55c8d7071da674798d6b6f9268580ad2f.tar.bz2
historical-33127fb55c8d7071da674798d6b6f9268580ad2f.zip
Import _pre10
Diffstat (limited to 'sys-kernel/vanilla-prepatch-sources')
-rw-r--r--sys-kernel/vanilla-prepatch-sources/Manifest4
-rw-r--r--sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.22_pre102
-rw-r--r--sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.22_pre10.ebuild46
3 files changed, 50 insertions, 2 deletions
diff --git a/sys-kernel/vanilla-prepatch-sources/Manifest b/sys-kernel/vanilla-prepatch-sources/Manifest
index 3d3a8f6f7272..bf5cc8746da4 100644
--- a/sys-kernel/vanilla-prepatch-sources/Manifest
+++ b/sys-kernel/vanilla-prepatch-sources/Manifest
@@ -1,8 +1,8 @@
MD5 c0b832d8d5c0ae9d9a6ac9f8e2b4b73d vanilla-prepatch-sources-2.4.22_pre7.ebuild 1478
MD5 41dd20becae16704e6a1c8cb202c830c vanilla-prepatch-sources-2.4.22_pre8.ebuild 1478
MD5 d7558d2760d2d1fb6b25e42b7c0b04f2 vanilla-prepatch-sources-2.4.22_pre9.ebuild 1478
-MD5 d7558d2760d2d1fb6b25e42b7c0b04f2 vanilla-prepatch-sources-2.4.22_pre10.ebuild 1478
-MD5 259b12456f170f108cd077ac1b06623e ChangeLog 1026
+MD5 e74ddc1a91d8de46388638836add8d01 vanilla-prepatch-sources-2.4.22_pre10.ebuild 1479
+MD5 c99fb6ea1447b5ced8f612b35e02cc56 ChangeLog 1026
MD5 ae6ad96d78df15c03c62089437fbefcc files/digest-vanilla-prepatch-sources-2.4.22_pre7 134
MD5 310eb701884d1125c92221d56e1cec4b files/digest-vanilla-prepatch-sources-2.4.22_pre8 134
MD5 db5ab5c532224269dd9e6c3f976579c7 files/digest-vanilla-prepatch-sources-2.4.22_pre9 134
diff --git a/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.22_pre10 b/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.22_pre10
new file mode 100644
index 000000000000..924b43090546
--- /dev/null
+++ b/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.22_pre10
@@ -0,0 +1,2 @@
+MD5 f51e12efa18bb828cf57d9d4a81b2fb1 linux-2.4.21.tar.bz2 28533733
+MD5 6623a5074735e440f1c5eec8cf8bd232 patch-2.4.22-pre10.bz2 4282161
diff --git a/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.22_pre10.ebuild b/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.22_pre10.ebuild
new file mode 100644
index 000000000000..34972bde6531
--- /dev/null
+++ b/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.22_pre10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.22_pre10.ebuild,v 1.1 2003/08/01 19:55:32 frogger Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV="2.4.21"
+KV="${PV/_/-}"
+S=${WORKDIR}/linux-${KV}
+
+EXTRAVERSION="`echo ${KV}|sed -e 's:[^-]*\(-.*$\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+
+DESCRIPTION="Full sources for the prerelease vanilla Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+http://www.kernel.org/pub/linux/kernel/v2.4/testing/patch-${PV/_/-}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+
+ bzcat ${DISTDIR}/patch-${PV/_/-}.bz2|patch -p1 || die "-marcelo patch failed"
+
+ kernel_universal_unpack
+}
+
+pkg_postinst() {
+ einfo "Prepatches are the equivalent to alpha releases for Linux."
+ einfo "They may be poorly tested, and may not work at all."
+ einfo "Prepatches with -rc in the name are release candidates and"
+ einfo "may become full versions. It is particularly important"
+ einfo "that these are thoroughly tested and bugs are reported back"
+ einfo "upstream (and not to the Gentoo team)."
+}