summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-04-07 07:48:26 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-04-07 07:48:26 +0000
commit9b5ab7803840f4886001b4de66a5329ed414754a (patch)
tree3058119c8d241b12a65c104f1e51d686c24ab2e5 /sys-kernel/linux-headers/linux-headers-2.4.21-r1.ebuild
parent2.0 requires ogg now. Bug #47034. (diff)
downloadhistorical-9b5ab7803840f4886001b4de66a5329ed414754a.tar.gz
historical-9b5ab7803840f4886001b4de66a5329ed414754a.tar.bz2
historical-9b5ab7803840f4886001b4de66a5329ed414754a.zip
Moved the mips checking code into pkg_setup and added hppa to the check (both have their own headers packages)
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-2.4.21-r1.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.21-r1.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.21-r1.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.21-r1.ebuild
index d1c2dad2d049..9ec4bf792864 100644
--- a/sys-kernel/linux-headers/linux-headers-2.4.21-r1.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.4.21-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.21-r1.ebuild,v 1.7 2004/03/21 06:25:59 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.21-r1.ebuild,v 1.8 2004/04/07 07:48:26 kumba Exp $
ETYPE="headers"
inherit kernel
@@ -25,21 +25,23 @@ PROVIDE="virtual/kernel virtual/os-headers"
KEYWORDS="-* amd64 sparc x86 -mips s390"
-# Figure out what architecture we are, and set ARCH appropriately
-ARCH="$(uname -m)"
-ARCH=`echo $ARCH | sed -e s/[i].86/i386/ -e s/x86/i386/ -e s/sun4u/sparc64/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/amd64/x86_64/`
-[ "$ARCH" == "sparc" -a "$PROFILE_ARCH" == "sparc64" ] && ARCH=sparc64
-
-
-# Archs which have their own separate header packages, add a check here
-# and redirect the user to them
-if [ "${ARCH}" = "mips" ] || [ "${ARCH}" = "mips64" ]; then
- eerror "These headers are not appropriate for your architecture."
- eerror "Please use sys-kernel/${ARCH/64/}-headers instead."
- die
-fi
+pkg_setup() {
+ # Figure out what architecture we are, and set ARCH appropriately
+ ARCH="$(uname -m)"
+ ARCH=`echo $ARCH | sed -e s/[i].86/i386/ -e s/x86/i386/ -e s/sun4u/sparc64/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/amd64/x86_64/`
+ [ "$ARCH" == "sparc" -a "$PROFILE_ARCH" == "sparc64" ] && ARCH=sparc64
+ # Archs which have their own separate header packages, add a check here
+ # and redirect the user to them
+ case "${ARCH}" in
+ mips|mips64|hppa)
+ eerror "These headers are not appropriate for your architecture."
+ eerror "Please use sys-kernel/${ARCH/64/}-headers instead."
+ die
+ ;;
+ esac
+}
src_unpack() {
unpack ${A}