summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-06-18 16:57:07 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-06-18 16:57:07 +0000
commit87fccce4f775e05b3b86a0a970c3f8126ccca0d4 (patch)
tree1e59e7ed76baf4d87d28c4153b432279a6c9474b /sys-kernel/hardened-sources/hardened-sources-2.6.32-r111.ebuild
parentadded 'esethome' to user.eclass (diff)
downloadhistorical-87fccce4f775e05b3b86a0a970c3f8126ccca0d4.tar.gz
historical-87fccce4f775e05b3b86a0a970c3f8126ccca0d4.tar.bz2
historical-87fccce4f775e05b3b86a0a970c3f8126ccca0d4.zip
Based on 2.6.32.59 + genpatches-2.6.32-48 + grsecurity-2.9.1-2.6.32.59-201206171956
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-2.6.32-r111.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r111.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r111.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r111.ebuild
new file mode 100644
index 000000000000..004bf713d247
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r111.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r111.ebuild,v 1.1 2012/06/18 16:57:07 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="48"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-113"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.9.1"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]."
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}