summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-11-24 18:01:29 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-11-24 18:01:29 +0000
commit09649d5de66f44e4ca56976ea1ba22e6d15e8c21 (patch)
tree160f64637837dd3c40d5194e531b87dea84b4e04 /sys-fs
parentRemove old version (diff)
downloadhistorical-09649d5de66f44e4ca56976ea1ba22e6d15e8c21.tar.gz
historical-09649d5de66f44e4ca56976ea1ba22e6d15e8c21.tar.bz2
historical-09649d5de66f44e4ca56976ea1ba22e6d15e8c21.zip
Fix build with KV_OUT thanks to Stefan Talpalaru <stefantalpalaru@yahoo.com> in bug 156140
Package-Manager: portage-2.1.2_rc2-r1
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog8
-rw-r--r--sys-fs/fuse/fuse-2.6.0.ebuild4
-rw-r--r--sys-fs/fuse/fuse-2.6.0_rc1.ebuild4
3 files changed, 11 insertions, 5 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index f481aece2969..09a8e76b3b52 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.66 2006/11/01 15:57:22 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.67 2006/11/24 18:01:29 genstef Exp $
+
+ 24 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
+ -fuse-2.6.0_pre2.ebuild, fuse-2.6.0_rc1.ebuild, -fuse-2.6.0_rc3.ebuild,
+ fuse-2.6.0.ebuild:
+ Fix build with KV_OUT thanks to Stefan Talpalaru <stefantalpalaru@yahoo.com>
+ in bug 156140
*fuse-2.6.0 (01 Nov 2006)
diff --git a/sys-fs/fuse/fuse-2.6.0.ebuild b/sys-fs/fuse/fuse-2.6.0.ebuild
index 6747c5d89668..8904ac09da6c 100644
--- a/sys-fs/fuse/fuse-2.6.0.ebuild
+++ b/sys-fs/fuse/fuse-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0.ebuild,v 1.1 2006/11/01 15:57:22 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0.ebuild,v 1.2 2006/11/24 18:01:29 genstef Exp $
inherit linux-mod eutils libtool
@@ -19,7 +19,7 @@ CONFIG_CHECK="@FUSE_FS:fuse"
BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
BUILD_TARGETS="all"
-ECONF_PARAMS="--with-kernel=${KV_OUT_DIR}"
+ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
We will continue, but we wont build the module this time."
diff --git a/sys-fs/fuse/fuse-2.6.0_rc1.ebuild b/sys-fs/fuse/fuse-2.6.0_rc1.ebuild
index 85cd25258b39..7224093708d5 100644
--- a/sys-fs/fuse/fuse-2.6.0_rc1.ebuild
+++ b/sys-fs/fuse/fuse-2.6.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0_rc1.ebuild,v 1.6 2006/10/20 03:40:33 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0_rc1.ebuild,v 1.7 2006/11/24 18:01:29 genstef Exp $
inherit linux-mod eutils libtool
@@ -19,7 +19,7 @@ CONFIG_CHECK="@FUSE_FS:fuse"
BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
BUILD_TARGETS="all"
-ECONF_PARAMS="--with-kernel=${KV_OUT_DIR}"
+ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
We will continue, but we wont build the module this time."