summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2006-08-01 10:34:14 +0000
committerChristian Andreetta <satya@gentoo.org>2006-08-01 10:34:14 +0000
commit29a7895d8665c877a45f8f1647065e9702047f48 (patch)
tree303d26662391563dc6cca3a907d126be0c3a8627 /sys-fs/unionfs/unionfs-1.2.ebuild
parentNew version (diff)
downloadhistorical-29a7895d8665c877a45f8f1647065e9702047f48.tar.gz
historical-29a7895d8665c877a45f8f1647065e9702047f48.tar.bz2
historical-29a7895d8665c877a45f8f1647065e9702047f48.zip
Old ebuilds cleanup. Version bump (bug #142332)
Package-Manager: portage-2.1
Diffstat (limited to 'sys-fs/unionfs/unionfs-1.2.ebuild')
-rw-r--r--sys-fs/unionfs/unionfs-1.2.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sys-fs/unionfs/unionfs-1.2.ebuild b/sys-fs/unionfs/unionfs-1.2.ebuild
new file mode 100644
index 000000000000..4d55c756f105
--- /dev/null
+++ b/sys-fs/unionfs/unionfs-1.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.2.ebuild,v 1.1 2006/08/01 10:34:14 satya Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
+HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
+SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="acl debug nfs"
+
+local_version_info() {
+ ewarn
+ ewarn "you need the proper kernel version!"
+ ewarn
+ einfo "kernel: 2.4.x (x>19) Version: 1.0.14"
+ einfo "kernel: 2.6.x (x<9) Version: Not Supported"
+ einfo "kernel: 2.6.9 - 2.6.15 Version: 1.1.5"
+ einfo "kernel: 2.6.16 Version: 1.2"
+ einfo "kernel: 2.6.17 Version: 1.3"
+}
+
+pkg_setup() {
+ # kernel version check
+ if ! kernel_is eq 2 6 16; then
+ local_version_info
+ die
+ fi
+
+ linux-mod_pkg_setup
+
+ MODULE_NAMES="unionfs(kernel/fs/${PN}:)"
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
+}
+
+src_unpack() {
+ local user_Makefile=fistdev.mk EXTRACFLAGS=""
+
+ unpack ${A}
+ cd ${S}
+
+ if ! use debug; then
+ echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
+ EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_NDEBUG"
+ fi
+
+ if use acl; then
+ EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR" # -DFIST_SETXATTR_CONSTVOID"
+ elif use nfs; then
+ EXTRACFLAGS="${EXTRACFLAGS} -DNFS_SECURITY_HOLE"
+ fi
+
+ echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
+ einfo EXTRACFLAGS: ${EXTRACFLAGS}
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc INSTALL NEWS README ChangeLog patch-kernel.sh
+
+ #emake PREFIX="${D}" install-utils # Makefile is bugged
+ doman man/unionfs.4 man/unionctl.8 man/uniondbg.8 man/unionimap.8
+ into / # ${D}/sbin: usr could be unionfs mounted: bug #129960
+ dosbin utils/unionctl utils/uniondbg utils/unionimap
+}
+