summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2006-02-01 23:53:40 +0000
committerDaniel Drake <dsd@gentoo.org>2006-02-01 23:53:40 +0000
commitf6219b0059ad4f8111c7aa07460479a9af5ca291 (patch)
tree494b3fbfc5f5d17db7201825e0bbf06c1ed89b66 /sys-fs/udftools/udftools-1.0.0b-r6.ebuild
parentMark 1.33.1 stable on alpha/ia64 #120840 (diff)
downloadhistorical-f6219b0059ad4f8111c7aa07460479a9af5ca291.tar.gz
historical-f6219b0059ad4f8111c7aa07460479a9af5ca291.tar.bz2
historical-f6219b0059ad4f8111c7aa07460479a9af5ca291.zip
Bigendian platform fix, thanks to Chris Abbey <genfool@cabbey.net> in bug #120245
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'sys-fs/udftools/udftools-1.0.0b-r6.ebuild')
-rw-r--r--sys-fs/udftools/udftools-1.0.0b-r6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-fs/udftools/udftools-1.0.0b-r6.ebuild b/sys-fs/udftools/udftools-1.0.0b-r6.ebuild
new file mode 100644
index 000000000000..803170b16daf
--- /dev/null
+++ b/sys-fs/udftools/udftools-1.0.0b-r6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udftools/udftools-1.0.0b-r6.ebuild,v 1.1 2006/02/01 23:53:40 dsd Exp $
+
+inherit eutils
+
+MY_P="${P}3"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Ben Fennema's tools for packet writing and the UDF filesystem"
+SRC_URI="mirror://sourceforge/linux-udf/${MY_P}.tar.gz
+ http://w1.894.telia.com/~u89404340/patches/packet/${MY_P}.patch.bz2"
+HOMEPAGE="http://sourceforge.net/projects/linux-udf/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # For new kernel packet writing driver
+ epatch ${WORKDIR}/${MY_P}.patch
+
+ # Fix CD blanking for 2.6.8 and newer
+ epatch ${FILESDIR}/cdrwtool-linux2.6-fix-v2.patch
+
+ # gcc4 compat, bug #112122
+ epatch ${FILESDIR}/${P}-gcc4.patch
+
+ # BE fix, bug #120245
+ epatch ${FILESDIR}/${P}-bigendian.patch
+}
+
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog COPYING
+ newinitd ${FILESDIR}/pktcdvd.init pktcdvd
+}
+