summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-09-29 22:29:47 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-09-29 22:29:47 +0000
commitccd006e42e049512dce2d4ab4c2c650eeb331fcc (patch)
treea304275cd1e1b2dcda9badaf23645421b5d0fe09 /sys-fs/ntfsprogs
parentVersion bump (diff)
downloadhistorical-ccd006e42e049512dce2d4ab4c2c650eeb331fcc.tar.gz
historical-ccd006e42e049512dce2d4ab4c2c650eeb331fcc.tar.bz2
historical-ccd006e42e049512dce2d4ab4c2c650eeb331fcc.zip
Added gcc3 patch .Closes #27519.
Diffstat (limited to 'sys-fs/ntfsprogs')
-rw-r--r--sys-fs/ntfsprogs/ChangeLog6
-rw-r--r--sys-fs/ntfsprogs/Manifest5
-rw-r--r--sys-fs/ntfsprogs/files/ntfsprogs-1.7.1-gcc3.patch39
-rw-r--r--sys-fs/ntfsprogs/ntfsprogs-1.7.1.ebuild9
4 files changed, 51 insertions, 8 deletions
diff --git a/sys-fs/ntfsprogs/ChangeLog b/sys-fs/ntfsprogs/ChangeLog
index 1c3d2c43688e..93e86fd0c206 100644
--- a/sys-fs/ntfsprogs/ChangeLog
+++ b/sys-fs/ntfsprogs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/ntfsprogs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ChangeLog,v 1.1 2003/09/15 18:17:31 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ChangeLog,v 1.2 2003/09/29 22:29:41 mholzer Exp $
+
+ 30 Sep 2003; Martin Holzer <mholzer@gentoo.org> ntfsprogs-1.7.1.ebuild,
+ files/ntfsprogs-1.7.1-gcc3.patch:
+ Added gcc3 patch .Closes #27519.
*ntfsprogs-1.7.1 (15 Sep 2003)
diff --git a/sys-fs/ntfsprogs/Manifest b/sys-fs/ntfsprogs/Manifest
index 75045a23c613..0af5a122746b 100644
--- a/sys-fs/ntfsprogs/Manifest
+++ b/sys-fs/ntfsprogs/Manifest
@@ -1,3 +1,4 @@
-MD5 f06ce9d22efd5db278bf72bf48f89396 ChangeLog 1093
-MD5 ccdafefa1cb480a9c6eab41e76c7a5b2 ntfsprogs-1.7.1.ebuild 1238
+MD5 966ead79191a130866b7d850c7e1ddc3 ChangeLog 1239
+MD5 d1bd9f6618208a212662beabfed13930 ntfsprogs-1.7.1.ebuild 1172
MD5 9c54070c93405b7ad66d548e7fa2e2a4 files/digest-ntfsprogs-1.7.1 67
+MD5 2954e3eda945cc153d217db1eb3a3a6e files/ntfsprogs-1.7.1-gcc3.patch 1983
diff --git a/sys-fs/ntfsprogs/files/ntfsprogs-1.7.1-gcc3.patch b/sys-fs/ntfsprogs/files/ntfsprogs-1.7.1-gcc3.patch
new file mode 100644
index 000000000000..f802acce36eb
--- /dev/null
+++ b/sys-fs/ntfsprogs/files/ntfsprogs-1.7.1-gcc3.patch
@@ -0,0 +1,39 @@
+--- ntfsprogs/Makefile.in 2003-09-10 05:57:10.000000000 +0000
++++ ntfsprogs/Makefile.in.patched 2003-09-10 05:57:37.000000000 +0000
+@@ -88,8 +88,8 @@
+ VERSION = @VERSION@
+ all_includes = @all_includes@
+ all_libraries = @all_libraries@
+-@DEBUG_TRUE@AM_CFLAGS = @DEBUG_TRUE@-D_FILE_OFFSET_BITS=64 -Wall -g -DDEBUG
+-@DEBUG_FALSE@AM_CFLAGS = @DEBUG_FALSE@-D_FILE_OFFSET_BITS=64 -Wall
++@DEBUG_TRUE@AM_CFLAGS = @DEBUG_TRUE@-D_FILE_OFFSET_BITS=64 -Wall -g -DDEBUG -fms-extensions
++@DEBUG_FALSE@AM_CFLAGS = @DEBUG_FALSE@-D_FILE_OFFSET_BITS=64 -Wall -fms-extensions
+ @REALLYSTATIC_TRUE@AM_LIBS = @REALLYSTATIC_TRUE@$(top_srcdir)/libntfs/.libs/libntfs.a
+ @REALLYSTATIC_FALSE@AM_LIBS = @REALLYSTATIC_FALSE@$(top_srcdir)/libntfs/libntfs.la
+ @REALLYSTATIC_TRUE@AM_LFLAGS = @REALLYSTATIC_TRUE@-static
+--- libntfs/Makefile.in 2003-09-10 05:57:45.000000000 +0000
++++ libntfs/Makefile.in.patched 2003-09-10 05:58:05.000000000 +0000
+@@ -115,8 +115,8 @@
+ all_libraries = @all_libraries@
+
+ LTVERSION = 4:0:0
+-@DEBUG_TRUE@AM_CFLAGS = @DEBUG_TRUE@-D_FILE_OFFSET_BITS=64 -Wall -g -DDEBUG
+-@DEBUG_FALSE@AM_CFLAGS = @DEBUG_FALSE@-D_FILE_OFFSET_BITS=64 -Wall
++@DEBUG_TRUE@AM_CFLAGS = @DEBUG_TRUE@-D_FILE_OFFSET_BITS=64 -Wall -g -DDEBUG -fms-extensions
++@DEBUG_FALSE@AM_CFLAGS = @DEBUG_FALSE@-D_FILE_OFFSET_BITS=64 -Wall -fms-extensions
+
+ linux_ntfsincludedir = -I$(top_srcdir)/include
+ lib_LTLIBRARIES = libntfs.la
+--- libntfs/lcnalloc.c 2003-02-06 15:24:56.000000000 +0000
++++ libntfs/lcnalloc.c.patched 2003-09-10 06:00:08.000000000 +0000
+@@ -101,8 +101,8 @@
+ int err = 0, rlpos, rlsize, buf_size;
+ u8 pass, done_zones, search_zone, need_writeback, bit;
+
+- Dprintf("%s(): Entering with count = 0x%Lx, start_lcn = 0x%Lx,
+- zone = %s_ZONE.\n", (long long)count,
++ Dprintf("%s(): Entering with count = 0x%Lx, start_lcn = 0x%Lx, "
++ "zone = %s_ZONE.\n", (long long)count,
+ (long long)start_lcn,
+ zone == MFT_ZONE ? "MFT" : "DATA");
+ if (!vol || count < 0 || start_lcn < -1 || !vol->lcnbmp_na ||
diff --git a/sys-fs/ntfsprogs/ntfsprogs-1.7.1.ebuild b/sys-fs/ntfsprogs/ntfsprogs-1.7.1.ebuild
index e89e43dc1612..9d1020926340 100644
--- a/sys-fs/ntfsprogs/ntfsprogs-1.7.1.ebuild
+++ b/sys-fs/ntfsprogs/ntfsprogs-1.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ntfsprogs-1.7.1.ebuild,v 1.1 2003/09/15 18:17:32 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ntfsprogs-1.7.1.ebuild,v 1.2 2003/09/29 22:29:41 mholzer Exp $
DESCRIPTION="Utilities and library for accessing NTFS filesystems"
HOMEPAGE="http://linux-ntfs.sourceforge.net/"
@@ -13,6 +13,7 @@ LICENSE="GPL-2"
KEYWORDS="x86 amd64"
src_compile() {
+ epatch ${FILESDIR}/${P}-gcc3.patch || die
sed -i 's:head -1:head -n 1:' configure
econf || die "Configure failed"
@@ -27,10 +28,8 @@ src_install() {
make DESTDIR=${D} install || die "Install failed"
# lot's of docs (a good thing :)
- dodoc CREDITS ChangeLog NEWS README TODO.include TODO.mkntfs TODO.ntfsfix \
- doc/attribute_definitions doc/attributes.txt doc/compression.txt \
- doc/system_files.txt doc/system_security_descriptors.txt \
- doc/tunable_settings
+ dodoc AUTHORS COPYING CREDITS ChangeLog NEWS README TODO.* \
+ doc/attribute_definitions doc/*.txt doc/tunable_settings
# a normal user cannot run ntfsfix
cd ${D}