summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2013-06-11 17:23:58 +0000
committerDaniel Pielmeier <billie@gentoo.org>2013-06-11 17:23:58 +0000
commitee20010a957d650a6598d587175888b4db72afcd (patch)
treef22a77d244f6bd16d7d64abc547f1f2a1b3f41ce /sys-fs/fatsort/fatsort-1.1.1.ebuild
parentFixed installation of doc with the new metric flag (bug #472974) (diff)
downloadhistorical-ee20010a957d650a6598d587175888b4db72afcd.tar.gz
historical-ee20010a957d650a6598d587175888b4db72afcd.tar.bz2
historical-ee20010a957d650a6598d587175888b4db72afcd.zip
Version bump. Remove old.
Package-Manager: portage-2.1.12.2/cvs/Linux i686 Manifest-Sign-Key: 0x215AD14D
Diffstat (limited to 'sys-fs/fatsort/fatsort-1.1.1.ebuild')
-rw-r--r--sys-fs/fatsort/fatsort-1.1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-fs/fatsort/fatsort-1.1.1.ebuild b/sys-fs/fatsort/fatsort-1.1.1.ebuild
new file mode 100644
index 000000000000..514b4eaece94
--- /dev/null
+++ b/sys-fs/fatsort/fatsort-1.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fatsort/fatsort-1.1.1.ebuild,v 1.1 2013/06/11 17:23:51 billie Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+SVN_REV=336
+MY_P=${P}.${SVN_REV}
+
+DESCRIPTION="Sorts files on FAT16/32 partitions, ideal for basic audio players."
+HOMEPAGE="http://fatsort.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-util/bbe sys-fs/dosfstools )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e '/^\(MANDIR=\|SBINDIR=\)/s|/usr/local|/usr|' \
+ $(find ./ -name Makefile) || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ DESTDIR="${D}"
+}
+
+src_test() {
+ make tests
+}