summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-14 09:07:41 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-14 09:07:41 +0000
commitdfa8ade825d8984450a493ac7efeac0ec2745039 (patch)
tree4a47d1dda9a9d1f96abc02baa20c440542029118 /sys-devel
parenteclass for binutils (diff)
downloadhistorical-dfa8ade825d8984450a493ac7efeac0ec2745039.tar.gz
historical-dfa8ade825d8984450a493ac7efeac0ec2745039.tar.bz2
historical-dfa8ade825d8984450a493ac7efeac0ec2745039.zip
more cross-compile updates
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/Manifest8
-rw-r--r--sys-devel/binutils/binutils-2.15.92.0.2-r2.ebuild165
2 files changed, 12 insertions, 161 deletions
diff --git a/sys-devel/binutils/Manifest b/sys-devel/binutils/Manifest
index 5d1342c338ac..5c6a2331de71 100644
--- a/sys-devel/binutils/Manifest
+++ b/sys-devel/binutils/Manifest
@@ -2,7 +2,7 @@
Hash: SHA1
MD5 f3472d881eb2f7607e6f0285f96b66d6 ChangeLog 36571
-MD5 e72d8cbf7beac0c9b6fcdc31a483db77 binutils-2.15.92.0.2-r2.ebuild 4496
+MD5 04b080366059f0780dfa079da7e2cd6b binutils-2.15.92.0.2-r2.ebuild 529
MD5 49e852b8fe8101cd814b93eac95326eb binutils-2.14.90.0.6-r6.ebuild 6613
MD5 1bb1dac74aec61b33248f85c53583a6e binutils-2.14.90.0.6-r7.ebuild 6738
MD5 7ad231c717fbcebf8be7059ad29f273d binutils-2.15.90.0.1.1-r1.ebuild 4755
@@ -87,7 +87,7 @@ MD5 8f619fc0c409a5ba768f126f172ee6bc files/2.15/05_all_binutils-2.15-elf32-arm-t
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBlxLrHTu7gpaalycRAoI/AKCkdhYufbPAuwMaI9lI3Go10j3JDgCg7pH5
-GTT9Bx7xGT3N2NOipAp3RvQ=
-=nRQK
+iD8DBQFBlyCKHTu7gpaalycRAsnEAJ95YT7M4ZBQjDzuHNpgP0zNzfhQiACeKtr8
+BkActsQTGQFVkU58h7Fkg+0=
+=YFq9
-----END PGP SIGNATURE-----
diff --git a/sys-devel/binutils/binutils-2.15.92.0.2-r2.ebuild b/sys-devel/binutils/binutils-2.15.92.0.2-r2.ebuild
index ca10a7809727..061ba40b13b3 100644
--- a/sys-devel/binutils/binutils-2.15.92.0.2-r2.ebuild
+++ b/sys-devel/binutils/binutils-2.15.92.0.2-r2.ebuild
@@ -1,174 +1,25 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.92.0.2-r2.ebuild,v 1.5 2004/11/09 02:17:41 vapier Exp $
-
-inherit eutils libtool flag-o-matic gnuconfig
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.92.0.2-r2.ebuild,v 1.6 2004/11/14 09:07:41 vapier Exp $
PATCHVER="1.2"
UCLIBC_PATCHVER="1.0"
-DESCRIPTION="Tools necessary to build programs"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-SRC_URI="mirror://kernel/linux/devel/binutils/${P}.tar.bz2
- mirror://kernel/linux/devel/binutils/test/${P}.tar.bz2
- mirror://gentoo/${PN}-${PV:0:4}-uclibc-patches-${UCLIBC_PATCHVER}.tar.bz2
- mirror://gentoo/${P}-patches-${PATCHVER}.tar.bz2"
+inherit toolchain-binutils
-LICENSE="|| ( GPL-2 LGPL-2 )"
-SLOT="${CTARGET:-${CHOST}}"
KEYWORDS="-*"
-IUSE="nls bootstrap build multitarget uclibc"
-
-DEPEND="virtual/libc
- nls? ( sys-devel/gettext )
- !build? ( !bootstrap? ( dev-lang/perl ) )"
-
-MY_BUILDDIR="${WORKDIR}/build"
src_unpack() {
- unpack ${A}
- cd ${S}
- mkdir -p "${MY_BUILDDIR}"
+ toolchain-binutils_src_unpack
# Patches
cd ${WORKDIR}/patch
mkdir skip
- mv *no_rel_ro* 20_* *ldsoconf* skip/
- cd ${S}
- epatch ${WORKDIR}/patch
- epatch ${WORKDIR}/uclibc-patches
-
- # Run misc portage update scripts
- gnuconfig_update
- elibtoolize --portage --no-uclibc
-
- strip-linguas -i */po
-}
-
-src_compile() {
- strip-linguas -i */po #42033
-
- filter-flags -fomit-frame-pointer -fssa #6730
- strip-flags && replace-flags -O3 -O2 #47581
-
- cd "${MY_BUILDDIR}"
- local myconf=""
- use nls \
- && myconf="${myconf} --without-included-gettext" \
- || myconf="${myconf} --disable-nls"
- use multitarget && myconf="${myconf} --enable-targets=all"
- ECONF_SOURCE="${S}" \
- econf \
- --enable-shared \
- --enable-64-bit-bfd \
- ${myconf} || die
-
- make configure-bfd || die "configure-bfd"
- make headers -C bfd || die "headers-bfd"
- emake all || die "emake"
-
- if ! use build ; then
- if ! has noinfo ${FEATURES} ; then
- # Make the info pages (makeinfo included with gcc is used)
- make info || die "info"
- fi
- if ! use bootstrap && ! has noman ${FEATURES} ; then
- cd "${S}"
- # Nuke the manpages to recreate them (only use this if we have perl)
- find . -name '*.1' -exec rm -f {} \; || :
- fi
- fi
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- local x d
-
- cd "${MY_BUILDDIR}"
- make DESTDIR="${D}" install || die
-
- # Now we move everything out of /usr and into $CTARGET/$SLOT
- if [ -n "${CTARGET}" ] && [ "${CHOST}" != "${CTARGET}" ] ; then
- cd "${D}/usr/${CHOST}/${CTARGET}/"
- for x in * ; do
- cp -r ${x} ../../${CTARGET}/
- rm -r ${x}
- ln -s ../../${CTARGET}/${x}
- done
-
- cd "${D}/usr/bin"
- for x in * ; do
- [ "${x/${CTARGET}}" != "${x}" ] && mv "${x}" "${x/${CTARGET}-}"
- done
-
- rm -rf "${D}"/usr/share/{locale,doc,man,info}
-
- dodir /usr/include
+ if use uclibc ; then
+ mv *relro* skip/
else
- insinto /usr/include
- doins "${S}/include/libiberty.h"
+ mv *no_rel_ro* 20_* skip/
fi
- cd "${D}/usr"
- find bin -maxdepth 1 -type l -exec rm {} \;
- cp -r bin lib include ${SLOT}/
- rm -r bin lib include
+ mv *ldsoconf* skip/
- # Keep all the real files in /usr/${SLOT}/ and symlink
- # them into our path for
- cd "${D}/usr/${SLOT}/bin"
- dodir /usr/bin
- for x in * ; do
- dosym ../${SLOT}/bin/${x} /usr/bin/${SLOT}-${x}
- done
- if [ -z "${CTARGET}" ] || [ "${CHOST}" == "${CTARGET}" ] ; then
- for d in bin lib include ; do
- cd "${D}/usr/${SLOT}/${d}"
- dodir /usr/${d}
- for x in * ; do
- [ -d "${x}" ] && continue
- dosym ../${SLOT}/${d}/${x} /usr/${d}/${x}
- done
- done
-
- if [ -n "${PROFILE_ARCH}" ] && [ "${PROFILE_ARCH/64}" != "${PROFILE_ARCH}" ] ; then
- dosym ${CHOST} /usr/${CHOST/-/64-}
- for x in `ls ${D}/usr/${CHOST}/bin/` ; do
- [ ! -e "${D}/usr/bin/${CHOST}-${x}" ] && \
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST}-${x}
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST/-/64-}-${x}
- done
- fi
- fi
-
- # Handle documentation
- if ! use build ; then
- if ! has noinfo ${FEATURES} ; then
- cd "${MY_BUILDDIR}"
- make DESTDIR="${D}" install-info || die
- fi
-
- if ! has nodoc ${FEATURES} ; then
- cd "${S}"
- dodoc README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO gprof/bbconv.pl
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- # Install pre-generated manpages .. currently we do not ...
- fi
- else
- rm -rf ${D}/usr/share/man
- fi
+ apply_binutils_update
}