summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-08 22:10:32 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-08 22:10:32 +0000
commita8a7054f08a2dd170481cd3cc27634ee9caa6073 (patch)
tree1b954f305cac3033de158c45224b6f64099270ad /sys-devel
parentVersion bump. Add linux context manager using netlink. (diff)
downloadhistorical-a8a7054f08a2dd170481cd3cc27634ee9caa6073.tar.gz
historical-a8a7054f08a2dd170481cd3cc27634ee9caa6073.tar.bz2
historical-a8a7054f08a2dd170481cd3cc27634ee9caa6073.zip
Initial ebuild.
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/smatch/ChangeLog10
-rw-r--r--sys-devel/smatch/Manifest13
-rw-r--r--sys-devel/smatch/metadata.xml6
-rw-r--r--sys-devel/smatch/smatch-9999.ebuild48
4 files changed, 77 insertions, 0 deletions
diff --git a/sys-devel/smatch/ChangeLog b/sys-devel/smatch/ChangeLog
new file mode 100644
index 000000000000..b0e4f328b427
--- /dev/null
+++ b/sys-devel/smatch/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-devel/smatch
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/ChangeLog,v 1.1 2011/09/08 22:10:32 vapier Exp $
+
+*smatch-9999 (08 Sep 2011)
+
+ 08 Sep 2011; Mike Frysinger <vapier@gentoo.org> +smatch-9999.ebuild,
+ +metadata.xml:
+ Initial ebuild.
+
diff --git a/sys-devel/smatch/Manifest b/sys-devel/smatch/Manifest
new file mode 100644
index 000000000000..a807c33ca43f
--- /dev/null
+++ b/sys-devel/smatch/Manifest
@@ -0,0 +1,13 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+EBUILD smatch-9999.ebuild 1070 RMD160 22ed9db3af3ff3fc686f6f7b715b2eec948eb16d SHA1 67a3a1f57004fae246db5b1bae05597851ddbc0d SHA256 372bc27a42147fe4f6e88e613711a42ad3802f9fff20ffb26f7d90b2ed48cc7d
+MISC ChangeLog 340 RMD160 80facb851f31efa42280499e0b07a27413d80690 SHA1 40d2f2d48fcf372be940c08d10710b6b83ff45f9 SHA256 ca32fea0c9f35761b7c1b188e5c264901fc78a2bea1ce20e4d3cd07925958c84
+MISC metadata.xml 189 RMD160 aab1ee25c01468eb7628b38009b16ecb269acef7 SHA1 3b00989b12c9267dde5f4d8d0092a232c13f9b20 SHA256 f6c4bd31d739964490c3345b792de749704bfa69602dad420a448393f140e820
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iF4EAREIAAYFAk5pPWoACgkQaC/OocHi7Jai+QD5AbeURXOWUAygAyj7gQKTkPKE
+h+G+L4nR+SfFSvErVWIBAIdU6l44s0ZhoblSTAsuTLcbiGOob8OVhzyZ9JalwDsD
+=xCuW
+-----END PGP SIGNATURE-----
diff --git a/sys-devel/smatch/metadata.xml b/sys-devel/smatch/metadata.xml
new file mode 100644
index 000000000000..f8824b4cf31c
--- /dev/null
+++ b/sys-devel/smatch/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kernel-misc</herd>
+ <herd>toolchain</herd>
+</pkgmetadata>
diff --git a/sys-devel/smatch/smatch-9999.ebuild b/sys-devel/smatch/smatch-9999.ebuild
new file mode 100644
index 000000000000..6a2ce508c7b3
--- /dev/null
+++ b/sys-devel/smatch/smatch-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/smatch-9999.ebuild,v 1.1 2011/09/08 22:10:32 vapier Exp $
+
+EAPI="2"
+
+inherit multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://repo.or.cz/smatch.git"
+ inherit git
+fi
+
+DESCRIPTION="static analysis tool for C"
+HOMEPAGE="http://smatch.sourceforge.net/"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI=""
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-db/sqlite"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e '/^CFLAGS =/{s:=:+=:;s:-O2 -finline-functions:${CPPFLAGS}:}' \
+ Makefile || die
+}
+
+src_compile() {
+ emake PREFIX=/usr V=1 CC="$(tc-getCC)" smatch || die
+}
+
+src_install() {
+ # default install target installs a lot of sparse cruft
+ dobin smatch || die
+ insinto /usr/share/smatch/smatch_data
+ doins smatch_data/* || die
+ dodoc FAQ README
+}