summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-07-22 08:09:19 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-07-22 08:09:19 +0000
commit867732920780ab7e9f75931769b9dc87951ed2da (patch)
tree2b5bd81693e7ecc2ece993f60a21a19925bd4450 /sys-devel
parentAdded ebuild for 3.3.4 version of sparc64 compiler. (diff)
downloadhistorical-867732920780ab7e9f75931769b9dc87951ed2da.tar.gz
historical-867732920780ab7e9f75931769b9dc87951ed2da.tar.bz2
historical-867732920780ab7e9f75931769b9dc87951ed2da.zip
Added ebuild for 3.3.4 version of mips64 compiler.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-mips64/ChangeLog8
-rw-r--r--sys-devel/gcc-mips64/files/digest-gcc-mips64-3.3.42
-rw-r--r--sys-devel/gcc-mips64/files/gcc-3.3.4-gentoo-branding.patch18
-rw-r--r--sys-devel/gcc-mips64/gcc-mips64-3.3.4.ebuild124
4 files changed, 151 insertions, 1 deletions
diff --git a/sys-devel/gcc-mips64/ChangeLog b/sys-devel/gcc-mips64/ChangeLog
index 11f4afcfe453..1ddcfa19f6af 100644
--- a/sys-devel/gcc-mips64/ChangeLog
+++ b/sys-devel/gcc-mips64/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc-mips64
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-mips64/ChangeLog,v 1.6 2004/07/02 09:32:53 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-mips64/ChangeLog,v 1.7 2004/07/22 08:09:19 kumba Exp $
+
+*gcc-mips64-3.3.4 (22 Jul 2004)
+
+ 22 Jul 2004; Joshua Kinard <kumba@gentoo.org>
+ +files/gcc-3.3.4-gentoo-branding.patch, +gcc-mips64-3.3.4.ebuild:
+ Added ebuild for 3.3.4 version of mips64 compiler.
02 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
gcc-mips64-3.3.1.ebuild, gcc-mips64-3.3.2.ebuild, gcc-mips64-3.3.3.ebuild:
diff --git a/sys-devel/gcc-mips64/files/digest-gcc-mips64-3.3.4 b/sys-devel/gcc-mips64/files/digest-gcc-mips64-3.3.4
new file mode 100644
index 000000000000..fbbc8d944089
--- /dev/null
+++ b/sys-devel/gcc-mips64/files/digest-gcc-mips64-3.3.4
@@ -0,0 +1,2 @@
+MD5 a1c267b34f05c8660b24251865614d8b gcc-3.3.4.tar.bz2 23331664
+MD5 a9edaf4e17cc4e91db9804caf8ee56c3 gcc-3.3.4-branch-update-20040623.patch.bz2 250809
diff --git a/sys-devel/gcc-mips64/files/gcc-3.3.4-gentoo-branding.patch b/sys-devel/gcc-mips64/files/gcc-3.3.4-gentoo-branding.patch
new file mode 100644
index 000000000000..e2caf9b0218b
--- /dev/null
+++ b/sys-devel/gcc-mips64/files/gcc-3.3.4-gentoo-branding.patch
@@ -0,0 +1,18 @@
+diff -Naurp gcc-3.3.orig/gcc/version.c gcc-3.3/gcc/version.c
+--- gcc-3.3.orig/gcc/version.c 2003-05-13 17:26:03.000000000 -0400
++++ gcc-3.3/gcc/version.c 2003-05-16 14:35:08.000000000 -0400
+@@ -6,7 +6,7 @@
+ please modify this string to indicate that, e.g. by putting your
+ organization's name in parentheses at the end of the string. */
+
+-const char version_string[] = "3.3.4";
++const char version_string[] = "3.3.4 @GENTOO@";
+
+ /* This is the location of the online document giving instructions for
+ reporting bugs. If you distribute a modified version of GCC,
+@@ -15,4 +15,4 @@ const char version_string[] = "3.3";
+ forward us bugs reported to you, if you determine that they are
+ not bugs in your modifications.) */
+
+-const char bug_report_url[] = "<URL:http://gcc.gnu.org/bugs.html>";
++const char bug_report_url[] = "<URL:http://bugs.gentoo.org/>";
diff --git a/sys-devel/gcc-mips64/gcc-mips64-3.3.4.ebuild b/sys-devel/gcc-mips64/gcc-mips64-3.3.4.ebuild
new file mode 100644
index 000000000000..4c0c6d2e412c
--- /dev/null
+++ b/sys-devel/gcc-mips64/gcc-mips64-3.3.4.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-mips64/gcc-mips64-3.3.4.ebuild,v 1.1 2004/07/22 08:09:19 kumba Exp $
+
+
+# Variables
+inherit eutils flag-o-matic
+MYARCH="$(echo ${PN} | cut -d- -f2)"
+TMP_P="${P/-${MYARCH}/}"
+TMP_PN="${PN/-${MYARCH}/}"
+I="/usr"
+S="${WORKDIR}/${P}"
+BRANCH_UPDATE="20040623"
+
+DESCRIPTION="Mips64 Kernel Compiler (Experimental)"
+HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${TMP_P}/${TMP_P}.tar.bz2
+ mirror://gentoo/${TMP_P}-branch-update-${BRANCH_UPDATE}.patch.bz2"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~mips"
+
+DEPEND="virtual/libc
+ >=sys-devel/binutils-2.14.90.0.7
+ >=sys-devel/gcc-config-1.3.1"
+
+RDEPEND="virtual/libc
+ >=sys-devel/gcc-config-1.3.1
+ >=sys-libs/zlib-1.1.4
+ >=sys-apps/texinfo-4.2-r4
+ !build? ( >=sys-libs/ncurses-5.2-r2 )"
+
+
+
+version_patch() {
+ [ ! -f "$1" ] && return 1
+ [ -z "$2" ] && return 1
+
+ sed -e "s:@GENTOO@:$2:g" ${1} > ${T}/${1##*/}
+ epatch ${T}/${1##*/}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ ln -s ${TMP_P} ${P}
+ cd ${S}
+
+ # Patch in Branch update
+ epatch ${WORKDIR}/${TMP_P}-branch-update-${BRANCH_UPDATE}.patch
+
+ # Make gcc's version info specific to Gentoo
+ if [ -z "${PP_VER}" ]; then
+ version_patch ${FILESDIR}/${TMP_P}-gentoo-branding.patch \
+ "${BRANCH_UPDATE} (Gentoo Linux ${PVR})" || die "Failed Branding"
+ fi
+}
+
+src_compile() {
+ cd ${WORKDIR}
+ ln -s ${TMP_P} ${P}
+
+ append-flags "-Dinhibit_libc"
+
+ # Build in a separate build tree
+ mkdir -p ${WORKDIR}/build
+ cd ${WORKDIR}/build
+
+ einfo "Configuring GCC..."
+ if [ "`uname -m | grep 64`" ]; then
+ myconf="${myconf} --host=${MYARCH/64/}-unknown-linux-gnu"
+ fi
+
+ addwrite "/dev/zero"
+ ${S}/configure --prefix=${I} \
+ --disable-shared \
+ --disable-multilib \
+ --target=${MYARCH}-unknown-linux-gnu \
+ --enable-languages=c \
+ --enable-threads=single \
+ ${myconf} || die
+
+ einfo "Building GCC..."
+ S="${WORKDIR}/build" \
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ # Do allow symlinks in ${I}/lib/gcc-lib/${CHOST}/${PV}/include as
+ # this can break the build.
+ for x in cd ${WORKDIR}/build/gcc/include/*
+ do
+ if [ -L ${x} ]
+ then
+ rm -f ${x}
+ fi
+ done
+
+ einfo "Installing GCC..."
+ # Do the 'make install' from the build directory
+ cd ${WORKDIR}/build
+ S="${WORKDIR}/build" \
+ make prefix=${D}${I} \
+ FAKE_ROOT="${D}" \
+ install || die
+
+ cd ${D}${I}/bin
+ ln -s ${MYARCH}-unknown-linux-gnu-gcc gcc64
+ ln -s ${MYARCH}-unknown-linux-gnu-gcc ${MYARCH}-linux-gcc
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "To facilitate an easier kernel build, you may wish to add the following line to your profile:"
+ einfo ""
+ einfo "alias ${MYARCH}make=\"make ARCH=${MYARCH} CROSS_COMPILE=${MYARCH}-unknown-linux-gnu-\""
+ einfo ""
+ einfo "Then to compile a kernel, simply goto the kernel source directory, and issue:"
+ einfo "${MYARCH}make <target>"
+ einfo "Where <target> is one of the usual kernel targets"
+ einfo ""
+ sleep 10
+}