summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-01 07:00:56 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-01 07:00:56 +0000
commitdf76c22ae18336cc51c7febdd23fbb311d63a4e4 (patch)
tree75b3bcdde6a78042c212862ba6bedc85e5a49f33 /sys-devel/patch/patch-2.6.1.ebuild
parentold (diff)
downloadhistorical-df76c22ae18336cc51c7febdd23fbb311d63a4e4.tar.gz
historical-df76c22ae18336cc51c7febdd23fbb311d63a4e4.tar.bz2
historical-df76c22ae18336cc51c7febdd23fbb311d63a4e4.zip
Version bump.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/patch/patch-2.6.1.ebuild')
-rw-r--r--sys-devel/patch/patch-2.6.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/patch/patch-2.6.1.ebuild b/sys-devel/patch/patch-2.6.1.ebuild
new file mode 100644
index 000000000000..690e249cd884
--- /dev/null
+++ b/sys-devel/patch/patch-2.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.6.1.ebuild,v 1.1 2010/01/01 07:00:56 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Utility to apply diffs to files"
+HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
+SRC_URI="mirror://gnu/patch/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="static"
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf=""
+ [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
+ econf ${myconf} || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README
+}