summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-03 14:21:08 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-03 14:21:08 +0000
commitd4002630dafdaaaa8cd77c4178331bd3f0b72320 (patch)
treee501095b5adca72bd563399ca4cb5dcdafa5da8e /sys-devel/m4
parent*** empty log message *** (diff)
downloadhistorical-d4002630dafdaaaa8cd77c4178331bd3f0b72320.tar.gz
historical-d4002630dafdaaaa8cd77c4178331bd3f0b72320.tar.bz2
historical-d4002630dafdaaaa8cd77c4178331bd3f0b72320.zip
*** empty log message ***
Diffstat (limited to 'sys-devel/m4')
-rw-r--r--sys-devel/m4/files/digest1
-rw-r--r--sys-devel/m4/m4-1.4o-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-devel/m4/files/digest b/sys-devel/m4/files/digest
new file mode 100644
index 000000000000..1c079de24c37
--- /dev/null
+++ b/sys-devel/m4/files/digest
@@ -0,0 +1 @@
+MD5 99b833fc3d3aeb6621d9d00661b8abc7 m4-1.4o.tar.gz
diff --git a/sys-devel/m4/m4-1.4o-r1.ebuild b/sys-devel/m4/m4-1.4o-r1.ebuild
new file mode 100644
index 000000000000..65e90e4e1cca
--- /dev/null
+++ b/sys-devel/m4/m4-1.4o-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4o-r1.ebuild,v 1.1 2000/08/03 14:16:17 achim Exp $
+
+P=m4-1.4o
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU macro processor"
+CATEGORY="sys-devel"
+SRC_URI="ftp://ftp.seindal.dk/gnu/${A}"
+HOMEPAGE="http://www.gnu.org/software/m4/m4.html"
+
+src_compile() {
+ ./configure --prefix=/usr --with-modules --with-catgets --host=${CHOST}
+ make
+}
+
+src_install() {
+ into /usr
+ cd ${S}
+ make prefix=${D}/usr install
+ prepman
+ prepinfo
+ insinto /usr/share/m4
+ cd ${S}/examples
+ doins *.m4
+ cd ${S}
+
+ dodoc AUTHORS BACKLOG COPYING NEWS README THANKS TODO
+}
+
+