summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-20 06:06:04 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-20 06:06:04 +0000
commit77ec5b166d13cf7e11c4ece0a2f4a4b4d46bde1e (patch)
treebe0e81a844839d7770fa3dac2a6ea73e5b716738 /sys-devel/kgcc64/kgcc64-3.4.6.ebuild
parentVersion bump (#144405). (diff)
downloadhistorical-77ec5b166d13cf7e11c4ece0a2f4a4b4d46bde1e.tar.gz
historical-77ec5b166d13cf7e11c4ece0a2f4a4b4d46bde1e.tar.bz2
historical-77ec5b166d13cf7e11c4ece0a2f4a4b4d46bde1e.zip
add a wrapper the kernel expects
Package-Manager: portage-2.1.1_pre5-r2
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-3.4.6.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-3.4.6.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/sys-devel/kgcc64/kgcc64-3.4.6.ebuild b/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
index 21987bb340e6..b7022d6c8c99 100644
--- a/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
+++ b/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-3.4.6.ebuild,v 1.3 2006/08/17 15:58:25 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-3.4.6.ebuild,v 1.4 2006/08/20 06:06:04 vapier Exp $
case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
@@ -30,7 +30,7 @@ DEPEND="hppa? ( sys-devel/binutils-hppa64 )
!sys-devel/gcc-mips64"
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
epatch "${GCC_FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
@@ -56,3 +56,13 @@ src_unpack() {
;;
esac
}
+
+src_install() {
+ toolchain_src_install
+
+ local x
+ for x in gcc cpp ; do
+ newbin "${FILESDIR}"/wrapper ${CTARGET%%-*}-linux-gnu-${x}
+ dosed "s:TARGET:${CTARGET}-${x}:" /usr/bin/${CTARGET%%-*}-linux-gnu-${x}
+ done
+}