summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-05 02:08:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-05 02:08:22 +0000
commitc3fd6a692d9178bed1e32e83829c7c59db62df31 (patch)
treeae8e63e36168ea65406db41397bcaa777b229586 /sys-devel/gcc/gcc-3.2.1-r7.ebuild
parentNew revision with experimental gtk2 support. should be kept hard masked for a... (diff)
downloadhistorical-c3fd6a692d9178bed1e32e83829c7c59db62df31.tar.gz
historical-c3fd6a692d9178bed1e32e83829c7c59db62df31.tar.bz2
historical-c3fd6a692d9178bed1e32e83829c7c59db62df31.zip
whitespace cleanup
Diffstat (limited to 'sys-devel/gcc/gcc-3.2.1-r7.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.2.1-r7.ebuild32
1 files changed, 16 insertions, 16 deletions
diff --git a/sys-devel/gcc/gcc-3.2.1-r7.ebuild b/sys-devel/gcc/gcc-3.2.1-r7.ebuild
index c8cb86d6dbc6..ff66268705dd 100644
--- a/sys-devel/gcc/gcc-3.2.1-r7.ebuild
+++ b/sys-devel/gcc/gcc-3.2.1-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.1-r7.ebuild,v 1.5 2003/05/17 00:18:44 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.1-r7.ebuild,v 1.6 2003/09/05 02:01:09 msterret Exp $
IUSE="static nls bootstrap java build"
@@ -65,7 +65,7 @@ if [ -z "${SNAPSHOT}" ]
then
S="${WORKDIR}/${P}"
SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.bz2"
-
+
if [ -n "${PATCH_VER}" ]
then
SRC_URI="${SRC_URI}
@@ -104,7 +104,7 @@ DEPEND="virtual/glibc
>=sys-devel/gcc-config-1.2
!build? ( >=sys-libs/ncurses-5.2-r2
nls? ( sys-devel/gettext ) )"
-
+
RDEPEND="virtual/glibc
>=sys-devel/gcc-config-1.3.0
>=sys-libs/zlib-1.1.4
@@ -121,7 +121,7 @@ src_unpack() {
if [ -z "${SNAPSHOT}" ]
then
unpack ${P}.tar.bz2
-
+
if [ -n "${PATCH_VER}" ]
then
unpack ${P}-patches-${PATCH_VER}.tar.bz2
@@ -183,7 +183,7 @@ src_unpack() {
cp ${x} ${x}.orig
sed -e 's:datadir = @datadir@:datadir = $(FAKE_ROOT)@datadir@:' \
${x}.orig > ${x}
-
+
# Fix --bindir=
cp ${x} ${x}.orig
sed -e 's:bindir = @bindir@:bindir = $(FAKE_ROOT)@bindir@:' \
@@ -199,12 +199,12 @@ src_unpack() {
sed -e 's:gxx_include_dir = @gxx_:gxx_include_dir = $(FAKE_ROOT)@gxx_:' \
-e 's:glibcppinstalldir = @gxx_:glibcppinstalldir = $(FAKE_ROOT)@gxx_:' \
${x}.orig > ${x}
-
+
# Where java security stuff should be installed
cp ${x} ${x}.orig
sed -e 's:secdir = $(libdir)/security:secdir = $(FAKE_ROOT)$(LIBPATH)/security:' \
${x}.orig > ${x}
-
+
rm -f ${x}.orig
done
@@ -220,7 +220,7 @@ src_unpack() {
src_compile() {
local myconf=""
local gcc_lang=""
-
+
if [ -z "`use build`" ]
then
myconf="${myconf} --enable-shared"
@@ -276,7 +276,7 @@ src_compile() {
# Do not make manpages if we do not have perl ...
if [ ! -x /usr/bin/perl ]
- then
+ then
find ${S} -name '*.[17]' -exec touch {} \; || :
fi
@@ -328,9 +328,9 @@ src_install() {
LIBPATH="${LIBPATH}" \
FAKE_ROOT="${D}" \
install || die
-
+
[ -r ${D}${BINPATH}/gcc ] || die "gcc not found in ${D}"
-
+
dodir /lib /usr/bin
dodir /etc/env.d/gcc
echo "PATH=\"${BINPATH}\"" > ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
@@ -342,14 +342,14 @@ src_install() {
# Also set CC and CXX
echo "CC=\"gcc\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
echo "CXX=\"g++\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
-
+
# Install wrappers
# Handled by gcc-config now ...
# exeinto /lib
# doexe ${FILESDIR}/cpp
# exeinto /usr/bin
# doexe ${FILESDIR}/cc
-
+
# This should be invalidated by the linker scripts we have as the latest
# fix for bug #4411
#
@@ -468,7 +468,7 @@ src_install() {
dohtml -r -a css,diff,html,txt,xml docs/html/*
cp -f docs/html/17_intro/[A-Z]* \
${D}/usr/share/doc/${PF}/${DOCDESTTREE}/17_intro/
-
+
if [ -n "`use java`" ]
then
cd ${S}/fastjar
@@ -495,14 +495,14 @@ pkg_postinst() {
# Update libtool linker scripts to reference new gcc version ...
if [ -f ${WORKDIR}/.oldgccversion -a "${ROOT}" = "/" ]
- then
+ then
OLD_GCC_VERSION="`cat ${WORKDIR}/.oldgccversion`"
cp -f ${FILESDIR}/fix_libtool_files.sh ${T}
chmod +x ${T}/fix_libtool_files.sh
${T}/fix_libtool_files.sh ${OLD_GCC_VERSION}
fi
-
+
# Fix ncurses b0rking (if r5 isn't unmerged)
find ${ROOT}/usr/lib/gcc-lib -name '*curses.h' -exec rm -f {} \;
}