summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-12 12:06:25 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-12 12:06:25 +0000
commit43dd3bf0b27087404adecefc010af4d5affa9db4 (patch)
tree7bbec201923073f51c87b6f72e380843d577d574 /sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild
parentDisable broken libpng support wrt #309003. Use correct app-defaults directory. (diff)
downloadhistorical-43dd3bf0b27087404adecefc010af4d5affa9db4.tar.gz
historical-43dd3bf0b27087404adecefc010af4d5affa9db4.tar.bz2
historical-43dd3bf0b27087404adecefc010af4d5affa9db4.zip
Update libstdc++ version check to exclude 64-bits builds on Leopard, dtrace is 32-bits only there.
Package-Manager: portage-2.2.00.15754-prefix/cvs/SunOS i386
Diffstat (limited to 'sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild')
-rw-r--r--sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild
index 357204e7d851..8a0739b22060 100644
--- a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild
+++ b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild,v 1.4 2010/03/09 17:53:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild,v 1.5 2010/03/12 12:06:25 grobian Exp $
EAPI="3"
@@ -18,12 +18,16 @@ SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gcc-${APPLE
fortran? ( mirror://gnu/gcc/gcc-${GCC_VERS}/gcc-fortran-${GCC_VERS}.tar.bz2 )"
LICENSE="GPL-2"
-if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -ge 9 ]] ; then
- LIBSTDCXX_APPLE_VERSION=39
-else
- # pre Leopard has no dtrace, which is required by 37.11 and above
- LIBSTDCXX_APPLE_VERSION=16
-fi
+case ${CHOST} in
+ *-darwin1*|i?86-*darwin9)
+ LIBSTDCXX_APPLE_VERSION=39
+ ;;
+ *)
+ # pre Leopard has no dtrace, which is required by 37.11 and above
+ # Leopard only has 32-bits version of dtrace
+ LIBSTDCXX_APPLE_VERSION=16
+ ;;
+esac
if is_crosscompile; then
SLOT="${CTARGET}-42"