summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-09-25 15:26:09 +0000
committerFabian Groffen <grobian@gentoo.org>2009-09-25 15:26:09 +0000
commit8ff9f2aa06beccea94ddc4b8f6238253cbd2d5ad (patch)
treed3054fc2bf18cb5f27b752e3a74c1ee120705a9d /sys-devel/gcc-apple/files
parentVersion bump. (diff)
downloadhistorical-8ff9f2aa06beccea94ddc4b8f6238253cbd2d5ad.tar.gz
historical-8ff9f2aa06beccea94ddc4b8f6238253cbd2d5ad.tar.bz2
historical-8ff9f2aa06beccea94ddc4b8f6238253cbd2d5ad.zip
Merge back Snow Leopard fixes from Prefix Tree
Package-Manager: portage-2.2.00.14411-prefix/cvs/Darwin powerpc
Diffstat (limited to 'sys-devel/gcc-apple/files')
-rw-r--r--sys-devel/gcc-apple/files/gcc-apple-4.2.1_p5574-darwin10.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/gcc-apple/files/gcc-apple-4.2.1_p5574-darwin10.patch b/sys-devel/gcc-apple/files/gcc-apple-4.2.1_p5574-darwin10.patch
new file mode 100644
index 000000000000..8845c950469b
--- /dev/null
+++ b/sys-devel/gcc-apple/files/gcc-apple-4.2.1_p5574-darwin10.patch
@@ -0,0 +1,26 @@
+On Snow Leopard the perl script fails because the object files aren't
+placed in some .libs dir, it seems as if no libtool is used here at all,
+so fix it by not looking in .libs dir
+
+--- libstdcxx-16/libstdcxx/libstdc++-v3/src/Makefile.am
++++ libstdcxx-16/libstdcxx/libstdc++-v3/src/Makefile.am
+@@ -53,7 +53,7 @@
+ $(libstdc___la_OBJECTS) $(libstdc___la_LIBADD)
+ perl ${glibcxx_srcdir}/scripts/make_exports.pl \
+ libstdc++-symbol.ver \
+- $(libstdc___la_OBJECTS:%.lo=.libs/%.o) \
++ $(libstdc___la_OBJECTS:%.lo=%.o) \
+ `echo $(libstdc___la_LIBADD) | \
+ sed 's,/\([^/.]*\)\.la,/.libs/\1.a,g'` \
+ > $@ || (rm -f $@ ; exit 1)
+--- libstdcxx-16/libstdcxx/libstdc++-v3/src/Makefile.in
++++ libstdcxx-16/libstdcxx/libstdc++-v3/src/Makefile.in
+@@ -689,7 +689,7 @@
+ @ENABLE_SYMVERS_DARWIN_EXPORT_TRUE@@ENABLE_SYMVERS_GNU_FALSE@ $(libstdc___la_OBJECTS) $(libstdc___la_LIBADD)
+ @ENABLE_SYMVERS_DARWIN_EXPORT_TRUE@@ENABLE_SYMVERS_GNU_FALSE@ perl ${glibcxx_srcdir}/scripts/make_exports.pl \
+ @ENABLE_SYMVERS_DARWIN_EXPORT_TRUE@@ENABLE_SYMVERS_GNU_FALSE@ libstdc++-symbol.ver \
+-@ENABLE_SYMVERS_DARWIN_EXPORT_TRUE@@ENABLE_SYMVERS_GNU_FALSE@ $(libstdc___la_OBJECTS:%.lo=.libs/%.o) \
++@ENABLE_SYMVERS_DARWIN_EXPORT_TRUE@@ENABLE_SYMVERS_GNU_FALSE@ $(libstdc___la_OBJECTS:%.lo=%.o) \
+ @ENABLE_SYMVERS_DARWIN_EXPORT_TRUE@@ENABLE_SYMVERS_GNU_FALSE@ `echo $(libstdc___la_LIBADD) | \
+ @ENABLE_SYMVERS_DARWIN_EXPORT_TRUE@@ENABLE_SYMVERS_GNU_FALSE@ sed 's,/\([^/.]*\)\.la,/.libs/\1.a,g'` \
+ @ENABLE_SYMVERS_DARWIN_EXPORT_TRUE@@ENABLE_SYMVERS_GNU_FALSE@ > $@ || (rm -f $@ ; exit 1)