summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-09-13 05:13:37 +0000
committerMike Frysinger <vapier@gentoo.org>2012-09-13 05:13:37 +0000
commit81e22b21dbd8a2b5356b1bde071f3a3a251376fa (patch)
tree238d7d4946ac53966f67a3b166559a2f6270ee98 /sys-devel/crossdev/crossdev-20120913.ebuild
parentinitial aarch64 support (diff)
downloadhistorical-81e22b21dbd8a2b5356b1bde071f3a3a251376fa.tar.gz
historical-81e22b21dbd8a2b5356b1bde071f3a3a251376fa.tar.bz2
historical-81e22b21dbd8a2b5356b1bde071f3a3a251376fa.zip
Version bump.
Package-Manager: portage-2.2.0_alpha120/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/crossdev/crossdev-20120913.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-20120913.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-devel/crossdev/crossdev-20120913.ebuild b/sys-devel/crossdev/crossdev-20120913.ebuild
new file mode 100644
index 000000000000..cf21c724d37c
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20120913.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20120913.ebuild,v 1.1 2012/09/13 05:13:37 vapier Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}