summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2004-01-03 16:14:58 +0000
committerGuy Martin <gmsoft@gentoo.org>2004-01-03 16:14:58 +0000
commit0d42b4d24c1fb3f68c417eba9349f349887e88d2 (patch)
tree9533e4a69f585213025a4fc1ff4a9b58cb4c98cc /sys-devel/binutils-hppa64
parentFirst add of binutils for hppa64. This one will compile 64 bit kernels. (diff)
downloadhistorical-0d42b4d24c1fb3f68c417eba9349f349887e88d2.tar.gz
historical-0d42b4d24c1fb3f68c417eba9349f349887e88d2.tar.bz2
historical-0d42b4d24c1fb3f68c417eba9349f349887e88d2.zip
First add of binutils for hppa64. This one will compile 64 bit kernels.
Diffstat (limited to 'sys-devel/binutils-hppa64')
-rw-r--r--sys-devel/binutils-hppa64/Manifest4
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.7.ebuild106
-rw-r--r--sys-devel/binutils-hppa64/files/digest-binutils-hppa64-2.14.90.0.71
-rw-r--r--sys-devel/binutils-hppa64/metadata.xml8
4 files changed, 117 insertions, 2 deletions
diff --git a/sys-devel/binutils-hppa64/Manifest b/sys-devel/binutils-hppa64/Manifest
index 5b779f1a91e0..22559bc4c83f 100644
--- a/sys-devel/binutils-hppa64/Manifest
+++ b/sys-devel/binutils-hppa64/Manifest
@@ -1,4 +1,4 @@
-MD5 deeb3a36cec4e1103dc102c604593900 ChangeLog 335
+MD5 19be3eecaabcd4eda5cdc2822020c898 ChangeLog 433
MD5 de79bd48762a61610e04f1f9302a49f4 metadata.xml 229
-MD5 cf1645bb86c97c1b72830856d54c75a3 binutils-hppa64-2.14.90.0.7.ebuild 2423
+MD5 293036cae8c73aba9e5b23ef371ce6a6 binutils-hppa64-2.14.90.0.7.ebuild 2432
MD5 c19b60c5d77c4e0779d7820598b3b749 files/digest-binutils-hppa64-2.14.90.0.7 75
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.7.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.7.ebuild
new file mode 100644
index 000000000000..43c9039236a3
--- /dev/null
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.7.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.7.ebuild,v 1.1 2004/01/03 16:14:24 gmsoft Exp $
+
+IUSE="nls bootstrap build"
+
+# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
+# the manpages, but seems this is incorrect ....
+
+inherit eutils libtool flag-o-matic
+
+# Generate borked binaries. Bug #6730
+filter-flags "-fomit-frame-pointer -fssa"
+
+MY_P=${P/-hppa64/}
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Tools necessary to build programs"
+SRC_URI="mirror://kernel/linux/devel/binutils/${MY_P}.tar.bz2
+ mirror://kernel/linux/devel/binutils/test/${MY_P}.tar.bz2"
+HOMEPAGE="http://sources.redhat.com/binutils/"
+
+SLOT="0"
+LICENSE="GPL-2 | LGPL-2"
+KEYWORDS="-* ~hppa"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ !build? ( !bootstrap? ( dev-lang/perl ) )"
+
+TARGET=hppa64-linux
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Libtool is broken (Redhat).
+ for x in ${S}/opcodes/Makefile.{am,in}
+ do
+ cp ${x} ${x}.orig
+ gawk '
+ {
+ if ($0 ~ /LIBADD/)
+ gsub("../bfd/libbfd.la", "-L../bfd/.libs ../bfd/libbfd.la")
+
+ print
+ }' ${x}.orig > ${x}
+ rm -rf ${x}.orig
+ done
+}
+
+src_compile() {
+ local myconf=
+
+ use nls && \
+ myconf="${myconf} --without-included-gettext" || \
+ myconf="${myconf} --disable-nls"
+
+
+ # Fix /usr/lib/libbfd.la
+ elibtoolize --portage
+
+ ./configure --enable-shared \
+ --enable-64-bit-bfd \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ --target=${TARGET} \
+ ${myconf} || die
+
+ make configure-bfd || die
+ make headers -C bfd || die
+ emake tooldir="${ROOT}/usr/bin" \
+ MAKEOVERRIDES="VERSION=${PV}-${TARGET/-linux/}" \
+ all || die
+
+}
+
+src_install() {
+
+ make MAKEOVERRIDES="VERSION=${PV}-${TARGET/-linux/}" \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ # Move shared libs to the standart path
+ mv ${D}/usr/${CHOST}/${TARGET}/lib/lib*-*.so ${D}/usr/lib
+
+ # Remove unused files
+ for i in man info include share ${CHOST} lib/libiberty.a lib/ldscripts
+ do
+ rm -Rf ${D}/usr/${i}
+ done
+
+ # Remove /usr/bin/* to create symlinks
+ rm ${D}/usr/bin/*
+
+ # Create symlinks
+ cd ${D}/usr/bin
+ for i in ${D}/usr/${TARGET}/bin/*
+ do
+ BIN=`basename ${i}`
+ dosym ../${TARGET}/bin/${BIN} /usr/bin/${TARGET}-${BIN}
+ done
+}
diff --git a/sys-devel/binutils-hppa64/files/digest-binutils-hppa64-2.14.90.0.7 b/sys-devel/binutils-hppa64/files/digest-binutils-hppa64-2.14.90.0.7
new file mode 100644
index 000000000000..07f652ab2119
--- /dev/null
+++ b/sys-devel/binutils-hppa64/files/digest-binutils-hppa64-2.14.90.0.7
@@ -0,0 +1 @@
+MD5 b5b1608f7308c487c0f3af8e4592a71a binutils-2.14.90.0.7.tar.bz2 10575077
diff --git a/sys-devel/binutils-hppa64/metadata.xml b/sys-devel/binutils-hppa64/metadata.xml
new file mode 100644
index 000000000000..665bc8a02b23
--- /dev/null
+++ b/sys-devel/binutils-hppa64/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>hppa</herd>
+<longdescription>
+binutils for 64bit kernel on hppa2
+</longdescription>
+</pkgmetadata>