summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-06-23 04:50:50 +0000
committerMike Frysinger <vapier@gentoo.org>2013-06-23 04:50:50 +0000
commit8d142faa755bc3eaee7d077b17c9d1c258f59e2b (patch)
tree74ff428e46d8f4dabe2b7fbad1704700c22b6055 /sys-devel/automake-wrapper/automake-wrapper-9.ebuild
parentfix conditional for 9999 requiring <=gr-3.7 (diff)
downloadhistorical-8d142faa755bc3eaee7d077b17c9d1c258f59e2b.tar.gz
historical-8d142faa755bc3eaee7d077b17c9d1c258f59e2b.tar.bz2
historical-8d142faa755bc3eaee7d077b17c9d1c258f59e2b.zip
Version bump for automake-1.14.
Package-Manager: portage-2.2.0_alpha179/cvs/Linux x86_64 Manifest-Sign-Key: 0xFB7C4156
Diffstat (limited to 'sys-devel/automake-wrapper/automake-wrapper-9.ebuild')
-rw-r--r--sys-devel/automake-wrapper/automake-wrapper-9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/automake-wrapper/automake-wrapper-9.ebuild b/sys-devel/automake-wrapper/automake-wrapper-9.ebuild
new file mode 100644
index 000000000000..e7f344226244
--- /dev/null
+++ b/sys-devel/automake-wrapper/automake-wrapper-9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake-wrapper/automake-wrapper-9.ebuild,v 1.1 2013/06/23 04:50:40 vapier Exp $
+
+DESCRIPTION="wrapper for automake to manage multiple automake versions"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${FILESDIR}"/am-wrapper-${PV}.sh "${S}"/
+ # usr/bin/aclocal: bad substitution -> /bin/sh != POSIX shell
+ if use prefix ; then
+ sed -i -e '1c\#!'"${EPREFIX}"'/bin/sh' "${S}"/am-wrapper-${PV}.sh || die
+ fi
+}
+
+src_install() {
+ newbin "${S}"/am-wrapper-${PV}.sh automake || die
+ dosym automake /usr/bin/aclocal
+
+ keepdir /usr/share/aclocal
+}