summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-03-23 21:51:15 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-03-23 21:51:15 +0000
commit4ebe630c11eabb741f19b5fc7c9fccbccfcc620b (patch)
treee94d471ad7615fb3a53e42f1d0ac7235ed517bc2 /sys-cluster
parentInstall neroexpress, bug 293543 (diff)
downloadhistorical-4ebe630c11eabb741f19b5fc7c9fccbccfcc620b.tar.gz
historical-4ebe630c11eabb741f19b5fc7c9fccbccfcc620b.tar.bz2
historical-4ebe630c11eabb741f19b5fc7c9fccbccfcc620b.zip
add initial version of corosync for testing with clvm
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/corosync/ChangeLog10
-rw-r--r--sys-cluster/corosync/Manifest15
-rw-r--r--sys-cluster/corosync/corosync-1.2.0.ebuild34
-rw-r--r--sys-cluster/corosync/files/corosync.initd23
-rw-r--r--sys-cluster/corosync/metadata.xml17
5 files changed, 99 insertions, 0 deletions
diff --git a/sys-cluster/corosync/ChangeLog b/sys-cluster/corosync/ChangeLog
new file mode 100644
index 000000000000..36f24402e09a
--- /dev/null
+++ b/sys-cluster/corosync/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-cluster/corosync
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.1 2010/03/23 21:51:14 cardoe Exp $
+
+*corosync-1.2.0 (23 Mar 2010)
+
+ 23 Mar 2010; Doug Goldstein <cardoe@gentoo.org> +corosync-1.2.0.ebuild,
+ +files/corosync.initd, +metadata.xml:
+ add initial version of corosync for testing with clvm
+
diff --git a/sys-cluster/corosync/Manifest b/sys-cluster/corosync/Manifest
new file mode 100644
index 000000000000..bcddb8e9c297
--- /dev/null
+++ b/sys-cluster/corosync/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX corosync.initd 597 RMD160 303ac32e97905c1fe3ab140bb592e0ef6c5100d1 SHA1 538ba64c51661cfa1e1f516cc78369bbe452e142 SHA256 eb0c36f0f5c07772b097ec4e8dd34381f048b169b8a628bc990643929371a535
+DIST corosync-1.2.0.tar.gz 662226 RMD160 dcb62de83f3ce21b6e7f2fd50de8d9f4ce64b717 SHA1 c7f75cba87341d17f5badc99eabf40d1e1640a76 SHA256 3cee3be9f747c7031da9eafdffa5e3009513f4ac93ce021a49574e3de1fd93f0
+EBUILD corosync-1.2.0.ebuild 822 RMD160 304c0e3e8b7aec16147fd1ab9ff106e6af6254ca SHA1 e016a94b5b854380cbedde4300a50859095f7c83 SHA256 2e8a853bde7c19ea71bf2252d5f84f5f1ee82fd924b03a8e2e6d56606c160de6
+MISC ChangeLog 415 RMD160 77c28c9087f3512832d9ff84b3a4b05149513f75 SHA1 0dfb99bf5772d21e0c4ccda8d459167c6d62048e SHA256 d5fff01167f31f9c88f48f13ee75d24d0e2082d8d9372a89a2393b5ba8eb5fef
+MISC metadata.xml 430 RMD160 41da7d404cbae21afaaaece54be217657db6c4f8 SHA1 77d671b3e0e72f9a9a5bb70606133c236ab32d42 SHA256 6816d7aa2ffca7c8e57201913fb2723d22c8a1e60b0181491cdaa9de42a56063
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.14 (GNU/Linux)
+
+iEYEARECAAYFAkupN9sACgkQoeSe8B0zEfxS/ACfQtCYAqclkUYuDHm+YQQ9rrTl
+AlAAnjE4ykth6tWgQRjL0gBh9YerfbMe
+=47QZ
+-----END PGP SIGNATURE-----
diff --git a/sys-cluster/corosync/corosync-1.2.0.ebuild b/sys-cluster/corosync/corosync-1.2.0.ebuild
new file mode 100644
index 000000000000..9a14791bbf64
--- /dev/null
+++ b/sys-cluster/corosync/corosync-1.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-1.2.0.ebuild,v 1.1 2010/03/23 21:51:14 cardoe Exp $
+
+EAPI=3
+
+DESCRIPTION="Corosync Cluster Engine"
+HOMEPAGE="http://corosync.org"
+SRC_URI="ftp://ftp:downloads@ftp.corosync.org/downloads/${PN}-1.2.0/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+nss"
+
+RDEPEND="nss? ( dev-libs/nss )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-apps/groff"
+
+src_configure() {
+ econf --disable-rdma $(use_enable nss) || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ rm "${D}"/etc/init.d/corosync
+ newinitd "${FILESDIR}"/corosync.initd corosync
+}
diff --git a/sys-cluster/corosync/files/corosync.initd b/sys-cluster/corosync/files/corosync.initd
new file mode 100644
index 000000000000..ed57796c9ea4
--- /dev/null
+++ b/sys-cluster/corosync/files/corosync.initd
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/files/corosync.initd,v 1.1 2010/03/23 21:51:15 cardoe Exp $
+
+depend() {
+ need net
+ use syslog
+}
+
+start() {
+ ebegin "Starting Corosync Cluster Engine"
+ start-stop-daemon --start -q --exec /usr/sbin/corosync \
+ --pidfile /var/run/corosync.pid --make-pidfile --background \
+ -- -f
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Corosync Cluster Engine"
+ start-stop-daemon --stop -q --pidfile /var/run/corosync.pid
+ eend $?
+}
diff --git a/sys-cluster/corosync/metadata.xml b/sys-cluster/corosync/metadata.xml
new file mode 100644
index 000000000000..d0326fa1becc
--- /dev/null
+++ b/sys-cluster/corosync/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ha-cluster</herd>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ </maintainer>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin Johnson</name>
+ </maintainer>
+ <use>
+ <flag name='nss'>Enable NSS support for cryptography</flag>
+ </use>
+</pkgmetadata>
+