summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-10-20 16:31:02 +0000
committerPeter Volkov <pva@gentoo.org>2009-10-20 16:31:02 +0000
commitc27c3aa3133bb8a8c51ab4b11cb7ffe63ef409f2 (patch)
treea0fcc914edde233d71875d1ad0f4f9699e90c040 /sys-cluster/vzctl/vzctl-9999.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-c27c3aa3133bb8a8c51ab4b11cb7ffe63ef409f2.tar.gz
historical-c27c3aa3133bb8a8c51ab4b11cb7ffe63ef409f2.tar.bz2
historical-c27c3aa3133bb8a8c51ab4b11cb7ffe63ef409f2.zip
amd64/x86 stable, bug #199738. Removed old. Added git ebuild, thank Andrian Nord for suggestion in bug #259433.
Package-Manager: portage-2.1.7.1/cvs/Linux x86_64
Diffstat (limited to 'sys-cluster/vzctl/vzctl-9999.ebuild')
-rw-r--r--sys-cluster/vzctl/vzctl-9999.ebuild105
1 files changed, 105 insertions, 0 deletions
diff --git a/sys-cluster/vzctl/vzctl-9999.ebuild b/sys-cluster/vzctl/vzctl-9999.ebuild
new file mode 100644
index 000000000000..d763dca07da3
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-9999.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.1 2009/10/20 16:31:02 pva Exp $
+
+EAPI="2"
+inherit bash-completion eutils autotools
+
+DESCRIPTION="OpenVZ VE control utility"
+HOMEPAGE="http://openvz.org/"
+
+EGIT_REPO_URI="git://git.openvz.org/pub/vzctl"
+inherit git
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="bash-completion logrotate"
+
+RDEPEND="logrotate? ( app-admin/logrotate )
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota
+ virtual/cron"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Set default OSTEMPLATE on gentoo
+ sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-cron \
+ --enable-udev \
+ $(use_enable bash-completion bashcomp) \
+ $(use_enable logrotate)
+}
+
+src_install() {
+ make DESTDIR="${D}" install install-gentoo || die "make install failed"
+
+ # install the bash-completion script into the right location
+ rm -rf "${D}"/etc/bash_completion.d
+ dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh vzctl
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ ewarn
+ if has_version "<sys-cluster/vzctl-3.0.10"; then
+ ewarn "The location of some vzctl files have changed. Most notably,"
+ ewarn "VE configuration files and samples directory has changed from"
+ ewarn "/etc/vz to /etc/vz/conf. In order to be able to work with"
+ ewarn "your VEs, please do the following:"
+ ewarn
+ ewarn "bash# mv /etc/vz/[0-9]*.conf /etc/vz/conf/"
+ ewarn
+ fi
+
+ local conf_without_OSTEMPLATE
+ for file in \
+ $(find "${ROOT}/etc/vz/conf/" \( -name *.conf -a \! -name 0.conf \)); do
+ if ! grep '^OSTEMPLATE' $file > /dev/null; then
+ conf_without_OSTEMPLATE+=" $file"
+ fi
+ done
+
+ if [[ -n ${conf_without_OSTEMPLATE} ]]; then
+ ewarn
+ ewarn "OSTEMPLATE default was changed from redhat-like to gentoo."
+ ewarn "This means that any VEID.conf files without explicit or correct"
+ ewarn "OSTEMPLATE set will use gentoo scripts instead of redhat."
+ ewarn "Please check the following configs:"
+ for file in ${conf_without_OSTEMPLATE}; do
+ ewarn "${file}"
+ done
+ ewarn
+ fi
+
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ elog "NOTE: Starting with vzctl-3.0.22 the mechanism for choosing the"
+ elog "interfaces to send ARP requests to has been improved (see description"
+ elog "of NEIGHBOUR_DEVS in vz.conf(5) man page). In case VE IP addresses"
+ elog "are not on the same subnet as HN IPs, it may lead to such VEs being"
+ elog "unreachable from the outside world."
+ elog
+ elog "The solution is to set up a device route(s) for the network your VEs are"
+ elog "in. For more details, see http://bugzilla.openvz.org/show_bug.cgi?id=771#c1"
+ elog
+ elog "The old vzctl behavior can be restored by setting NEIGHBOUR_DEVS to any"
+ elog 'value other than "detect" in /etc/vz/vz.conf.'
+}