summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2009-06-13 18:57:53 +0000
committerJustin Bronder <jsbronder@gentoo.org>2009-06-13 18:57:53 +0000
commit0e6ac9c07ee3f086fd793fec92320ebc1bdc3d7d (patch)
treee31fcea23c54fb625ec428a70d910623485f0ad2 /sys-cluster/mpich2/files
parentFix building with glibc-2.10, bug #273503 (diff)
downloadhistorical-0e6ac9c07ee3f086fd793fec92320ebc1bdc3d7d.tar.gz
historical-0e6ac9c07ee3f086fd793fec92320ebc1bdc3d7d.tar.bz2
historical-0e6ac9c07ee3f086fd793fec92320ebc1bdc3d7d.zip
Patch mpd to detect python2.6, #269856
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'sys-cluster/mpich2/files')
-rw-r--r--sys-cluster/mpich2/files/mpich2-1.0.8-py26.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-cluster/mpich2/files/mpich2-1.0.8-py26.patch b/sys-cluster/mpich2/files/mpich2-1.0.8-py26.patch
new file mode 100644
index 000000000000..52e22b8e81be
--- /dev/null
+++ b/sys-cluster/mpich2/files/mpich2-1.0.8-py26.patch
@@ -0,0 +1,29 @@
+diff -urN a/mpich2-1.0.8/src/pm/mpd/configure.in b/mpich2-1.0.8/src/pm/mpd/configure.in
+--- a/mpich2-1.0.8/src/pm/mpd/configure.in 2008-03-08 16:58:08.000000000 -0500
++++ b/mpich2-1.0.8/src/pm/mpd/configure.in 2009-06-13 14:01:38.921760910 -0400
+@@ -81,13 +81,15 @@
+ # echo "GOT PYTHON", $PYTHON
+ if test -z "$PYTHON" ; then ## user did not give us a python; find one
+ dnl Find a Python
++ AC_CHECK_PROG(PY26, python2.6, python2.6)
+ AC_CHECK_PROG(PY25, python2.5, python2.5)
+ AC_CHECK_PROG(PY24, python2.4, python2.4)
+ AC_CHECK_PROG(PY23, python2.3, python2.3)
+ AC_CHECK_PROG(PY22, python2.2, python2.2)
+ AC_CHECK_PROG(PY2, python2, python2)
+ AC_CHECK_PROG(PY, python, python)
+- if test -z "$PY25" -a \
++ if test -z "$PY26" -a \
++ -z "$PY25" -a \
+ -z "$PY24" -a \
+ -z "$PY23" -a \
+ -z "$PY22" -a \
+@@ -96,7 +98,7 @@
+ AC_MSG_WARN([Could not find a python executable in path: $PATH])
+ fi
+ dnl See if one of the pythons has the right modules
+- for pypgm in $PY25 $PY24 $PY23 $PY22 $PY2 $PY ; do \
++ for pypgm in $PY26 $PY25 $PY24 $PY23 $PY22 $PY2 $PY ; do \
+ AC_MSG_CHECKING([that $pypgm is a valid python version])
+ changequote(,)dnl
+ py_version=`$pypgm -c "import sys;print sys.version_info[0]"`