summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-02-25 02:08:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-02-25 02:08:22 +0000
commitd1929ab6b7a087a76a06e64142ef5429792da2fa (patch)
tree17302e5c06091034d7196d8db5481e932e186255 /sys-boot/grub/grub-0.97.ebuild
parentVersion bump (diff)
downloadhistorical-d1929ab6b7a087a76a06e64142ef5429792da2fa.tar.gz
historical-d1929ab6b7a087a76a06e64142ef5429792da2fa.tar.bz2
historical-d1929ab6b7a087a76a06e64142ef5429792da2fa.zip
Fix up all quoting to make repoman happy.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sys-boot/grub/grub-0.97.ebuild')
-rw-r--r--sys-boot/grub/grub-0.97.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-boot/grub/grub-0.97.ebuild b/sys-boot/grub/grub-0.97.ebuild
index 2ca8af3edd43..14ecf1f5830c 100644
--- a/sys-boot/grub/grub-0.97.ebuild
+++ b/sys-boot/grub/grub-0.97.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97.ebuild,v 1.2 2005/08/21 02:24:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97.ebuild,v 1.3 2008/02/25 02:08:22 robbat2 Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -125,11 +125,11 @@ src_install() {
newdoc docs/menu.lst grub.conf.sample
docinto gentoo
- dodoc ${PATCHDIR}/README*
+ dodoc "${PATCHDIR}"/README*
}
pkg_postinst() {
- [[ ${ROOT} != "/" ]] && return 0
+ [[ "${ROOT}" != "/" ]] && return 0
# change menu.lst to grub.conf
if [[ ! -e /boot/grub/grub.conf && -e /boot/grub/menu.lst ]] ; then
@@ -145,7 +145,7 @@ pkg_postinst() {
einfo "Copying files from /lib/grub and /usr/lib/grub to /boot"
for x in /lib/grub/*/* /usr/lib/grub/*/* ; do
- [[ -f ${x} ]] && cp -p ${x} /boot/grub
+ [[ -f "${x}" ]] && cp -p "${x}" /boot/grub
done
[[ -e /boot/grub/grub.conf ]] \