summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-09-14 09:15:35 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-09-14 09:15:35 +0000
commitbe3fbad1af628e92cb9cd590d3ab791870d3d94f (patch)
tree17115591c964e98cbf4c06b0d89169e49d51ce85 /sys-apps
parentFix various issues with update_mtab(), causing 'mount -f' to not update mtab (diff)
downloadhistorical-be3fbad1af628e92cb9cd590d3ab791870d3d94f.tar.gz
historical-be3fbad1af628e92cb9cd590d3ab791870d3d94f.tar.bz2
historical-be3fbad1af628e92cb9cd590d3ab791870d3d94f.zip
Use xstrdup() instead of strdup() to catch out of memory issues.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/ChangeLog6
-rw-r--r--sys-apps/util-linux/Manifest10
-rw-r--r--sys-apps/util-linux/files/util-linux-2.12q-update-mtab-when-moving.patch6
3 files changed, 13 insertions, 9 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index ff136f3ad650..53798cd31668 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.112 2005/09/14 09:07:25 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.113 2005/09/14 09:15:35 azarah Exp $
+
+ 14 Sep 2005; Martin Schlemmer <azarah@gentoo.org>
+ files/util-linux-2.12q-update-mtab-when-moving.patch:
+ Use xstrdup() instead of strdup() to catch out of memory issues.
14 Sep 2005; Martin Schlemmer <azarah@gentoo.org>
+files/util-linux-2.12q-update_mtab-fixes.patch,
diff --git a/sys-apps/util-linux/Manifest b/sys-apps/util-linux/Manifest
index 51f81bfa2957..ece664923207 100644
--- a/sys-apps/util-linux/Manifest
+++ b/sys-apps/util-linux/Manifest
@@ -2,11 +2,11 @@
Hash: SHA1
MD5 5497e9050dc8cde95a0e015edcd59c81 util-linux-2.12i-r1.ebuild 3960
-MD5 4ec337ef027b8e0f3c8ec6ad906821c0 ChangeLog 19263
+MD5 526225599dc07676b3820c84c7bb87b9 ChangeLog 19439
MD5 42a00cdd523f8facea7f10a9f4df86a1 util-linux-2.12q-r2.ebuild 5692
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 40353e338343ed2b6a8f23259c881e49 util-linux-2.12q.ebuild 4785
-MD5 e8c2796a3427138ca8a09a69db357a1f files/util-linux-2.12q-update-mtab-when-moving.patch 1031
+MD5 3708f6eda344a2aa0a4d85d49f69dcee files/util-linux-2.12q-update-mtab-when-moving.patch 1036
MD5 9d4c2454a6506ec913d901830ab06a22 files/util-linux-2.12-only-root-can-remount.patch 294
MD5 519d6757067c4ee7c634c8b60f9abeb3 files/util-linux-2.12p-swapon-check-symlinks.patch 864
MD5 65f42fbf981464410f7d5d84a429e920 files/util-linux-no-kill.patch 642
@@ -40,7 +40,7 @@ MD5 d20405e12353610b3ef8fbc2e1d57f2a files/crypto-loop.initd 1625
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDJ+ih1ZcsMnZjRyIRAsy3AJ0WMToOWLTN8otX1+Mwby5jW8DKrQCgjXOw
-5CHUa8VLiZCzZDT6Jtc3roQ=
-=JeNN
+iD8DBQFDJ+qL1ZcsMnZjRyIRAjdJAKCS8ZuOu/0cS+1KKsAH0Zhv9fwRbwCguMYk
++G+gKy9qUTIrlQQkMZS+nuw=
+=lelx
-----END PGP SIGNATURE-----
diff --git a/sys-apps/util-linux/files/util-linux-2.12q-update-mtab-when-moving.patch b/sys-apps/util-linux/files/util-linux-2.12q-update-mtab-when-moving.patch
index 34927d4d8a7f..aa921f5edc2c 100644
--- a/sys-apps/util-linux/files/util-linux-2.12q-update-mtab-when-moving.patch
+++ b/sys-apps/util-linux/files/util-linux-2.12q-update-mtab-when-moving.patch
@@ -3,8 +3,8 @@ and create a new /bar entry with wrong info.
http://bugs.gentoo.org/104697
---- mount/mount.c
-+++ mount/mount.c
+--- 1/mount/mount.c
++++ 2/mount/mount.c
@@ -665,6 +665,25 @@
else {
mntFILE *mfp;
@@ -17,7 +17,7 @@ http://bugs.gentoo.org/104697
+ const char *olddir = mnt.mnt_fsname;
+ struct mntentchn *oldmc = oldmc = getmntfile(olddir);
+ if (oldmc != NULL) {
-+ mnt.mnt_fsname = strdup(oldmc->m.mnt_fsname);
++ mnt.mnt_fsname = xstrdup(oldmc->m.mnt_fsname);
+ mnt.mnt_type = oldmc->m.mnt_type;
+ mnt.mnt_opts = oldmc->m.mnt_opts;
+ mnt.mnt_freq = oldmc->m.mnt_freq;