summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-04-16 16:58:36 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-04-16 16:58:36 +0000
commit83ec95798503f6f530cba71a9fc1fafb29402c4e (patch)
tree35a6fea16296207dd51dfc1d459add9eceb70270 /sys-apps
parentVersion bumped. (diff)
downloadhistorical-83ec95798503f6f530cba71a9fc1fafb29402c4e.tar.gz
historical-83ec95798503f6f530cba71a9fc1fafb29402c4e.tar.bz2
historical-83ec95798503f6f530cba71a9fc1fafb29402c4e.zip
Version bumped.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xinetd/Manifest4
-rw-r--r--sys-apps/xinetd/files/digest-xinetd-2.3.111
-rw-r--r--sys-apps/xinetd/xinetd-2.3.11.ebuild66
3 files changed, 69 insertions, 2 deletions
diff --git a/sys-apps/xinetd/Manifest b/sys-apps/xinetd/Manifest
index fe00ddb4f505..abb2a08b0418 100644
--- a/sys-apps/xinetd/Manifest
+++ b/sys-apps/xinetd/Manifest
@@ -1,8 +1,8 @@
-MD5 e000abd8453846e7d972527b38d8074f ChangeLog 3004
+MD5 b2333954a9bef1ee54c8f98bfca71022 ChangeLog 3138
MD5 a170af6ab45e1e9d7ac75e42e09523dc xinetd-2.3.7.ebuild 1777
MD5 b0733c48d522654c89d7eff07d491c5a xinetd-2.3.9.ebuild 2032
MD5 cf8b3e9d572b075519ca2fa8d399186a xinetd-2.3.10.ebuild 2124
-MD5 cf8b3e9d572b075519ca2fa8d399186a xinetd-2.3.11.ebuild 2124
+MD5 0f3daba39b402d2c1bd744570cea5f8b xinetd-2.3.11.ebuild 2116
MD5 29e7449ffc4ddaecf18694bf8863804e files/digest-xinetd-2.3.7 64
MD5 606b483b66ae9a568747b4574f4f8e19 files/digest-xinetd-2.3.9 64
MD5 41406ad0e85906703ed6e0def5b42bed files/svc-xinetd 827
diff --git a/sys-apps/xinetd/files/digest-xinetd-2.3.11 b/sys-apps/xinetd/files/digest-xinetd-2.3.11
new file mode 100644
index 000000000000..6d7c4c03f1db
--- /dev/null
+++ b/sys-apps/xinetd/files/digest-xinetd-2.3.11
@@ -0,0 +1 @@
+MD5 37df520fb367beae040daac2b63be5a5 xinetd-2.3.11.tar.gz 289867
diff --git a/sys-apps/xinetd/xinetd-2.3.11.ebuild b/sys-apps/xinetd/xinetd-2.3.11.ebuild
new file mode 100644
index 000000000000..6795b688668b
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.11.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.11.ebuild,v 1.1 2003/04/16 16:58:20 mholzer Exp $
+
+
+#SPV=the directory in files/ to grab the goodies from
+SPV=2.3.9
+
+DESCRIPTION="Xinetd is a powerful replacement for inetd, with advanced features"
+HOMEPAGE="http://www.xinetd.org"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~hppa"
+
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+RDEPEND="${DEPEND} dev-lang/perl"
+
+PROVIDE="virtual/inetd"
+
+src_compile() {
+ local myconf
+ use tcpd && myconf="--with-libwrap"
+
+ # the --with-inet6 is now obsolete. Services will default to IPv4 unless configured otherwise.
+
+ econf --with-loadavg ${myconf}
+
+ # Fix CFLAGS
+ sed "/^CFLAGS/s/+=/=/" < Makefile > makefile
+ mv --force makefile Makefile
+
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ into /usr ; dosbin xinetd/xinetd xinetd/itox
+ exeinto /usr/sbin ; doexe xinetd/xconv.pl
+
+ newman xinetd/xinetd.conf.man xinetd.conf.5
+ newman xinetd/xinetd.log.man xinetd.log.8
+ newman xinetd/xinetd.man xinetd.8
+ doman xinetd/itox.8
+
+ newdoc xinetd/sample.conf xinetd.conf.dist.sample
+ newdoc ${FILESDIR}/${SPV}/xinetd.conf xinetd.conf.default || die
+ dodoc AUDIT INSTALL README TODO CHANGELOG COPYRIGHT
+
+ insinto /etc/xinetd.d ; doins ${FILESDIR}/${SPV}/etc.xinetd.d/* || die
+ exeinto /etc/init.d ; newexe ${FILESDIR}/${SPV}/xinetd.rc6 xinetd || die
+ insinto /etc/conf.d ; newins ${FILESDIR}/${SPV}/xinetd.confd xinetd || die
+ insinto /etc ; doins ${FILESDIR}/${SPV}/xinetd.conf || die
+}
+
+pkg_postinst(){
+ einfo "This ebuild introduces the /etc/xinetd.d includedir with a default"
+ einfo "/etc/xinetd.conf file. Check your config files if you're upgrading from an older"
+ einfo "ebuild version. You should browse /etc/xinetd.conf and the files in /etc/xinetd.d."
+ ewarn
+ ewarn "PLEASE NOTE: Everything is off by default with access restricted to localhost."
+ ewarn
+ einfo "Check /etc/conf.d/xinetd for the startup options."
+ echo ""
+}