summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-13 07:54:53 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-13 07:54:53 +0000
commit7cd1801f627f0e2446905ef4798fa8ec18814c24 (patch)
tree41d9e67ecd9b2f1bf0a17b68caf2cf768ea08c9d /sys-apps
parent-xmms USE flag fixes (diff)
downloadhistorical-7cd1801f627f0e2446905ef4798fa8ec18814c24.tar.gz
historical-7cd1801f627f0e2446905ef4798fa8ec18814c24.tar.bz2
historical-7cd1801f627f0e2446905ef4798fa8ec18814c24.zip
New ebuild with logic for uclibc detection and static use variable
support.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/ChangeLog12
-rw-r--r--sys-apps/busybox/busybox-0.60.5-r1.ebuild66
-rw-r--r--sys-apps/busybox/files/digest-busybox-0.60.5-r11
3 files changed, 76 insertions, 3 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 62766768ae3f..20f334f74191 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,15 +1,21 @@
# ChangeLog for sys-apps/busybox
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.8 2002/12/21 00:35:38 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.9 2003/01/13 07:54:53 raker Exp $
+*busybox-0.60.5-r1 (13 Jan 2003)
+
+ 13 Jan 2003; Nick Hadaway <raker@gentoo.org> busybox-0.60.5-r1.ebuild :
+ Added some logic for detection of uclibc which needs to be tested.
+ Please comment on bug #13517.
+
+*busybox-0.60.5 (20 Dec 2002)
-*busybox-0.60.5.ebuild (20 Dec 2002)
20 Dec 2002; Jon Portnoy <avenj@gentoo.org> busybox-0.60.5.ebuild :
Version bump.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-*busybox-0.50.ebuild (14 July 2002)
+*busybox-0.50 (14 July 2002)
14 Jul 2002; phoen][x <phoenix@gentoo.org> busybox-0.50.ebuild :
Added KEYWORDS, SLOT.
diff --git a/sys-apps/busybox/busybox-0.60.5-r1.ebuild b/sys-apps/busybox/busybox-0.60.5-r1.ebuild
new file mode 100644
index 000000000000..b32f00fdb5b5
--- /dev/null
+++ b/sys-apps/busybox/busybox-0.60.5-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r1.ebuild,v 1.1 2003/01/13 07:54:53 raker Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Utilities for rescue and embedded systems"
+SRC_URI="http://www.busybox.net/downloads/${P}.tar.gz"
+HOMEPAGE="http://www.busybox.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="static"
+
+DEPEND="virtual/glibc"
+RDEPEND="!static? ${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cp ${FILESDIR}/Config.h-${PV}-cd ${S}/Config.h
+ # I did not include the msh patch since I don't know if it will
+ # break stuff, I compile ash anyway, and it's in CVS
+}
+
+src_compile() {
+ local myconf
+ use static && myconf="${myconf} DOSTATIC=true"
+ INSTLIBC="`best_version virtual/glibc`"
+ UCLIBC="dev-libs/uclibc"
+ if [ ${INSTLIBC:0:${#UCLIBC}} = $UCLIBC ]; then
+ myconf="${myconf} \
+ CC=/usr/i386-linux-uclibc/bin/i386-uclibc-gcc \
+ USE_SYSTEM_PWD=false"
+ unset CFLAGS
+ fi
+ emake ${myconf} || die
+}
+
+src_install() {
+ into /
+ dobin busybox
+ into /usr
+ dodoc AUTHORS Changelog LICENSE README TODO
+
+ cd docs
+ doman *.1
+ docinto txt
+ dodoc *.txt
+ docinto pod
+ dodoc *.pod
+ dohtml *.html
+ dohtml *.sgml
+
+ cd ../scripts
+ docinto scripts
+ dodoc inittab
+ dodoc depmod.pl
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Edit /usr/portage/sys-apps/busybox/files/Config.h and"
+ einfo "re-emerge if you need to add/remove functionality in "
+ einfo "BusyBox."
+ einfo ""
+}
diff --git a/sys-apps/busybox/files/digest-busybox-0.60.5-r1 b/sys-apps/busybox/files/digest-busybox-0.60.5-r1
new file mode 100644
index 000000000000..b6977779e16d
--- /dev/null
+++ b/sys-apps/busybox/files/digest-busybox-0.60.5-r1
@@ -0,0 +1 @@
+MD5 1dfe09e0b1db1aab2a5f7d03e47640a6 busybox-0.60.5.tar.gz 785216