summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-06 20:57:49 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-06 20:57:49 +0000
commit4672ac495c7110103017ece0f33638b9308b3a1d (patch)
treed36f9fc7321ffe977150120af4bf4bf24fba0844 /sys-apps
parentfix compiling under NPTL ... (diff)
downloadhistorical-4672ac495c7110103017ece0f33638b9308b3a1d.tar.gz
historical-4672ac495c7110103017ece0f33638b9308b3a1d.tar.bz2
historical-4672ac495c7110103017ece0f33638b9308b3a1d.zip
add patch for kernel-2.5
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/eject/ChangeLog5
-rw-r--r--sys-apps/eject/eject-2.0.12-r1.ebuild11
-rw-r--r--sys-apps/eject/files/eject-2.0.12-kernel25-support.patch17
3 files changed, 29 insertions, 4 deletions
diff --git a/sys-apps/eject/ChangeLog b/sys-apps/eject/ChangeLog
index cc0a11e794da..f222c82ad863 100644
--- a/sys-apps/eject/ChangeLog
+++ b/sys-apps/eject/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/eject
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/eject/ChangeLog,v 1.11 2003/03/03 10:52:31 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/eject/ChangeLog,v 1.12 2003/03/06 20:57:49 azarah Exp $
+
+ 06 Mar 2003; Martin Schlemmer <azarah@gentoo.org> eject-2.0.12-r1.ebuild :
+ Get eject to build with kernel-2.5.x.
03 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> :
This update should not be classified as a security update. The advisory says that eject is only
diff --git a/sys-apps/eject/eject-2.0.12-r1.ebuild b/sys-apps/eject/eject-2.0.12-r1.ebuild
index 0e24679a8c68..099ed1ed91b1 100644
--- a/sys-apps/eject/eject-2.0.12-r1.ebuild
+++ b/sys-apps/eject/eject-2.0.12-r1.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/eject/eject-2.0.12-r1.ebuild,v 1.1 2003/03/03 10:06:58 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/eject/eject-2.0.12-r1.ebuild,v 1.2 2003/03/06 20:57:49 azarah Exp $
inherit eutils
-S=${WORKDIR}/${P}
+S="${WORKDIR}/${P}"
DESCRIPTION="A command to eject a disc from the CD-ROM drive"
SRC_URI="http://www.ibiblio.org/pub/Linux/utils/disk-management/${P}.tar.gz
http://www.pobox.com/~tranter/${P}.tar.gz"
HOMEPAGE="http://eject.sourceforge.net/"
+
KEYWORDS="x86 ppc sparc alpha"
SLOT="0"
LICENSE="GPL-2"
@@ -19,7 +20,11 @@ src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.security.patch
+ epatch ${FILESDIR}/${P}-gentoo.security.patch
+
+ # Get this puppy working with kernel 2.5.x
+ # <azarah@gentoo.org> (06 March 2003)
+ epatch ${FILESDIR}/${P}-kernel25-support.patch
}
src_install() {
diff --git a/sys-apps/eject/files/eject-2.0.12-kernel25-support.patch b/sys-apps/eject/files/eject-2.0.12-kernel25-support.patch
new file mode 100644
index 000000000000..f443260f68fb
--- /dev/null
+++ b/sys-apps/eject/files/eject-2.0.12-kernel25-support.patch
@@ -0,0 +1,17 @@
+--- eject-2.0.12/eject.c.orig 2003-03-06 22:38:27.000000000 +0200
++++ eject-2.0.12/eject.c 2003-03-06 22:41:07.000000000 +0200
+@@ -56,7 +56,13 @@
+ #include <sys/ioctl.h>
+ #include <sys/wait.h>
+ #include <sys/mtio.h>
+-#include <linux/types.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,5,0) /* 2.5.x breaks things again */
++# define __KERNEL__
++# include <linux/types.h>
++# undef __KERNEL__
++#else
++# include <linux/types.h>
++#endif
+ #include <linux/cdrom.h>
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2,1,0)
+ #include <linux/ucdrom.h>